]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- note about lb locale in deluge.spec
[packages/glibc.git] / glibc.spec
index ce3b84f53b9d09de739dc99fa929adab13b7425f..222a162ffe26bbe2831cdc10e10d08a24e3fd601 100644 (file)
@@ -1,3 +1,9 @@
+# TODO:
+# - look at locale fixes/updates in bugzilla
+# - no more chicken-egg problem (postshell is no more dynamically linked with libc), remove SONAME symlinks? see files section.
+# [OLD]
+# - localedb-gen man pages(?)
+# - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
 # min_kernel   (default is 2.6.12)
 %bcond_without localedb        # don't build localedb-all (is time consuming)
 %bcond_with    cross           # build using crossgcc (without libgcc_eh)
 #
-# TODO:
-# - look at locale fixes/updates in bugzilla
-# - no more chicken-egg problem (postshell is no more dynamically linked with libc), remove SONAME symlinks? see files section.
-# [OLD]
-# - localedb-gen man pages(?)
-# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
-#   debug/backtrace-tst(SEGV)  fail on alpha
 %{!?min_kernel:%global         min_kernel      2.6.12}
 
 %ifarch sparc64
 %undefine      with_memusage
 %endif
 
+%define                ports_version   2.13
 %define                llh_version     7:2.6.20.4-1
 
 Summary:       GNU libc
@@ -32,15 +32,15 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       2.10.1
-Release:       14
+Version:       2.14
+Release:       16
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: ee71dedf724dc775e4efec9b823ed3be
-Source1:       ftp://sources.redhat.com/pub/glibc/releases/%{name}-libidn-%{version}.tar.bz2
-# Source1-md5: 8ef88560ec608d5923ee05eb5f0e15ea
+Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
+# Source0-md5: 8f5f6b09f98d17c630819b4845e31e65
+Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.bz2
+# Source1-md5: 483f37cfdd619e81d8ca9e9d713944b5
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -49,10 +49,12 @@ Source5:    http://qboosh.pl/man/%{name}-man-pages.tar.bz2
 # Source5-md5: f464eadf3cf06761f65639e44a179e6b
 Source6:       %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
+Source8:       nscd.upstart
+Patch0:                %{name}-restore-rpc+nis.patch
 Patch1:                %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-crypt-blowfish.patch
-Patch4:                %{name}-git.patch
+Patch4:                %{name}-sotruss-sh.patch
 Patch5:                %{name}-sparc-softfp-gcc.patch
 Patch6:                %{name}-paths.patch
 Patch7:                %{name}-no_opt_override.patch
@@ -72,6 +74,19 @@ Patch22:     %{name}-with-stroke.patch
 Patch23:       %{name}-pt_pax.patch
 Patch25:       %{name}-cv_gnu89_inline.patch
 Patch26:       %{name}-posix-sh.patch
+Patch27:       %{name}-i686.patch
+Patch29:       %{name}-arm-alignment-fix.patch
+Patch30:       %{name}-bug-12492.patch
+Patch31:       %{name}-origin.patch
+Patch32:       %{name}-Os-fail-workaround.patch
+Patch33:       0020_all_glibc-tweak-rfc1918-lookup.patch
+Patch35:       0055_all_glibc-2.12-static-shared-getpagesize.patch
+Patch37:       0061_all_glibc-2.13-static-memset.patch
+Patch38:       1055_all_glibc-resolv-dynamic.patch
+Patch39:       %{name}-git.patch
+Patch40:       %{name}-bad-fix.patch
+Patch41:       %{name}-bug-12684.patch
+Patch42:       %{name}-revert-dso-breakout.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -83,7 +98,7 @@ BuildRequires:        binutils >= 2:2.15.90.0.3
 %endif
 %{!?with_cross:BuildRequires:  dietlibc-static}
 BuildRequires: gawk
-BuildRequires: gcc >= 5:3.4
+BuildRequires: gcc >= 6:4.3
 %{?with_memusage:BuildRequires:        gd-devel >= 2.0.1}
 BuildRequires: gettext-devel >= 0.10.36
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
@@ -91,8 +106,7 @@ BuildRequires:       linux-libc-headers >= %{llh_version}
 BuildRequires: nss-devel >= 1:3.12.3
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.3-0.20030610.28
-BuildRequires: rpm-perlprov
-BuildRequires: rpmbuild(macros) >= 1.413
+BuildRequires: rpmbuild(macros) >= 1.567
 BuildRequires: sed >= 4.0.5
 BuildRequires: texinfo
 Requires(post):        ldconfig = %{epoch}:%{version}-%{release}
@@ -108,8 +122,8 @@ Obsoletes:  glibc64
 %endif
 Suggests:      localedb
 Suggests:      tzdata
-Conflicts:     SysVinit < 2.86-11
 Conflicts:     %{name}-misc < %{epoch}:%{version}-%{release}
+Conflicts:     SysVinit < 2.86-11
 Conflicts:     kernel < %{min_kernel}
 Conflicts:     kernel24
 Conflicts:     kernel24-smp
@@ -118,7 +132,7 @@ Conflicts:  man-pages < 1.43
 Conflicts:     poldek < 0.18.8-5
 Conflicts:     rc-scripts < 0.3.1-13
 Conflicts:     rpm < 4.1
-ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} ia64 alpha s390 s390x sparc sparc64 sparcv9 ppc ppc64
+ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} ia64 alpha s390 s390x sparc sparc64 sparcv9 ppc ppc64 armv5tel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # avoid -s here (ld.so must not be stripped to allow any program debugging)
@@ -139,6 +153,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{expand:%%define      __cc    %{__cc} -m32}
 %endif
 
+# Architectures supported in glibc-ports
+%define                ports_arch              alpha %{arm}
+
 # Xen-friendly glibc
 %define                specflags_ia32          -mno-tls-direct-seg-refs
 %define                specflags_x86_64        -mno-tls-direct-seg-refs -fasynchronous-unwind-tables
@@ -282,6 +299,7 @@ Summary:    glibc library for crypt(3)
 Summary(pl.UTF-8):     Biblioteka glibc z funkcją crypt(3)
 Group:         Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      %{name}-libcrypt(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 Provides:      crypt(blowfish)
 
 %description libcrypt
@@ -322,7 +340,7 @@ crée aussi /etc/ld.so.cache qui accélčre le chargement des programmes
 utilisant les bibliothčques partagées.
 
 %description -n ldconfig -l pl.UTF-8
-ldconfig testuje uruchominy system i tworzy dowiązania symboliczne,
+ldconfig testuje uruchomiony system i tworzy dowiązania symboliczne,
 które są następnie używane do poprawnego ładowania bibliotek
 dynamicznych. Program ten tworzy plik /etc/ld.so.cache, który
 przyśpiesza ładowanie programów korzystających z bibliotek
@@ -347,7 +365,12 @@ Summary(uk.UTF-8): Додаткові бібліотеки, потрібні д
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      %{name}-devel-utils = %{epoch}:%{version}-%{release}
+Requires:      %{name}-libcrypt(%{_target_cpu}) = %{epoch}:%{version}-%{release}
+%if "%{_lib}" == "lib64"
+Requires:      %{name}-headers(64bit) = %{epoch}:%{version}-%{release}
+%else
 Requires:      %{name}-headers = %{epoch}:%{version}-%{release}
+%endif
 Provides:      %{name}-devel(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 Obsoletes:     libiconv-devel
 
@@ -408,6 +431,9 @@ Summary:    Header files for development using standard C libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia programów przy użyciu standardowych bibliotek C
 Group:         Development/Building
 Provides:      %{name}-headers(%{_target_cpu}) = %{epoch}:%{version}-%{release}
+%if "%{_lib}" == "lib64"
+Provides:      %{name}-headers(64bit) = %{epoch}:%{version}-%{release}
+%endif
 %ifarch %{x8664}
 # If both -m32 and -m64 is to be supported on x86_64, x86_64 package
 # have to be installed, not ix86 one.
@@ -558,7 +584,7 @@ Requires(pre):      /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 %{?with_selinux:Requires:      libselinux >= 1.18}
-Requires:      rc-scripts >= 0.2.0
+Requires:      rc-scripts >= 0.4.3.0
 Provides:      group(nscd)
 Provides:      user(nscd)
 
@@ -674,9 +700,9 @@ czyli z zestawu funkcji z tej biblioteki, które umożliwiają konwersję
 kodowania danych z poziomu dowolnego programu.
 
 %package static
-Summary:       Static libraries
+Summary:       Static GNU libc libraries
 Summary(es.UTF-8):     Bibliotecas estáticas
-Summary(pl.UTF-8):     Biblioteki statyczne
+Summary(pl.UTF-8):     Biblioteki statyczne GNU libc
 Summary(ru.UTF-8):     Статические библиотеки glibc
 Summary(uk.UTF-8):     Статичні бібліотеки glibc
 Group:         Development/Libraries
@@ -873,27 +899,24 @@ datos NIS+.
 Moduł glibc NSS (Name Service Switch) dostępu do baz danych NIS+.
 
 %package memusage
-Summary:       A toy
-Summary(es.UTF-8):     Un juguete
-Summary(pl.UTF-8):     Zabawka
-Group:         Applications
+Summary:       Memory usage profiler
+Summary(pl.UTF-8):     Narzędzie do profilowania zużycia pamięci
+Group:         Development/Tools
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description memusage
-A toy.
-
-%description memusage -l es.UTF-8
-Un juguete.
+Memory usage profiler.
 
 %description memusage -l pl.UTF-8
-Zabawka.
+Narzędzie do profilowania zużycia pamięci.
 
 %prep
 %setup -q -a1
-ln -s glibc-libidn-%{version} libidn
-#%patch1 -p1
+mv %{name}-ports-%{ports_version} ports
+%patch0 -p1
+%patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%patch3 -p0
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
@@ -912,8 +935,26 @@ ln -s glibc-libidn-%{version} libidn
 %{?with_cross:%patch21 -p1}
 %patch22 -p1
 %patch23 -p0
+
 %patch25 -p1
 %patch26 -p1
+%patch27 -p1
+%patch29 -p1
+%patch30 -p0
+%patch31 -p1
+%patch32 -p1
+%patch33 -p1
+
+%patch35 -p1
+
+%patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
+# revert broken fix
+%patch41 -p1 -R
+# revert broken fix
+%patch42 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -921,8 +962,8 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 chmod +x scripts/cpp
 
 # i786 (aka pentium4) hack
-cd nptl/sysdeps/i386 && ln -s i686 i786 && cd -
-cd nptl/sysdeps/unix/sysv/linux/i386 && ln -s i686 i786 && cd -
+ln -s i686 nptl/sysdeps/i386/i786
+ln -s i686 nptl/sysdeps/unix/sysv/linux/i386/i786
 
 %build
 # glibc has its own way to remove PLT relocations. / H. J. Lu.
@@ -938,17 +979,30 @@ cd builddir
 %ifarch sparc64
 CC="%{__cc} -m64 -mcpu=ultrasparc -mvis -fcall-used-g6"
 %endif
+
+AddOns=nptl,libidn
+%ifarch %{ports_arch}
+AddOns=$AddOns,ports
+%endif
+
+# force ld bfd (instead of gold)
+install -d alt-tools
+ln -sf %{_bindir}/ld.bfd alt-tools/ld
+PATH=$(pwd)/alt-tools:$PATH; export PATH
+
 AWK="gawk" \
 ../%configure \
+       --with-binutils=$(pwd)/alt-tools \
        --enable-kernel="%{min_kernel}" \
        --enable-omitfp \
        --with-headers=%{_includedir} \
        --with%{!?with_selinux:out}-selinux \
        --with-tls \
-       --enable-add-ons=nptl,libidn \
+       --enable-add-ons=$AddOns \
 %if "%{pld_release}" != "ti"
        --enable-nss-crypt \
 %endif
+       --enable-experimental-malloc \
        --enable-stackguard-randomization \
        --enable-hidden-plt \
        --enable-bind-now \
@@ -985,7 +1039,7 @@ diet ${CC#*ccache } %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/{default,logrotate.d,rc.d/init.d,sysconfig},%{_mandir}/man{3,8},/var/log,/var/{lib,run}/nscd}
+install -d $RPM_BUILD_ROOT{/etc/{default,logrotate.d,rc.d/init.d,sysconfig,init},%{_mandir}/man{3,8},/var/log,/var/{lib,run}/nscd,/var/cache/ldconfig}
 
 cd builddir
 env LANGUAGE=C LC_ALL=C \
@@ -1004,16 +1058,16 @@ PICFILES="libc_pic.a libc.map
        math/libm_pic.a libm.map
        resolv/libresolv_pic.a"
 
-install $PICFILES                              $RPM_BUILD_ROOT%{_libdir}
-install elf/soinit.os                          $RPM_BUILD_ROOT%{_libdir}/soinit.o
-install elf/sofini.os                          $RPM_BUILD_ROOT%{_libdir}/sofini.o
+install -p $PICFILES                           $RPM_BUILD_ROOT%{_libdir}
+install -p elf/soinit.os                               $RPM_BUILD_ROOT%{_libdir}/soinit.o
+install -p elf/sofini.os                               $RPM_BUILD_ROOT%{_libdir}/sofini.o
 
 # Include %{_libdir}/gconv/gconv-modules.cache
-./iconv/iconvconfig --nostdlib --prefix=$RPM_BUILD_ROOT %{_libdir}/gconv -o $RPM_BUILD_ROOT%{_libdir}/gconv/gconv-modules.cache
+LD_PRELOAD=$(pwd)/libc.so.6 ./iconv/iconvconfig --nostdlib --prefix=$RPM_BUILD_ROOT %{_libdir}/gconv -o $RPM_BUILD_ROOT%{_libdir}/gconv/gconv-modules.cache
 cd ..
 
 %if %{without cross}
-install glibc-postinst                         $RPM_BUILD_ROOT/sbin
+install -p glibc-postinst                              $RPM_BUILD_ROOT/sbin
 %endif
 
 %{?with_memusage:mv -f $RPM_BUILD_ROOT/%{_lib}/libmemusage.so $RPM_BUILD_ROOT%{_libdir}}
@@ -1035,18 +1089,21 @@ done
 # linking nss modules directly is not supported
 rm -f $RPM_BUILD_ROOT%{_libdir}/libnss_*.so
 
-install %{SOURCE2}             $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
-install %{SOURCE3}             $RPM_BUILD_ROOT/etc/sysconfig/nscd
-install %{SOURCE4}             $RPM_BUILD_ROOT/etc/logrotate.d/nscd
-install nscd/nscd.conf         $RPM_BUILD_ROOT%{_sysconfdir}
+install -p %{SOURCE2}          $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
+cp -p %{SOURCE8}               $RPM_BUILD_ROOT/etc/init/nscd.conf
+cp -a %{SOURCE3}               $RPM_BUILD_ROOT/etc/sysconfig/nscd
+cp -a %{SOURCE4}               $RPM_BUILD_ROOT/etc/logrotate.d/nscd
+cp -a nscd/nscd.conf           $RPM_BUILD_ROOT%{_sysconfdir}
+cp -a posix/gai.conf           $RPM_BUILD_ROOT%{_sysconfdir}
+cp -a nis/nss $RPM_BUILD_ROOT/etc/default/nss
 sed -e 's#\([ \t]\)db\([ \t]\)#\1#g' nss/nsswitch.conf > $RPM_BUILD_ROOT%{_sysconfdir}/nsswitch.conf
-install posix/gai.conf         $RPM_BUILD_ROOT%{_sysconfdir}
-install nis/nss $RPM_BUILD_ROOT/etc/default/nss
 
 bzip2 -dc %{SOURCE5} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-> $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.cache
+> $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.cache
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
 echo 'include ld.so.conf.d/*.conf' > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf
+: > $RPM_BUILD_ROOT/var/cache/ldconfig/aux-cache
+
 rm -f $RPM_BUILD_ROOT%{_mandir}/hu/man7/man.7
 
 # doesn't fit with out tzdata concept and configure.in is stupid assuming bash
@@ -1055,18 +1112,18 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/tzselect
 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/tzselect.8*
 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/tzselect.8*
 
-:> $RPM_BUILD_ROOT/var/log/nscd
-:> $RPM_BUILD_ROOT/var/lib/nscd/passwd
-:> $RPM_BUILD_ROOT/var/lib/nscd/group
-:> $RPM_BUILD_ROOT/var/lib/nscd/hosts
+: > $RPM_BUILD_ROOT/var/log/nscd
+: > $RPM_BUILD_ROOT/var/lib/nscd/passwd
+: > $RPM_BUILD_ROOT/var/lib/nscd/group
+: > $RPM_BUILD_ROOT/var/lib/nscd/hosts
 
 rm -rf documentation
 install -d documentation
 
 for f in ANNOUNCE ChangeLog DESIGN-{barrier,condvar,rwlock,sem}.txt TODO{,-kernel,-testing}; do
-       cp -f nptl/$f documentation/$f.nptl
+       cp -af nptl/$f documentation/$f.nptl
 done
-cp -f crypt/README.ufc-crypt ChangeLog* documentation
+cp -af crypt/README.ufc-crypt ChangeLog* documentation
 
 # Collect locale files and mark them with %%lang()
 echo '%defattr(644,root,root,755)' > glibc.lang
@@ -1082,26 +1139,43 @@ done
 # Languages not supported by glibc locales, but usable via $LANGUAGE:
 #   ang - Old English (gtk+, gnome)
 #   ca@valencia (gtk+, gnome; as ca_ES@valencia in FileZilla; locale exists in Debian)
+#   en@shaw - English with Shavian alphabet (gnome)
+#   la - Latin
 #   tlh - Klingon (bzflag)
 # and variants:
 #   sr@ije (use LANGUAGE=sr_ME@ije/sr_RS@ije) (gnome)
 #
 # To be added when they become supported by glibc:
-#   az_IR (gtk+)
-#   co (vlc)
-#   dv (iso-codes)
-#   gn (gn_BR in gnome, maybe gn_PY)
-#   la (deluge, gnome, others; patch needed, won't be officially supported)
-#   my (gaim)
-#   bal (newt)
-#   haw (iso-codes)
+#   az_IR (gtk+2)
+#   bal (newt,pessulus)
+#   bem (alacarte)
+#   co  (vlc)
+#   fil (stellarium)
+#   frp (xfce, lxlauncher)
+#   gn  (gn_BR in gnome, maybe gn_PY)
+#   haw (iso-codes, stellarium)
+#   hrx (stellarium)
 #   ilo (kudzu)
+#   io  (gtk+2, gnome, alacarte)
+#   jv  (gmpc, avant-window-navigator, kdesudo)
 #   kok (iso-codes)
+#   lb  (geany,miro,deluge)
 #   man (ccsm; incorrectly named md)
+#   mhr (pidgin)
 #   mus (bluez-gnome)
-#   sco (gnomad2)
+#   pms (deluge)
+#   sco (gnomad2, picard, stellarium)
+#   swg (sim)
 #   syr (iso-codes)
-#   ven (kalarm)
+#   tet (vlc)
+#
+# To be removed (after fixing packages still using it):
+#   sr@Latn (use sr@latin instead)
+#
+# To be clarified:
+#   sr@ije or sr@ijekavian? (currently sr@ije is supported)
+#   sr@ijelatin or sr@ijekavianlatin? (currently not supported)
+#   sr@ijekavian and sr@ijekavianlatin exist in: akonadi-googledata, amarok, k3b, konversation, ktorrent, wesnoth
 #
 # bn is used for bn_BD or bn_IN? Assume bn_IN as nothing for bn_BD appeared
 # till now.
@@ -1110,27 +1184,27 @@ done
 #   be ca cs da de el en_GB es fi fr gl hr hu it ja ko nb nl pl pt_BR ru rw sk
 #   sv tr zh_CN zh_TW
 #
-for i in aa aa@saaho af am an ang ar ar_TN as ast az be@alternative be@latin \
-       bg bn bn_IN br bs byn ca@valencia crh csb cy de_AT de_CH dz en \
-       en@boldquot en@quot en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
+for i in aa aa@saaho af am an ang ar ar_TN as ast az be@latin be@tarask \
+       bg bn bn_IN br bs byn ca@valencia ckb crh csb cy de_AT de_CH dv dz en \
+       en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
-       hi hne hsb hy ia id ig ik is it_CH iu ka kk kl km kn ks ku kw ky lg li \
-       lo lt lv mai mg mi mk ml mn mr ms mt nds ne nl_BE nn nr nso oc om or \
-       pa pap ps pt rm ro sa sc se si sid sl so sq sr sr@Latn sr@ije sr@latin \
-       ss st sw ta te tg th ti tig tk tl tlh tn ts tt ug uk ur uz uz@cyrillic \
-       ve vi wa wal wo xh yi yo zh_HK zu; do
+       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn ks ku kw ky la \
+       lg li lo lt lv mai mg mi mk ml mn mr ms mt my nds ne nl_BE nn nr nso \
+       oc om or pa pap ps pt ps rm ro sa sc se si sid sl so sq sr sr@Latn tl \
+       sr@ije sr@latin ss st sw ta te tg th ti tig tk tl tlh tn ts tt ug uk \
+       ur uz uz@cyrillic ve vi wa wal wo xh yi yo zh_HK zu; do
        if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES ]; then
                install -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES
                # use lang() tags with ll_CC@variant (stripping charset and @quot|@boldquot)
-               lang=`echo $i | sed -e 's/@quot\>\|@boldquot\>//'`
+               lang=$(echo $i | sed -e 's/@quot\>\|@boldquot\>//')
                echo "%lang($lang) %{_datadir}/locale/$i" >> glibc.lang
        fi
 done
 
 # LC_TIME category, used for localized date formats (at least by coreutils)
-for i in af be bg ca cs da de el es et eu fi fr ga gl hu id it ja ko lt ms nb nl pl \
-       pt pt_BR ru rw sk sl sv tr uk vi zh_CN zh_TW; do
+for i in af be bg ca cs da de el en eo es et eu fi fr ga gl hu id it ja kk ko lg lt \
+       ms nb nl pl pt pt_BR ro ru rw sk sl sv tr uk vi zh_CN zh_TW; do
        if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i ]; then
                echo "%lang($lang) %{_datadir}/locale/$i" >> glibc.lang
        fi
@@ -1143,15 +1217,12 @@ chmod +x $RPM_BUILD_ROOT%{_bindir}/localedb-gen
 install localedata/SUPPORTED $RPM_BUILD_ROOT%{_datadir}/i18n
 
 # shutup check-files
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.*
-rm -f $RPM_BUILD_ROOT%{_mandir}/diff.*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.*
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 # we don't support kernel without ptys support
-rm -f $RPM_BUILD_ROOT%{_libdir}/pt_chown
-# rpcbind
-rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/rpcinfo.8
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/rpcinfo.8
-rm -f $RPM_BUILD_ROOT%{_sbindir}/rpcinfo
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/pt_chown
+# rpcinfo dropped from glibc, provided by rpcbind now
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{,*/}man8/rpcinfo.8
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1168,12 +1239,26 @@ rm -rf $RPM_BUILD_ROOT
 -/bin/sed -i -e '1iinclude ld.so.conf.d/*.conf' /etc/ld.so.conf
 %endif
 
+%triggerin -- cronie,vixie-cron,hc-cron,fcron,mcron
+# restart crond if glibc is upgraded, LP#721338
+if [ "$1" != 1 ]; then
+       %service -q crond restart
+fi
+
 %post  libcrypt -p /sbin/ldconfig
 %postun        libcrypt -p /sbin/ldconfig
 
 %post  memusage -p /sbin/ldconfig
 %postun        memusage -p /sbin/ldconfig
 
+%post -n localedb-src
+SUPPORTED_LOCALES=
+[ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
+[ -f /etc/sysconfig/localedb ] && . /etc/sysconfig/localedb
+if [ "$SUPPORTED_LOCALES" ]; then
+       localedb-gen || :
+fi
+
 %post devel    -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
@@ -1185,12 +1270,14 @@ rm -rf $RPM_BUILD_ROOT
 %useradd -P nscd -u 144 -r -d /tmp -s /bin/false -c "Name Service Cache Daemon" -g nscd nscd
 
 %post -n nscd
+if [ ! -f /var/log/nscd ]; then
+       umask 027
+       touch /var/log/nscd
+       chown root:root /var/log/nscd
+       chmod 640 /var/log/nscd
+fi
 /sbin/chkconfig --add nscd
-touch /var/log/nscd
-chmod 000 /var/log/nscd
-chown root:root /var/log/nscd
-chmod 640 /var/log/nscd
-%service nscd restart "nscd daemon"
+%service nscd restart "Name Service Cache Daemon"
 
 %preun -n nscd
 if [ "$1" = "0" ]; then
@@ -1225,7 +1312,7 @@ fi
 %ifarch ppc64 s390x
 %attr(755,root,root) /%{_lib}/ld64.so.1
 %endif
-%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} ppc64 s390x
+%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} ppc64 s390x %{arm}
 %attr(755,root,root) /%{_lib}/ld.so.1
 %endif
 %attr(755,root,root) /%{_lib}/libBrokenLocale-%{version}.so
@@ -1310,13 +1397,16 @@ fi
 %endif
 %attr(755,root,root) %{_bindir}/locale
 %attr(755,root,root) %{_bindir}/rpcgen
-
+%attr(755,root,root) %{_bindir}/sotruss
 %attr(755,root,root) %{_sbindir}/zdump
 %attr(755,root,root) %{_sbindir}/zic
 
 %dir %{_libexecdir}/getconf
 %attr(755,root,root) %{_libexecdir}/getconf/*
 
+%dir %{_libdir}/audit
+%attr(755,root,root) %{_libdir}/audit/sotruss-lib.so
+
 %dir %{_datadir}/locale
 %{_datadir}/locale/locale.alias
 
@@ -1328,7 +1418,17 @@ fi
 %{_mandir}/man5/locale.5*
 %{_mandir}/man5/nsswitch.conf.5*
 %{_mandir}/man5/tzfile.5*
-%{_mandir}/man7/*
+%{_mandir}/man7/ascii.7*
+%{_mandir}/man7/charsets.7*
+%{_mandir}/man7/iso-8859-*.7*
+%{_mandir}/man7/iso_8859-*.7*
+%{_mandir}/man7/iso_8859_*.7*
+%{_mandir}/man7/koi8-r.7*
+%{_mandir}/man7/latin*.7*
+%{_mandir}/man7/locale.7*
+%{_mandir}/man7/unicode.7*
+%{_mandir}/man7/utf-8.7*
+%{_mandir}/man7/utf8.7*
 %{_mandir}/man8/ld-linux.8*
 %{_mandir}/man8/ld-linux.so.8*
 %{_mandir}/man8/ld.so.8*
@@ -1431,9 +1531,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libcrypt-%{version}.so
 %ifarch alpha
-%ghost %attr(755,root,root) /%{_lib}/libcrypt.so.1.1
+%attr(755,root,root) %ghost /%{_lib}/libcrypt.so.1.1
 %else
-%ghost %attr(755,root,root) /%{_lib}/libcrypt.so.1
+%attr(755,root,root) %ghost /%{_lib}/libcrypt.so.1
 %endif
 
 %files -n ldconfig
@@ -1450,6 +1550,8 @@ fi
 %lang(pl) %{_mandir}/pl/man8/ldconfig.8*
 %lang(pt) %{_mandir}/pt/man8/ldconfig.8*
 %lang(ru) %{_mandir}/ru/man8/ldconfig.8*
+%dir %attr(700,root,root) /var/cache/ldconfig
+%attr(600,root,root) %ghost /var/cache/ldconfig/aux-cache
 
 %files -n nss_compat
 %defattr(644,root,root,755)
@@ -1577,6 +1679,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/nscd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nscd.*
 %attr(754,root,root) /etc/rc.d/init.d/nscd
+%config(noreplace) %verify(not md5 mtime size) /etc/init/nscd.conf
 %attr(755,root,root) %{_sbindir}/nscd*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/nscd
 %attr(640,root,root) %ghost /var/log/nscd
This page took 0.09447 seconds and 4 git commands to generate.