]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- ReleasE: 9
[packages/glibc.git] / glibc.spec
index 01fbb87600559ebfe47be7cf69bea0a32a94067e..1b361a55aeebfaafc2469cf79a6db46615d62327 100644 (file)
@@ -9,8 +9,8 @@
                                # glibc-kernel-headers (evil, breakage etc., don't use)
 %bcond_without dist_kernel     # for above, allow non-distribution kernel
 %bcond_with    nptl            # use nptl instead of linuxthreads
-%bcond_without  tls            # do not use tls
-%bcond_without  tests          # do not perform "make test"
+%bcond_with     tls            # use tls
+%bcond_with    tests           # do not perform "make test"
 
 #
 # TODO:
@@ -25,7 +25,8 @@
 %{!?min_kernel:%global          min_kernel      2.4.6}
 
 %if %{with nptl}
-%ifarch i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
+# it seems that nptl uses cmpxchgl (available since i486) on x86
+%ifarch i486 i586 i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
 %if "%{min_kernel}" < "2.6.0"
 %global                min_kernel      2.6.0
 %endif
@@ -35,7 +36,7 @@
 %endif
 
 %if %{with tls}
-%ifnarch i686 athlon amd64 ia64 s390 s390x alphaev6 sparc sparcv9 ppc ppc64
+%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
 %undefine with_tls
 %endif
 %endif
@@ -52,7 +53,7 @@ Summary(tr):  GNU libc
 Summary(uk):   GNU libc ×ÅÒÓ¦§ 2.3
 Name:          glibc
 Version:       2.3.3
-Release:       0.20040101.4%{?with_nptl:+nptl}
+Release:       0.20040101.9%{?with_nptl:+nptl}
 Epoch:         6
 License:       LGPL
 Group:         Libraries
@@ -75,30 +76,29 @@ Source7:    sln.8
 Source8:       %{name}-localedb-gen
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-pl.po-update.patch
-#Patch1:               %{name}-initgroups-overflow.patch -- obsolete (came from upstream)
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-crypt-blowfish.patch
-#Patch4:               %{name}-string2-pointer-arith.patch -- obsolete since gcc 2.95.4 or so)
-Patch5:                %{name}-linuxthreads-lock.patch
-Patch6:                %{name}-pthread_create-manpage.patch
-Patch9:                %{name}-paths.patch
-#Patch10:      %{name}-vaargs.patch    -- obsolete fix for gcc 2.95/alpha (gcc>=3.2 is BRed)
-Patch11:       %{name}-getaddrinfo-workaround.patch
-Patch12:       %{name}-postshell.patch
-Patch14:       %{name}-missing-nls.patch
-Patch16:       %{name}-java-libc-wait.patch
-Patch18:       %{name}-lthrds_noomit.patch
-Patch19:       %{name}-no_opt_override.patch
+Patch4:                %{name}-linuxthreads-lock.patch
+Patch5:                %{name}-pthread_create-manpage.patch
+Patch6:                %{name}-paths.patch
+Patch7:                %{name}-getaddrinfo-workaround.patch
+Patch8:                %{name}-postshell.patch
+Patch9:                %{name}-missing-nls.patch
+Patch10:       %{name}-java-libc-wait.patch
+Patch11:       %{name}-lthrds_noomit.patch
+Patch12:       %{name}-no_opt_override.patch
 # this is broken (hardcoded /usr/src/linux)
-Patch23:       %{name}-kernel_includes.patch
-Patch24:       %{name}-includes.patch
-#Patch26:      %{name}-alpha-fix-as-syntax.patch       -- obsolete (fixed in other way)
-Patch27:       %{name}-soinit-EH_FRAME.patch
-Patch28:       %{name}-fix-asserts.patch
-Patch30:       %{name}-sparc-errno_fix.patch
-Patch31:       %{name}-make.patch
-Patch32:       %{name}-tests-io-tmp.patch
-Patch33:       %{name}-tests-noproc.patch
+Patch13:       %{name}-kernel_includes.patch
+Patch14:       %{name}-includes.patch
+Patch15:       %{name}-soinit-EH_FRAME.patch
+Patch16:       %{name}-fix-asserts.patch
+Patch17:       %{name}-sparc-errno_fix.patch
+Patch18:       %{name}-make.patch
+Patch19:       %{name}-tests-io-tmp.patch
+Patch20:       %{name}-tests-noproc.patch
+Patch21:       %{name}-linuxthreads-ppc-fix.patch
+Patch22:       %{name}-alpha-sigaction.patch
+Patch23:       %{name}-new-charsets.patch
 URL:           http://www.gnu.org/software/libc/
 BuildRequires: automake
 BuildRequires: binutils >= 2.13.90.0.2
@@ -411,14 +411,14 @@ Requires: %{name} = %{epoch}:%{version}-%{release}
 
 %description localedb-all
 This package contains locale database for all locales supported by
-glibc. In glibc 2.3.x it's one large file (about 19MB) - if you want
+glibc. In glibc 2.3.x it's one large file (about 27MB) - if you want
 something smaller with support for chosen locales only, consider
 installing localedb-src and regenerating database using localedb-gen
 script (when database is generated, localedb-src can be uninstalled).
 
 %description localedb-all -l es
 Este paquete contiene una base de datos de todos los locales soportados
-por glibc. En glibc 2.3.x ése es un fichero grande (aprox. 19 MB) -- si
+por glibc. En glibc 2.3.x ése es un fichero grande (aprox. 27 MB) -- si
 prefiere algo más pequeño, sólo con soporte de unos locales elegidos,
 considérese instalar localedb-src y regenerar la base de datos usando
 el escript localedb-gen (una vez que la base de datos esté creada,
@@ -427,7 +427,7 @@ localedb-src se podr
 %description localedb-all -l pl
 Ten pakiet zawiera bazê danych locale dla wszystkich lokalizacji
 obs³ugiwanych przez glibc. W glibc 2.3.x jest to jeden du¿y plik
-(oko³o 19MB); aby mieæ co¶ mniejszego, z obs³ug± tylko wybranych
+(oko³o 27MB); aby mieæ co¶ mniejszego, z obs³ug± tylko wybranych
 lokalizacji, nale¿y zainstalowaæ pakiet localedb-src i przegenerowaæ
 bazê danych przy u¿yciu skryptu localedb-gen (po wygenerowaniu bazy
 pakiet localedb-src mo¿na odinstalowaæ).
@@ -699,6 +699,7 @@ Summary(pl):        GNU libc - biblioteki 64-bitowe
 Group:         Libraries
 %ifarch amd64
 Provides:      glibc = %{epoch}:%{version}-%{release}
+Requires:      glibc-misc = %{epoch}:%{version}-%{release}
 %else
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 %endif
@@ -753,24 +754,27 @@ Statyczne 64-bitowe biblioteki GNU libc.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 %patch5 -p1
 %patch6 -p1
+#%%patch7 -p1
+%patch8 -p1
 %patch9 -p1
-#%%patch11 -p1
-%patch12 -p1
-%patch14 -p1
+%patch10 -p1
+%patch11 -p1
+# don't know, if it is good idea, for brave ones
+#%patch12 -p1
+%{?with_kernelheaders:%patch13}
+%{?!with_kernelheaders:%patch14 -p1}
+%patch15 -p1
 %patch16 -p1
+%patch17
 %patch18 -p1
-# don't know, if it is good idea, for brave ones
-#%patch19 -p1
-%{?with_kernelheaders:%patch23}
-%{?!with_kernelheaders:%patch24 -p1}
-%patch27 -p1
-%patch28 -p1
-%patch30
-%patch31 -p1
-%patch32 -p1
-%patch33 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+%patch23 -p1
 
 chmod +x scripts/cpp
 
@@ -847,9 +851,7 @@ install $PICFILES                           $RPM_BUILD_ROOT%{_libdir}
 install elf/soinit.os                          $RPM_BUILD_ROOT%{_libdir}/soinit.o
 install elf/sofini.os                          $RPM_BUILD_ROOT%{_libdir}/sofini.o
 
-install elf/postshell                          $RPM_BUILD_ROOT/%{_lib}
-mv $RPM_BUILD_ROOT/sbin/ldconfig               $RPM_BUILD_ROOT/%{_lib}
-ln -s /%{_lib}/ldconfig                        $RPM_BUILD_ROOT/sbin
+install elf/postshell                          $RPM_BUILD_ROOT/sbin
 
 %{?with_memusage:mv -f $RPM_BUILD_ROOT/%{_lib}/libmemusage.so  $RPM_BUILD_ROOT%{_libdir}}
 %ifnarch sparc64
@@ -917,6 +919,8 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libnss_*.so
 
 # Collect locale files and mark them with %%lang()
 rm -f ../glibc.lang
+# bokmaal has been renamed (no_NO -> nb_NO) in 2.3.3, but not in po
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{no,nb}
 echo '%defattr(644,root,root,755)' > ../glibc.lang
 for i in $RPM_BUILD_ROOT%{_datadir}/locale/* $RPM_BUILD_ROOT%{_libdir}/locale/* ; do
        if [ -d $i ]; then
@@ -941,13 +945,16 @@ for i in $RPM_BUILD_ROOT%{_datadir}/locale/* $RPM_BUILD_ROOT%{_libdir}/locale/*
        fi
 done
 # XXX: to be added when become supported by glibc
-# am,bn,ml (present in sources, but incomplete and disabled) (used by GNOME)
-# ia,kn,li,mn,sr@Latn (used by GNOME)
-#      note: GNOME2 uses sr as cyrillic!
-# nso,ss,ven,xh,zu (used by KDE)
-for i in af ar az be bg br bs cy de_AT el en en_AU eo es_AR es_MX et eu fa fi \
-        ga gr he hi hr hu id is ja_JP.SJIS ka lg lt lv mk ms mt nn pt ro ru \
-        se sl sq sr sr@cyrillic ta tg th uk uz vi wa yi zh_CN ; do
+# ia,li,sr@Latn (used by GNOME)
+#      note: GNOME2 uses sr (and probably uz) as cyrillic!
+# nso,ss,ven (used by KDE)
+# NOTES:
+# bn is used for bn_BD or bn_IN?
+# omitted here - already existing (with libc.mo):
+#   be,ca,cs,da,de,el,en_GB,es,fi,fr,gl,hr,hu,it,ja,ko,nb,nl,pl,pt_BR,sk,sv,tr,zh_CN,zh_TW
+for i in af am ar az bg bn br bs cy de_AT en en_AU eo es_AR es_MX et eu fa ga \
+        gr he hi id is ja_JP.SJIS ka kn lg lt lv mk ml mn ms mt nn pt ro ru \
+        se sl sq sr sr@cyrillic ta tg th uk uz vi wa xh yi zu ; do
        if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES ]; then
                install -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES
                lang=`echo $i | sed -e 's/_.*//'`
@@ -976,19 +983,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %ifnarch sparc64
 %ifarch amd64
-%post  -n %{name}64 -p /%{_lib}/postshell
+%post  -n %{name}64 -p /sbin/postshell
 %else
-%post  -p /%{_lib}/postshell
+%post  -p /sbin/postshell
 %endif
-/%{_lib}/ldconfig
+/sbin/ldconfig
 -/sbin/telinit u
 
 %ifarch amd64
-%postun        -n %{name}64 -p /%{_lib}/postshell
+%postun        -n %{name}64 -p /sbin/postshell
 %else
-%postun        -p /%{_lib}/postshell
+%postun        -p /sbin/postshell
 %endif
-/%{_lib}/ldconfig
+/sbin/ldconfig
 -/sbin/telinit u
 
 %post  memusage -p /sbin/ldconfig
@@ -1034,7 +1041,7 @@ fi
 # ld* and libc.so.6 SONAME symlinks must be in package because of
 # chicken-egg problem (postshell is dynamically linked with libc);
 # ld-*.so SONAME is ld.so.1 on ppc, ld-linux.so.2 on other archs
-%attr(755,root,root) /%{_lib}/postshell
+%attr(755,root,root) /sbin/postshell
 %attr(755,root,root) /%{_lib}/ld*
 %attr(755,root,root) /%{_lib}/libanl*
 %attr(755,root,root) /%{_lib}/libdl*
This page took 0.052031 seconds and 4 git commands to generate.