]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.5.3.1
[packages/git-core.git] / git-core.spec
index fb83f59b83d65c63421dac031182550717ae699e..88bb43a8f81d7a9643029e23e6a7468051062a80 100644 (file)
@@ -6,12 +6,12 @@
 Summary:       The stupid content tracker
 Summary(pl.UTF-8):     Prymitywne narzędzie do śledzenia treści
 Name:          git-core
-Version:       1.5.2.2
-Release:       3
+Version:       1.5.3.1
+Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: 846940654b703ec5c8de4ee388cb4d08
+# Source0-md5: 3213bc24c86e3741bae3607192f3ee7d
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 URL:           http://git.or.cz/
@@ -114,7 +114,7 @@ rewizji.
 Z punktu widzenia historii, gitk był pierwszą przeglądarką
 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
 w osobnym repozytorium, ale z czasem został włączony do głównego
-repozytorium git.
+repozytorium gita.
 
 %package gitweb
 Summary:       Web frontend to git
@@ -127,7 +127,19 @@ Requires:  webapps
 This package provides a web interface for browsing git repositories.
 
 %description gitweb -l pl.UTF-8
-Pakiet ten dostarcza interfejs WWW do przegl?dania repozytoriów git.
+Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
+
+%package -n bash-completion-git
+Summary:       bash-completion for git
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
+Group:         Applications/Shell
+Requires:      bash-completion
+
+%description -n bash-completion-git
+This package provides bash-completion for git.
+
+%description -n bash-completion-git -l pl.UTF-8
+Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
 
 %package -n perl-Git
 Summary:       Perl interface to the Git version control system
@@ -151,6 +163,19 @@ udostępni także specjalne metody do łatwego wykonywania operacji
 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
 poleceń.
 
+%package -n vim-syntax-gitcommit
+Summary:       Vim syntax: gitcommit
+Summary(pl.UTF-8):     Składnia dla Vima: gitcommit
+Group:         Applications/Editors/Vim
+# for _vimdatadir existence
+Requires:       vim >= 4:6.3.058-3
+
+%description -n vim-syntax-gitcommit
+This plugin provides syntax highlighting for git's commit messages.
+
+%description -n vim-syntax-gitcommit -l pl.UTF-8
+Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
+
 %prep
 %setup -q -n git-%{version}
 
@@ -176,6 +201,8 @@ poleceń.
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
+install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 
 %{__make} install \
        INSTALLDIRS=vendor \
@@ -184,8 +211,16 @@ install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
 %{__make} -C Documentation install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# header files and lib
 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
+install libgit.a $RPM_BUILD_ROOT%{_libdir}
+
+# bash completion
+install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
+
+# vim syntax
+install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
 
 # gitweb
 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
@@ -215,19 +250,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man*/*
+%doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
+%attr(755,root,root) %{_bindir}/git
+%attr(755,root,root) %{_bindir}/git-*
+%{_mandir}/man1/git-*.1*
+%{_mandir}/man5/gitattributes.5*
+%{_mandir}/man5/gitignore.5*
+%{_mandir}/man5/gitmodules.5*
+%{_mandir}/man7/git.7*
 %{_datadir}/%{name}
 %{_datadir}/git-gui
 %{_sharedstatedir}/git
-%exclude %{_bindir}/gitk
-%exclude %{_mandir}/man1/gitk.1*
-%exclude %{_mandir}/man3/*
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/*
+%{_libdir}/*.a
 
 %files gitk
 %defattr(644,root,root,755)
@@ -245,7 +283,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
 
+%files -n bash-completion-git
+%defattr(644,root,root,755)
+%{_sysconfdir}/bash_completion.d/*
+
 %files -n perl-Git
 %defattr(644,root,root,755)
 %{perl_vendorlib}/Git.pm
-%{_mandir}/man3/*
+%{_mandir}/man3/Git.3pm*
+
+%files -n vim-syntax-gitcommit
+%defattr(644,root,root,755)
+%doc contrib/vim/README
+%{_datadir}/vim/vimfiles/syntax/*
This page took 0.093543 seconds and 4 git commands to generate.