]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
apache multiversion config
[packages/git-core.git] / git-core.spec
index 4dc3cc467f3159c92c2141662592ae4cc876f1a3..3fcbe0610effe06b6efdee8b921dc617f9011e3d 100644 (file)
@@ -2,20 +2,20 @@
 # Conditional build:
 %bcond_without tests           # don't perform make test
 %bcond_with    tests_cvs       # perform tests which use CVS
-%bcond_with    tests_svn       # perform tests which use subversion
+%bcond_without tests_svn       # perform tests which use subversion
 %bcond_without doc             # skip building/packaging docs/manuals (takes some time)
+%bcond_without pcre            # perl-compatible regexes support
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.7.10
-Release:       1
+Version:       1.8.4
+Release:       2
 License:       GPL v2
 Group:         Development/Tools
-# Source0:     http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
 Source0:       http://git-core.googlecode.com/files/git-%{version}.tar.gz
-# Source0-md5: ab2716db51580037c7ebda4c8e9d56eb
+# Source0-md5: 355768a1c70d0cb4fedf4b598ac1375b
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -25,6 +25,9 @@ Source6:      %{name}.init
 Patch0:                %{name}-tests.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
+Patch3:                cherry-picked-commitlog.patch
+Patch4:                %{name}-svn-serf.patch
+Patch5:                %{name}-svn-exit-errors.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -32,6 +35,7 @@ BuildRequires:        curl-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: openssl-devel
+%{?with_pcre:BuildRequires:    pcre-devel}
 BuildRequires: perl-Error > 0.15
 BuildRequires: perl-base
 BuildRequires: python-devel
@@ -51,6 +55,7 @@ BuildRequires:        xmlto
 BuildRequires: cvs-gnu-client < 1.13
 BuildRequires: cvs-gnu-client >= 1.12
 %endif
+%{?with_tests_svn:BuildRequires:  subversion}
 Conflicts:     pdksh < 5.2.14-46
 %endif
 Requires:      coreutils
@@ -74,6 +79,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                webappdir       %{_sysconfdir}/webapps/%{webapp}
 %define                appdir          %{_datadir}/%{webapp}
 %define                cgibindir       %{_prefix}/lib/cgi-bin
+%define                bash_compdir    %{_datadir}/bash-completion/completions
 
 %description
 "git" can mean anything, depending on your mood.
@@ -162,16 +168,16 @@ udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
 do uruchomienia git-daemona w trybie usługi samodzielnej.
 
 %package devel
-Summary:       Header files for git-core
-Summary(pl.UTF-8):     Pliki nagłówkowe dla git-core
+Summary:       Git library with header files
+Summary(pl.UTF-8):     Biblioteka Gita oraz pliki nagłówkowe
 Group:         Development/Libraries
 Requires:      zlib-devel
 
 %description devel
-Header files for git-core.
+Git library with header files.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla git-core.
+Biblioteka Gita oraz pliki nagłówkowe.
 
 %package gitk
 Summary:       Tcl/Tk interface to the Git version control system
@@ -318,7 +324,7 @@ Summary:    bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-git
 This package provides bash-completion for git.
@@ -379,12 +385,15 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %patch0 -p1
 %patch1 -p0
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %configure \
        --sysconfdir=%{_sysconfdir}/git-core \
+       %{?with_pcre:--with-libpcre} \
        --with-openssl
 
 echo "BLK_SHA1=1" >> config.mak
@@ -398,14 +407,17 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_FAVICON="/gitweb/git-favicon.png" \
        V=1
 
-# use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
-%{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
+%if %{with doc}
+%{__make} -C Documentation \
+       MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
+       V=1
+%endif
 
 %if %{with tests}
 %if %{without tests_cvs}
-rm t/t*cvs*.sh || :
+%{__rm} t/t*cvs*.sh || :
 %endif
-%{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
+%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
 %endif
 
 %install
@@ -436,12 +448,15 @@ cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
+install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
+cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
+cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
 
 # bash completion
-install -d $RPM_BUILD_ROOT/etc/bash_completion.d
-cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
 
 # vim syntax
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
@@ -490,6 +505,7 @@ ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
 %py_postclean
 
+mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
 %find_lang git
 
 %clean
@@ -543,9 +559,12 @@ fi
 
 %if %{with doc}
 %{_mandir}/man1/git-*.1*
+%exclude %{_mandir}/man1/git-archimport.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
-%exclude %{_mandir}/man1/git-remote-helpers.1*
+%exclude %{_mandir}/man1/git-imap-send*.1*
+%exclude %{_mandir}/man1/*email*.1*
+%exclude %{_mandir}/man1/gitremote-helpers.1*
 %{_mandir}/man1/git.1*
 %{_mandir}/man5/gitattributes.5*
 %{_mandir}/man5/githooks.5*
@@ -573,8 +592,9 @@ fi
 %exclude %{_libdir}/%{name}/git-svn
 %exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
+%exclude %{_libdir}/%{name}/git-imap-send
 %exclude %{_libdir}/%{name}/git-instaweb
-%exclude %{_libdir}/%{name}/git-remote-testgit
+%exclude %{_libdir}/%{name}/git-remote-testsvn
 %exclude %{_libdir}/%{name}/*email*
 
 %{_datadir}/%{name}
@@ -668,6 +688,9 @@ fi
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/git-svn
+%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
+%{perl_vendorlib}/Git/SVN
+%{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
 %{_mandir}/man1/git-svn.1*
 %endif
@@ -690,24 +713,27 @@ fi
 
 %files email
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/git-imap-send
 %attr(755,root,root) %{_libdir}/%{name}/*email*
 %if %{with doc}
 %{_mandir}/man1/*email*.1*
+%{_mandir}/man1/*imap-send*.1*
 %endif
 
 %files -n bash-completion-git
 %defattr(644,root,root,755)
-/etc/bash_completion.d/git-completion.bash
+%{bash_compdir}/git
 
 %files -n perl-Git
 %defattr(644,root,root,755)
 %{perl_vendorlib}/Git.pm
-%{perl_vendorlib}/Git
+%dir %{perl_vendorlib}/Git
+%{perl_vendorlib}/Git/I18N.pm
+%{perl_vendorlib}/Git/IndexInfo.pm
 %{_mandir}/man3/Git*.3pm*
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
@@ -716,7 +742,7 @@ fi
 %{py_sitescriptdir}/git_remote_helpers*.egg-info
 %endif
 %if %{with doc}
-%{_mandir}/man1/git-remote-helpers.1*
+%{_mandir}/man1/gitremote-helpers.1*
 %endif
 
 %files -n vim-syntax-gitcommit
This page took 0.065869 seconds and 4 git commands to generate.