]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
apache multiversion config
[packages/git-core.git] / git-core.spec
index 1c71b071b7329986aebe2816d19137f2b2b2f239..3fcbe0610effe06b6efdee8b921dc617f9011e3d 100644 (file)
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.8.3.1
-Release:       1
+Version:       1.8.4
+Release:       2
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://git-core.googlecode.com/files/git-%{version}.tar.gz
-# Source0-md5: 35401b410e7f248b13e35a1069aca2e2
+# Source0-md5: 355768a1c70d0cb4fedf4b598ac1375b
 Source1:       %{name}-gitweb.conf
-Source2:       %{name}-gitweb-apache.conf
+Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
 Source4:       %{name}.sysconfig
 Source5:       %{name}.inet
 Source6:       %{name}.init
-Source7:       %{name}-gitweb-httpd.conf
 Patch0:                %{name}-tests.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
 Patch3:                cherry-picked-commitlog.patch
+Patch4:                %{name}-svn-serf.patch
+Patch5:                %{name}-svn-exit-errors.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -213,7 +214,6 @@ Requires:   webapps
 Requires:      webserver(alias)
 Requires:      webserver(cgi)
 Suggests:      webserver(setenv)
-Conflicts:     apache-base < 2.4.0-1
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -386,6 +386,7 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %patch1 -p0
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__aclocal}
@@ -447,8 +448,11 @@ cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
+install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
+cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
+cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
 
 # bash completion
 install -d $RPM_BUILD_ROOT%{bash_compdir}
@@ -475,7 +479,7 @@ mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
-cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
@@ -531,10 +535,10 @@ fi
 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{webapp}
 
-%triggerin gitweb -- apache-base
+%triggerin gitweb -- apache < 2.2.0, apache-base
 %webapp_register httpd %{webapp}
 
-%triggerun gitweb -- apache-base
+%triggerun gitweb -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{webapp}
 
 %triggerin gitweb -- lighttpd
@@ -558,6 +562,7 @@ fi
 %exclude %{_mandir}/man1/git-archimport.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
+%exclude %{_mandir}/man1/git-imap-send*.1*
 %exclude %{_mandir}/man1/*email*.1*
 %exclude %{_mandir}/man1/gitremote-helpers.1*
 %{_mandir}/man1/git.1*
@@ -587,8 +592,8 @@ fi
 %exclude %{_libdir}/%{name}/git-svn
 %exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
+%exclude %{_libdir}/%{name}/git-imap-send
 %exclude %{_libdir}/%{name}/git-instaweb
-%exclude %{_libdir}/%{name}/git-remote-testpy
 %exclude %{_libdir}/%{name}/git-remote-testsvn
 %exclude %{_libdir}/%{name}/*email*
 
@@ -708,9 +713,11 @@ fi
 
 %files email
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/git-imap-send
 %attr(755,root,root) %{_libdir}/%{name}/*email*
 %if %{with doc}
 %{_mandir}/man1/*email*.1*
+%{_mandir}/man1/*imap-send*.1*
 %endif
 
 %files -n bash-completion-git
@@ -727,7 +734,6 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
This page took 0.094537 seconds and 4 git commands to generate.