]> git.pld-linux.org Git - packages/gdm2.20.git/blobdiff - gdm2.20.spec
- use %useradd/%groupadd macros
[packages/gdm2.20.git] / gdm2.20.spec
index 6e563806c2522ad0d41a8694b092d5162a9d1ba8..f02d7592e1f21758200ae166a7ad7506a62ebf5b 100644 (file)
@@ -3,6 +3,9 @@
 # s=/dev/null=/home/services/xdm= in %%trigger for gracefull upgrade from xdm/kdm/gdm 2.2
 # check /etc/pam.d/gdm-autologin
 #
+# Conditiional build:
+%bcond_without selinux # without selinux
+#
 Summary:       GNOME Display Manager
 Summary(es):   Administrador de Entrada del GNOME
 Summary(ja):   GNOME ¥Ç¥£¥¹¥×¥ì¥¤¥Þ¥Í¡¼¥¸¥ã
@@ -11,25 +14,27 @@ Summary(pt_BR):     Gerenciador de Entrada do GNOME
 Summary(ru):   äÉÓÐÌÅÊÎÙÊ ÍÅÎÅÄÖÅÒ GNOME
 Summary(uk):   äÉÓÐÌÅÊÎÉÊ ÍÅÎÅÄÖÅÒ GNOME
 Name:          gdm
-Version:       2.6.0.3
-Release:       2
+Version:       2.6.0.9
+Release:       1
 Epoch:         1
 License:       GPL/LGPL
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.6/%{name}-%{version}.tar.bz2
-# Source0-md5: 2eb8c0fb4289d78fdae686aee3cfbd5c
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gdm/2.6/%{name}-%{version}.tar.bz2
+# Source0-md5: d845fe205412bb101d4c66d1e88a317d
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}-pld-logo.png
 # http://cvs.pld-linux.org/cgi-bin/cvsweb/pld-artwork/gdm/storky/
 Source4:       %{name}-storky.tar.gz
 # Source4-md5: e293fbe4a60004056f6894463b874ae8
+Source5:       %{name}-autologin.pamd
 Patch0:                %{name}-xdmcp.patch
 Patch1:                %{name}-conf.patch
 Patch2:                %{name}-xsession.patch
 Patch3:                %{name}-logdir.patch
-Patch4:                %{name}-locale-names.patch
-Patch5:                %{name}-default_theme.patch
+Patch4:                %{name}-default_theme.patch
+Patch5:                %{name}-desktop.patch
+patch6:                %{name}-vt_9.patch
 URL:           http://www.jirka.org/gdm.html
 BuildRequires: attr-devel
 BuildRequires: autoconf
@@ -37,29 +42,35 @@ BuildRequires:      automake
 BuildRequires: gettext-devel
 BuildRequires: gtk+2-devel >= 2:2.4.3
 BuildRequires: intltool >= 0.30
-BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.1
 BuildRequires: libgnome-devel >= 2.6.1
 BuildRequires: libgnomecanvas-devel >= 2.6.1
-BuildRequires: libgnomeui-devel >= 2.6.1
+BuildRequires: libgnomeui-devel >= 2.10.0-2
 BuildRequires: libgsf-devel >= 1.9.0
 BuildRequires: librsvg-devel >= 1:2.6.5
-BuildRequires: libselinux-devel
+%{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.5.11
 BuildRequires: pam-devel
 BuildRequires: perl-modules
-BuildRequires: scrollkeeper
+BuildRequires: rpmbuild(macros) >= 1.202
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(postun):      /usr/sbin/userdel
 Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
 Requires(post,postun): /usr/bin/scrollkeeper-update
 Requires:      libgnome >= 2.6.1
 Requires:      sessreg
 Requires:      which
 Requires:      pam >= 0.77.3-7
-Obsoletes:     xdm kdm wdm
+Provides:      group(xdm)
+Provides:      user(xdm)
+Obsoletes:     X11-xdm
+Obsoletes:     entrance
+Obsoletes:     kdm
+Obsoletes:     wdm
+Obsoletes:     xdm
 Conflicts:     gdkxft
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -136,16 +147,12 @@ Skrypt init dla GDM-a.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/themes/storky
-install storky/*.* $RPM_BUILD_ROOT%{_datadir}/%{name}/themes/storky/
-
-mv po/{no,nb}.po
+%patch6 -p1
 
 %build
-rm -f missing
 %{__libtoolize}
-glib-gettextize --copy --force
-intltoolize --copy --force
+%{__glib_gettextize}
+%{__intltoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
@@ -156,7 +163,7 @@ intltoolize --copy --force
        --with-tcp-wrappers=yes \
        --enable-authentication-scheme=pam \
        --disable-console-helper \
-       --with-selinux
+       --with%{!?with_selinux:out}-selinux
 
 %{__make}
 
@@ -173,6 +180,7 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,security} \
 mv $RPM_BUILD_ROOT%{_datadir}/gdm/BuiltInSessions/default.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
+install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/gdm-autologin
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
 
 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
@@ -181,6 +189,8 @@ install storky/*.* $RPM_BUILD_ROOT%{_datadir}/gdm/themes/storky/
 
 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
 
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
+
 %find_lang %{name} --all-name --with-gnome
 
 # Remove useless files
@@ -193,30 +203,17 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/xsessions/gnome.desktop
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-if [ -n "`getgid xdm`" ]; then
-       if [ "`getgid xdm`" != "55" ]; then
-                echo "Error: group xdm doesn't have gid=55. Correct this before installing %{name}." 1>&2
-                exit 1
-        fi
-else
-       /usr/sbin/groupadd -g 55 -r -f xdm
-fi
-
-
-if [ -z "`id -u xdm 2>/dev/null`" ]; then
-       /usr/sbin/useradd -u 55 -r -d /home/services/xdm -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
-fi
+%groupadd -g 55 -r -f xdm
+%useradd -u 55 -r -d /home/services/xdm -s /bin/false -c 'X Display Manager' -g xdm xdm
 
 %post
-/usr/bin/scrollkeeper-update
+%scrollkeeper_update_post
 
 %postun
-/usr/bin/scrollkeeper-update
+%scrollkeeper_update_postun
 if [ "$1" = "0" ]; then
-       if [ -n "`id -u xdm 2>/dev/null`" ]; then
-               /usr/sbin/userdel xdm
-       fi
-       /usr/sbin/groupdel xdm
+       %userremove xdm
+       %groupremove xdm
 fi
 
 %post init
@@ -262,7 +259,7 @@ fi
 %config %{_sysconfdir}/gdm/PostLogin/Default.sample
 %config %{_sysconfdir}/gdm/modules/*
 
-%config(noreplace)  %verify(not size mtime md5) %{_sysconfdir}/gdm/gdm.conf
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/gdm/gdm.conf
 %config %{_sysconfdir}/gdm/locale.alias
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/gdm*
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
This page took 0.034903 seconds and 4 git commands to generate.