]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- rebuilt with readline 4.1
[packages/gdb.git] / gdb.spec
index bbf5f69cda3a9c2407e5e2c8d5ae90714189275d..e8eddd0f8a9e217407b990edad5481740cf8fe93 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,24 +1,31 @@
-Summary:       Symbolic debugger for C and other languages
+Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de):   Symbolischer Debugger für C und andere Sprachen 
 Summary(fr):   Débugger symbolique pour C et d'autres langages
-Summary(pl):   Symboliczny debugger dla C i innych jêzyków
+Summary(pl):   Symboliczny odpluskwiacz dla C i innych jêzyków
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
 Version:       4.18
-Release:       4
+Release:       7
 Copyright:     GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
 Source:                ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
 Patch0:                gdb-info.patch
-Prereq:                /sbin/install-info
+Patch1:                gdb-sigtramp.patch
+Patch2:                gdb-sparc.patch
+Patch3:                gdb-xref.patch
+Patch4:                gdb-sparcmin.patch
+Patch5:                gdb-threads.patch
+Patch6:                gdb-shared-readline.patch
+Prereq:                /usr/sbin/fix-info-dir
+BuildRequires: ncurses-devel >= 5.0
+BuildRequires: readline-devel >= 4.1
 Buildroot:     /tmp/%{name}-%{version}-root
 
 %description
-This is a full featured, command driven debugger. It allows you to
-trace the exectuion of programs and examine their internal state
-at any time. It works for C and C++ compiled with the GNU C compiler
-gcc.
+Gdb is a full featured, command driven debugger. Gdb allows you to trace the
+execution of programs and examine their internal state at any time. Gdb
+works for C and C++ compiled with the GNU C compiler gcc.
 
 %description -l de
 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
@@ -31,10 +38,10 @@ des programmes et d'examiner 
 avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
 
 %description -l pl
-Gdb jest rozbudowanym debugerem, pozwalaj±cym ¶ledziæ wykonanie
-programu i badaæ jego stan wewnêtrzny. gdb umo¿liwia debugowanie
-programów napisanych w C i C++ i skompilowanych przy pomocy kompilatora
-C GNU (egcs).
+Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym ¶ledziæ
+wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb umo¿liwia
+odpluskwianie programów napisanych w C/C++ i skompilowanych przy pomocy
+kompilatora GNU (gcc).
 
 %description -l tr
 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
@@ -42,49 +49,46 @@ ve herhangi bir anda program
 
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
-./configure \
+./configure %{_target_platform} \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
-       %{_target_platform} 
+       --enable-shared
 
 make
 make info
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_prefix}
+install -d $RPM_BUILD_ROOT%{_infodir}
 
-make \
+make install \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
        infodir=$RPM_BUILD_ROOT%{_infodir} \
-       mandir=$RPM_BUILD_ROOT%{_mandir} \
-       install
+       mandir=$RPM_BUILD_ROOT%{_mandir}
 
 # install by hand
 install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
 
 strip $RPM_BUILD_ROOT%{_bindir}/*
 
-rm -f $RPM_BUILD_ROOT%{_infodir}{bfd*,history*,readline*,standard*,texinfo*}
-
 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
 
 %post
-/sbin/install-info %{_infodir}/gdb.info.gz     /etc/info-dir
-/sbin/install-info %{_infodir}/stabs.info.gz   /etc/info-dir
-/sbin/install-info %{_infodir}/gdbint.info.gz  /etc/info-dir
+/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun
-if [ "$1" = 0 ]; then
-       /sbin/install-info --delete %{_infodir}/gdb.info.gz     /etc/info-dir
-       /sbin/install-info --delete %{_infodir}/stabs.info.gz   /etc/info-dir
-       /sbin/install-info --delete %{_infodir}/gdbint.info.gz  /etc/info-dir
-fi
+%postun
+/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -94,34 +98,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 
 %{_mandir}/man1/*
-%{_infodir}/gd*.info*
+%{_infodir}/gdb*.info*
 %{_infodir}/stabs*.info*
-
-%changelog
-* Sun May 16 1999 Artur Frysiak <wiget@pld.org.pl>
-  [4.18-3]
-- configure with --host=%{_host_alias} instead --host=%{_host} to prevent build
-  crosscompiler prefix (eg i586-pc-linux-gdb)
-- using more rpm macros
-
-* Fri May 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.18-2]
-- now package is FHS 2.0 compliant.
-
-* Tue Apr 13 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.18-1]
-- standarized {un}registering info pages (added gdb-info.patch).
-- removed man group from man pages.
-
-* Mon Apr 12 1999 Marcin Dalecki <dalecki@cs.net.pl>
-  [4.18]
-- updated to this fresh new release.
-
-* Sat Oct 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.17.0.4-3]
-- added gdb-readline_ncurses.patch for compiling gdb agains shared
-  libredline and libncurses.
-
-* Sun Sep 27 1998 Marcin Korzonek <mkorz@shadow.eu.org>
-- added pl translation,
-- major changes for PLD Linux
This page took 0.031862 seconds and 4 git commands to generate.