]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- rebuilt with readline 4.1
[packages/gdb.git] / gdb.spec
index 83a37c97bf1862b7f59c5519628bc7ed7d8d3843..e8eddd0f8a9e217407b990edad5481740cf8fe93 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,24 +1,31 @@
-Summary:       Symbolic debugger for C and other languages
+Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de):   Symbolischer Debugger für C und andere Sprachen 
 Summary(fr):   Débugger symbolique pour C et d'autres langages
-Summary(pl):   Symboliczny debugger dla C i innych jêzyków
+Summary(pl):   Symboliczny odpluskwiacz dla C i innych jêzyków
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
 Version:       4.18
-Release:       2
+Release:       7
 Copyright:     GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
 Source:                ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
 Patch0:                gdb-info.patch
-Prereq:                /sbin/install-info
+Patch1:                gdb-sigtramp.patch
+Patch2:                gdb-sparc.patch
+Patch3:                gdb-xref.patch
+Patch4:                gdb-sparcmin.patch
+Patch5:                gdb-threads.patch
+Patch6:                gdb-shared-readline.patch
+Prereq:                /usr/sbin/fix-info-dir
+BuildRequires: ncurses-devel >= 5.0
+BuildRequires: readline-devel >= 4.1
 Buildroot:     /tmp/%{name}-%{version}-root
 
 %description
-This is a full featured, command driven debugger. It allows you to
-trace the exectuion of programs and examine their internal state
-at any time. It works for C and C++ compiled with the GNU C compiler
-gcc.
+Gdb is a full featured, command driven debugger. Gdb allows you to trace the
+execution of programs and examine their internal state at any time. Gdb
+works for C and C++ compiled with the GNU C compiler gcc.
 
 %description -l de
 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
@@ -31,10 +38,10 @@ des programmes et d'examiner 
 avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
 
 %description -l pl
-Gdb jest rozbudowanym debugerem, pozwalaj±cym ¶ledziæ wykonanie
-programu i badaæ jego stan wewnêtrzny. gdb umo¿liwia debugowanie
-programów napisanych w C i C++ i skompilowanych przy pomocy kompilatora
-C GNU (egcs).
+Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym ¶ledziæ
+wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb umo¿liwia
+odpluskwianie programów napisanych w C/C++ i skompilowanych przy pomocy
+kompilatora GNU (gcc).
 
 %description -l tr
 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
@@ -42,87 +49,54 @@ ve herhangi bir anda program
 
 %prep
 %setup -q
-#%patch0 -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
-./configure \
-       --prefix=/usr \
-       --target=%{_target_platform} \
-       --host=%{_host}
+./configure %{_target_platform} \
+       --prefix=%{_prefix} \
+       --infodir=%{_infodir} \
+       --mandir=%{_mandir} \
+       --enable-shared
+
 make
 make info
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/usr
+install -d $RPM_BUILD_ROOT%{_infodir}
+
+make install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       mandir=$RPM_BUILD_ROOT%{_mandir}
 
-make install install-info \
-       prefix=$RPM_BUILD_ROOT/usr \
-       infodir=$RPM_BUILD_ROOT/usr/share/info \
-       mandir=$RPM_BUILD_ROOT/usr/share/man
+# install by hand
+install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
 
-strip $RPM_BUILD_ROOT/usr/bin/*
+strip $RPM_BUILD_ROOT%{_bindir}/*
 
-rm -f $RPM_BUILD_ROOT/usr/share/info/{bfd*,history*,readline*,standard*,texinfo*}
-gzip -fn9 $RPM_BUILD_ROOT/usr/share/{info/*info*,man/man?/*}
+gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
 
 %post
-/sbin/install-info /usr/share/info/gdb.info.gz /etc/info-dir
-/sbin/install-info /usr/share/info/stabs.info.gz /etc/info-dir
-/sbin/install-info /usr/share/info/gdbint.info.gz /etc/info-dir
+/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun
-if [ "$1" = 0 ]; then
-       /sbin/install-info --delete /usr/share/info/gdb.info.gz /usr/share/info-dir
-       /sbin/install-info --delete /usr/share/info/stabs.info.gz /etc/info-dir
-       /sbin/install-info --delete /usr/share/info/gdbint.info.gz /etc/info-dir
-fi
+%postun
+/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) /usr/bin/*
-/usr/share/man/man1/*
-/usr/share/info/*info*
-
-%changelog
-* Fri May 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.18-2]
-- now package is FHS 2.0 compliant.
-
-* Tue Apr 13 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.18-1]
-- standarized {un}registering info pages (added gdb-info.patch).
-- removed man group from man pages.
-
-* Mon Apr 12 1999 Marcin Dalecki <dalecki@cs.net.pl>
-  [4.18]
-- updated to this fresh new release.
-
-* Sat Oct 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [4.17.0.4-3]
-- added gdb-readline_ncurses.patch for compiling gdb agains shared
-  libredline and libncurses.
-
-* Sun Sep 27 1998 Marcin Korzonek <mkorz@shadow.eu.org>
-- added pl translation.
-
-* Thu May 07 1998 Prospector System <bugs@redhat.com>
-- translations modified for de, fr, tr
-
-* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
-- upgraded to 4.17
-
-* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
-- updated to use a buildroot
-- uses install-info
-
-* Tue Aug 19 1997 Erik Troan <ewt@redhat.com>
-- turned off mmalloc() support, which seems to annoy glibc (resulting in
-  a quick core dump inside of getcwd())
+%attr(755,root,root) %{_bindir}/*
 
-* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
-- built against glibc
+%{_mandir}/man1/*
+%{_infodir}/gdb*.info*
+%{_infodir}/stabs*.info*
This page took 0.033724 seconds and 4 git commands to generate.