]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- updated bfd check-files cleanup, package sim headers (in -lib); guile 3.0 is suppor...
[packages/gdb.git] / gdb.spec
index ac15b73e86554cad5e172c310b1216ec560ef541..23ed5edea9aea17fc6b0b83d7100ac6022c08950 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -21,29 +21,26 @@ Summary(uk.UTF-8):  Символьний відладчик для С та інш
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
-Version:       9.1
-Release:       2
+Version:       11.1
+Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: f7e9f6236c425097d9e5f18a6ac40655
+# Source0-md5: 257cb0f67927f79acf636d8c01e19990
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
+Patch0:                glibc2.34.patch
 Patch100:      gdb-6.6-buildid-locate.patch
 Patch101:      gdb-6.6-buildid-locate-solib-missing-ids.patch
 Patch102:      gdb-6.6-buildid-locate-rpm.patch
-Patch103:      gdb-6.6-buildid-locate-core-as-arg.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
 Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
 
-Patch112:      gdb-archer-vla-tests.patch
-Patch113:      gdb-vla-intel-fortran-strides.patch
 Patch114:      gdb-vla-intel-stringbt-fix.patch
-Patch115:      gdb-vla-intel-fortran-vla-strings.patch
-Patch116:      gdb-vla-intel-tests.patch
+Patch115:      gdb-vla-intel-tests.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
@@ -59,7 +56,7 @@ BuildRequires:        flex >= 2.6.4
 BuildRequires: gettext-tools >= 0.12.1
 %if %{with guile}
 BuildRequires: guile-devel >= 2.0
-BuildRequires: guile-devel < 2.2
+BuildRequires: guile-devel < 3.2
 %endif
 %ifarch %{ix86} %{x8664}
 BuildRequires: libipt-devel
@@ -90,6 +87,8 @@ Requires:     python3-modules
 %{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
+
 %description
 Gdb is a full featured, command driven debugger. Gdb allows you to
 trace the execution of programs and examine their internal state at
@@ -192,20 +191,17 @@ GDB w postaci biblioteki statycznej.
 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
 %{__rm} gdb/m2-exp.c gdb/p-exp.c
 
+%patch0 -p1
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
-%patch103 -p1
 %patch104 -p1
 %patch105 -p1
 %patch106 -p1
 %patch110 -p1
 
-%patch112 -p1
-%patch113 -p1
 %patch114 -p1
 %patch115 -p1
-%patch116 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -233,9 +229,11 @@ sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
       gdb/gcore.in \
       src-release.sh
 
+sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
+
 %build
 # omit hand-written gdb/testsuite aclocal.m4
-for dir in gdb gdb/gdbserver ; do
+for dir in gdb gdbserver ; do
        olddir=$(pwd)
        cd $dir
        %{__rm} aclocal.m4
@@ -329,9 +327,9 @@ cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
 # These are part of binutils:
 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -358,6 +356,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
 %endif
+%ifarch aarch64
+%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
+%endif
 %{?with_guile:%{_datadir}/gdb/guile}
 %{_datadir}/gdb/syscalls
 %{_datadir}/gdb/system-gdbinit
@@ -390,3 +391,5 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libdecnumber.a
 %{_libdir}/libgdb.a
 %{_includedir}/gdb
+# -devel?
+%{_includedir}/sim
This page took 0.04061 seconds and 4 git commands to generate.