]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- use macros in %{pre,post}{,un}
[packages/gdb.git] / gdb.spec
index e8eddd0f8a9e217407b990edad5481740cf8fe93..13419307f7c520c1c47b538d3ed1106cffb88c8d 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -4,48 +4,50 @@ Summary(fr):  D
 Summary(pl):   Symboliczny odpluskwiacz dla C i innych jêzyków
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
-Version:       4.18
-Release:       7
-Copyright:     GPL
+Version:       5.0
+Release:       6
+License:       GPL
 Group:         Development/Debuggers
 Group(pl):     Programowanie/Odpluskwiacze
-Source:                ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
-Patch0:                gdb-info.patch
-Patch1:                gdb-sigtramp.patch
-Patch2:                gdb-sparc.patch
-Patch3:                gdb-xref.patch
-Patch4:                gdb-sparcmin.patch
-Patch5:                gdb-threads.patch
-Patch6:                gdb-shared-readline.patch
-Prereq:                /usr/sbin/fix-info-dir
-BuildRequires: ncurses-devel >= 5.0
-BuildRequires: readline-devel >= 4.1
-Buildroot:     /tmp/%{name}-%{version}-root
+Group(de):     Entwicklung/Debugger
+Source0:       ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
+Patch0:                %{name}-gettext.patch
+Patch1:                %{name}-ncurses.patch
+Patch2:                %{name}-readline.patch
+Patch3:                %{name}-info.patch
+Patch4:                %{name}-procfs.patch
+BuildRequires: ncurses-devel >= 5.2
+BuildRequires: readline-devel >= 4.2
+BuildRequires: XFree86-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Gdb is a full featured, command driven debugger. Gdb allows you to trace the
-execution of programs and examine their internal state at any time. Gdb
-works for C and C++ compiled with the GNU C compiler gcc.
+Gdb is a full featured, command driven debugger. Gdb allows you to
+trace the execution of programs and examine their internal state at
+any time. Gdb works for C and C++ compiled with the GNU C compiler
+gcc.
 
 %description -l de
-dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
-inneren Zustand überprüfen können. Er funktioniert für C und mit 
-GNU C kompiliertes C++. 
+dem Sie die Ausführung von Programmen verfolgen und jederzeit den
+inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
+kompiliertes C++.
 
 %description -l fr
 Débugger complet, piloté par commandes. Permet de tracer l'exécution
-des programmes et d'examiner à tout moment leur état interne. Fonctionne
-avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
+des programmes et d'examiner à tout moment leur état interne.
+Fonctionne avec les binaires C et C++ compilés avec le compilateur C
+de GNU, gcc.
 
 %description -l pl
-Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym ¶ledziæ
-wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb umo¿liwia
-odpluskwianie programów napisanych w C/C++ i skompilowanych przy pomocy
-kompilatora GNU (gcc).
+Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
+¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
+umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
+przy pomocy kompilatora GNU (gcc).
 
 %description -l tr
-Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
-ve herhangi bir anda programýn durumunu inceleme olanaðý verir.
+Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
+(trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
+verir.
 
 %prep
 %setup -q
@@ -54,41 +56,53 @@ ve herhangi bir anda program
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
-./configure %{_target_platform} \
-       --prefix=%{_prefix} \
-       --infodir=%{_infodir} \
-       --mandir=%{_mandir} \
-       --enable-shared
-
-make
-make info
+(cd gdb; aclocal; autoconf; cd ..)
+# !! Don't enable shared here !! 
+# This will cause serious problems --misiek
+%configure \
+       --disable-shared \
+       --enable-nls \
+       --without-included-gettext \
+       --enable-multi-ice \
+       --enable-gdbmi \
+       --enable-netrom \
+       --with-cpu=%{_target_cpu} \
+       --with-x \
+%ifnarch alpha
+       --with-mmalloc \
+%endif
+       --with-mmap
+#      --enable-tui
+
+# rebuild main Makefile again (due to some bug, Makefile is deleted)
+%configure \
+       --norecursion
+                       
+%{__make}
+%{__make} info
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_infodir}
 
-make install \
+%{__make} install install-info \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
+       bindir=$RPM_BUILD_ROOT%{_bindir} \
+       sbindir=$RPM_BUILD_ROOT%{_sbindir} \
        infodir=$RPM_BUILD_ROOT%{_infodir} \
+       includedir=$RPM_BUILD_ROOT%{_includedir} \
+       libdir=$RPM_BUILD_ROOT%{_libdir} \
        mandir=$RPM_BUILD_ROOT%{_mandir}
 
-# install by hand
-install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
-
-strip $RPM_BUILD_ROOT%{_bindir}/*
-
-gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
+gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
 
 %post
-/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%fix_info_dir
 
 %postun
-/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%fix_info_dir
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.140395 seconds and 4 git commands to generate.