]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- updated for 5.1
[packages/gdb.git] / gdb.spec
index d521e8254d412a92c827603a0e8a63ade0130e94..07184f07722edcd03f06dbb9f24ca565edc0ff5f 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,16 +1,19 @@
 Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de):   Symbolischer Debugger für C und andere Sprachen 
+Summary(es):   Depurador de programas C y otras lenguajes
 Summary(fr):   Débugger symbolique pour C et d'autres langages
 Summary(pl):   Symboliczny odpluskwiacz dla C i innych jêzyków
+Summary(pt_BR):        Depurador de programas C e outras linguagens
 Summary(tr):   C ve diðer diller için sembolik hata ayýklayýcý
 Name:          gdb
-Version:       5.0
-Release:       6
+Version:       5.1
+Release:       1
 License:       GPL
 Group:         Development/Debuggers
-Group(pl):     Programowanie/Odpluskwiacze
 Group(de):     Entwicklung/Debugger
-Source0:       ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
+Group(pl):     Programowanie/Odpluskwiacze
+Source0:       ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
+Source1:       %{name}-non-english-man-pages.tar.bz2
 Patch0:                %{name}-gettext.patch
 Patch1:                %{name}-ncurses.patch
 Patch2:                %{name}-readline.patch
@@ -19,6 +22,9 @@ Patch4:               %{name}-procfs.patch
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 4.2
 BuildRequires: XFree86-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -32,6 +38,12 @@ dem Sie die Ausf
 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
 kompiliertes C++.
 
+%description -l es
+Este es un debugger orientado a comandos repleto de características.
+Te permite rastrear la ejecución de programas y examinar su estado
+interno a cualquier momento. Funciona para C y C++ compilado con el
+compilador GNU C.
+
 %description -l fr
 Débugger complet, piloté par commandes. Permet de tracer l'exécution
 des programmes et d'examiner à tout moment leur état interne.
@@ -44,6 +56,12 @@ Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj
 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
 przy pomocy kompilatora GNU (gcc).
 
+%description -l pt_BR
+Este é um debugger orientado a comandos repleto de características.
+Ele permite à você rastrear a execução de programas e examinar o seu
+estado interno a qualquer momento. Ele funciona para para C e C++
+compilado com o compilador GNU C.
+
 %description -l tr
 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
@@ -58,28 +76,39 @@ verir.
 %patch4 -p1
 
 %build
-(cd gdb; aclocal; autoconf; cd ..)
+(cd gdb; libtoolize --copy --force; aclocal; autoconf)
+(cd gdb/doc; autoconf)
+(cd gdb/testsuite; autoconf)
+(cd gdb/testsuite/gdb.asm; autoconf)
+(cd gdb/testsuite/gdb.base; autoconf)
+(cd gdb/testsuite/gdb.c++; autoconf)
+(cd gdb/testsuite/gdb.chill; autoconf)
+(cd gdb/testsuite/gdb.disasm; autoconf)
+(cd gdb/testsuite/gdb.fortran; autoconf)
+(cd gdb/testsuite/gdb.java; autoconf)
+(cd gdb/testsuite/gdb.mi; autoconf)
+(cd gdb/testsuite/gdb.stabs; autoconf)
+(cd gdb/testsuite/gdb.threads; autoconf)
+(cd gdb/testsuite/gdb.trace; autoconf)
+(cd gdb/gdbserver; autoconf)
 # !! Don't enable shared here !! 
 # This will cause serious problems --misiek
-%configure \
+%configure2_13 \
        --disable-shared \
        --enable-nls \
        --without-included-gettext \
        --enable-multi-ice \
        --enable-gdbmi \
+       --enable-gdcli \
        --enable-netrom \
        --with-cpu=%{_target_cpu} \
        --with-x \
+       --enable-tui \
 %ifnarch alpha
        --with-mmalloc \
 %endif
        --with-mmap
-#      --enable-tui
 
-# rebuild main Makefile again (due to some bug, Makefile is deleted)
-%configure \
-       --norecursion
-                       
 %{__make}
 %{__make} info
 
@@ -96,7 +125,10 @@ install -d $RPM_BUILD_ROOT%{_infodir}
        libdir=$RPM_BUILD_ROOT%{_libdir} \
        mandir=$RPM_BUILD_ROOT%{_mandir}
 
-gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
+bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
@@ -104,13 +136,15 @@ gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
 %postun
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/*
 
 %{_mandir}/man1/*
+%lang(es) %{_mandir}/es/man1/*
+%lang(fr) %{_mandir}/fr/man1/*
+%lang(hu) %{_mandir}/hu/man1/*
+%lang(ja) %{_mandir}/ja/man1/*
+%lang(pl) %{_mandir}/pl/man1/*
 %{_infodir}/gdb*.info*
 %{_infodir}/stabs*.info*
This page took 0.064377 seconds and 4 git commands to generate.