]> git.pld-linux.org Git - packages/gd.git/blobdiff - gd.spec
- release 3, built against libpng >= 1.0.8
[packages/gd.git] / gd.spec
diff --git a/gd.spec b/gd.spec
index 7193eae346cec4b4410389bce87eef2ac24642b7..5c0e21c96a3990e6b04a3ca4f1bff0dc13cfbdc3 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,48 +1,60 @@
-Summary:       Library for PNG creation
-Summary(pl):   Biblioteka do tworzenia PNGów
+Summary:       Library for PNG, JPEG creation
+Summary(pl):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Name:          gd
-Version:       1.6.2
-Release:       1
-Copyright:     BSD-style
+Version:       1.8.3
+Release: 3
+License:       BSD-style
 Group:         Libraries
+Group(fr):     Librairies
 Group(pl):     Biblioteki
 Source0:       ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
-Source1:       gd-ref.html
+Patch0:                gd-pld-patch
+URL:           http://www.boutell.com/gd/
 BuildRequires: zlib-devel
-BuildRequires: libpng-devel
+BuildRequires: libpng >= 1.0.8
 BuildRequires: freetype-devel
-URL:           http://www.boutell.com/gd/
-BuildRoot:     /tmp/%{name}-%{version}-root
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define shlibver %(echo %{version} | cut -f-2 -d.)
 
 %description
-This library allows you to easily create and manipulate PNG image files
-from your C programs.
+gd library creates PNG, JPEG and WBMP images, not GIF images. This is a
+good thing. PNG is a more compact format, and full compression is available.
+JPEG works well with photographic images, and is still more compatible with
+the major Web browsers than even PNG is. WBMP is intended for wireless
+devices (not regular web browsers). Existing code will need modification to
+call or gdImageJpeg instead of gdImageGif.
+
+This library allows you to easily create and manipulate PNG, JPEG image
+files from your C programs.
 
 %description -l pl
-Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami graficznymi
-w formacie PNG.
+Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
+graficznymi w formacie PNG.
 
 %package devel
 Summary:       Development part of the GD library
-Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów.
+Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów
 Group:         Development/Libraries
+Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
 Requires:      %{name} = %{version}
 
 %description devel
-This package contains the files needed for development of programs linked
-against GD.
+This package contains the files needed for development of programs
+linked against GD.
 
 %description -l pl devel
-Pakiet ten zawiera pliki potrzebne do rozwoju programów
-korzystaj±cych z biblioteki GD.
+Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
+z biblioteki GD.
 
 %package static
-Summary:        Static GD library
-Summary(pl):    Statyczna biblioteka GD.
-Group:          Development/Libraries
-Group(pl):      Programowanie/Biblioteki
-Requires:       %{name} = %{version}
+Summary:       Static GD library
+Summary(pl):   Statyczna biblioteka GD
+Group:         Development/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
+Requires:      %{name} = %{version}
 
 %description devel
 This package contains static GD library.
@@ -51,38 +63,54 @@ This package contains static GD library.
 Pakiet ten zawiera statyczn± bibliotekê GD.
 
 %prep
-%setup -q -n %{name}-%{version}
-install %{SOURCE1} .
+%setup -q 
+%patch0 -p1 
 
 %build
-%configure
-make
+CFLAGS="$RPM_OPT_FLAGS -I/usr/include/freetype"
+LDFLAGS="-s"
+export CFLAGS LDFLAGS
+%{__make} libgd.a
+gcc -shared -o libgd.so.%{version} -Wl,-soname=libgd.so.%{shlibver} \
+        `ar t libgd.a` -L/usr/X11R6/lib -lttf -ljpeg -lpng -lz -lm
 
 %install
-rm -rf $RPM_BUILD_ROOT
-make DESTDIR="$RPM_BUILD_ROOT" install
-strip $RPM_BUILD_ROOT{%{_bindir}/*,%{_libdir}/*.so} || :
-gzip -9nf NEWS README index.html gd-ref.html
+
+
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
+%{__make} install \
+        INSTALL_BIN=$RPM_BUILD_ROOT%{_bindir} \
+        INSTALL_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
+        INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
+
+install libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/
+ln -s libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgd.so
+
+#make DESTDIR="$RPM_BUILD_ROOT" install
+
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
+
+gzip -9nf readme.txt index.html 
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+rm -fr $RPM_BUILD_ROOT
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc {NEWS,README}.gz
+%doc readme.txt.gz
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/*.so.*.*
-%attr(644,root,root) %{_libdir}/libgd.la
 
 %files devel
 %defattr(644,root,root,755)
-%doc index.html.gz gd-ref.html.gz
+%doc index.html.gz 
 %attr(755,root,root) %{_libdir}/*.so
 %{_includedir}/*
 
 %files static
 %defattr(644,root,root,755)
-%attr(644,root,root) %{_libdir}/*.a
+%{_libdir}/lib*.a
This page took 0.037548 seconds and 4 git commands to generate.