]> git.pld-linux.org Git - packages/gd.git/blobdiff - gd.spec
- release 5 (for allow upgrade from RH 7).
[packages/gd.git] / gd.spec
diff --git a/gd.spec b/gd.spec
index b90b728dd52e2c45e32c2ee428084b72221cc1d2..1214f07d3998ef572e3dbc0231146aef52deb936 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,22 +1,37 @@
-Summary:       Library for PNG creation
-Summary(pl):   Biblioteka do tworzenia PNGów
+Summary:       Library for PNG, JPEG creation
+Summary(pl):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Name:          gd
-Version:       1.6.3
-Release:       2
+Version:       1.8.3
+Release:       5
 License:       BSD-style
 Group:         Libraries
+Group(de):     Libraries
 Group(fr):     Librairies
 Group(pl):     Biblioteki
 Source0:       ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
+Patch0:                %{name}-ac_am.patch
 URL:           http://www.boutell.com/gd/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
 BuildRequires: zlib-devel
 BuildRequires: libpng-devel
 BuildRequires: freetype-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define shlibver %(echo %{version} | cut -f-2 -d.)
+
 %description
-This library allows you to easily create and manipulate PNG image
-files from your C programs.
+gd library creates PNG, JPEG and WBMP images, not GIF images. This is
+a good thing. PNG is a more compact format, and full compression is
+available. JPEG works well with photographic images, and is still more
+compatible with the major Web browsers than even PNG is. WBMP is
+intended for wireless devices (not regular web browsers). Existing
+code will need modification to call or gdImageJpeg instead of
+gdImageGif.
+
+This library allows you to easily create and manipulate PNG, JPEG
+image files from your C programs.
 
 %description -l pl
 Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
@@ -24,10 +39,13 @@ graficznymi w formacie PNG.
 
 %package devel
 Summary:       Development part of the GD library
-Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów.
+Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów
 Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
 Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
+Requires:      libpng-devel
+Requires:      zlib-devel
 Requires:      %{name} = %{version}
 
 %description devel
@@ -40,8 +58,9 @@ z biblioteki GD.
 
 %package static
 Summary:       Static GD library
-Summary(pl):   Statyczna biblioteka GD.
+Summary(pl):   Statyczna biblioteka GD
 Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
 Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
 Requires:      %{name} = %{version}
@@ -54,22 +73,23 @@ Pakiet ten zawiera statyczn
 
 %prep
 %setup -q 
+%patch0 -p1 
 
 %build
-CFLAGS="$RPM_OPT_FLAGS -I/usr/include/freetype"
-LDFLAGS="-s"
-export CFLAGS LDFLAGS
+libtoolize --copy --force
+automake -a -c
+aclocal
+autoconf
 %configure
-make
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make DESTDIR="$RPM_BUILD_ROOT" install
-
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
+%{__make} install \
+        DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf NEWS README index.html 
+gzip -9nf readme.txt index.html 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -79,7 +99,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {NEWS,README}.gz
+%doc readme.txt.gz
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/*.so.*.*
 
@@ -87,7 +107,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc index.html.gz 
 %attr(755,root,root) %{_libdir}/*.so
-%attr(755,root,root) %{_libdir}/libgd.la
+%attr(755,root,root) %{_libdir}/*.la
 %{_includedir}/*
 
 %files static
This page took 0.078531 seconds and 4 git commands to generate.