]> git.pld-linux.org Git - packages/gd.git/blobdiff - gd.spec
- release 5 (for allow upgrade from RH 7).
[packages/gd.git] / gd.spec
diff --git a/gd.spec b/gd.spec
index 5c572884a6674c62db969ba21875542c0bbee065..1214f07d3998ef572e3dbc0231146aef52deb936 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,42 +1,95 @@
-Summary:     Library for GIF creation
-Name:        gd
-Version:     1.3
-Release:     3
-Source:      ftp://ftp.boutell.com/pub/boutell/gd/%{name}%{version}.tar.gz
-URL:         http://www.boutell.com/gd/
-Patch0:      gd-shared.patch
-Patch1:      gd-non-root.patch
-Copyright:   BSD-style
-Group:       Libraries
-BuildRoot:   /tmp/%{name}-%{version}-root
+Summary:       Library for PNG, JPEG creation
+Summary(pl):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
+Name:          gd
+Version:       1.8.3
+Release:       5
+License:       BSD-style
+Group:         Libraries
+Group(de):     Libraries
+Group(fr):     Librairies
+Group(pl):     Biblioteki
+Source0:       ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
+Patch0:                %{name}-ac_am.patch
+URL:           http://www.boutell.com/gd/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+BuildRequires: zlib-devel
+BuildRequires: libpng-devel
+BuildRequires: freetype-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define shlibver %(echo %{version} | cut -f-2 -d.)
 
 %description
-This library allows you to easily create and manipulate GIF image files
-from your C programs.
+gd library creates PNG, JPEG and WBMP images, not GIF images. This is
+a good thing. PNG is a more compact format, and full compression is
+available. JPEG works well with photographic images, and is still more
+compatible with the major Web browsers than even PNG is. WBMP is
+intended for wireless devices (not regular web browsers). Existing
+code will need modification to call or gdImageJpeg instead of
+gdImageGif.
+
+This library allows you to easily create and manipulate PNG, JPEG
+image files from your C programs.
+
+%description -l pl
+Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
+graficznymi w formacie PNG.
 
 %package devel
-Summary:     Development part of the GD library
-Group:       Development/Libraries
-Requires:    %{name} = %{version}
+Summary:       Development part of the GD library
+Summary(pl):   Czê¶æ biblioteki GD przeznaczona dla developerów
+Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
+Requires:      libpng-devel
+Requires:      zlib-devel
+Requires:      %{name} = %{version}
+
+%description devel
+This package contains the files needed for development of programs
+linked against GD.
+
+%description -l pl devel
+Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
+z biblioteki GD.
+
+%package static
+Summary:       Static GD library
+Summary(pl):   Statyczna biblioteka GD
+Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
+Requires:      %{name} = %{version}
 
 %description devel
-This package contains the files needed for development of programs linked
-against GD.
+This package contains static GD library.
+
+%description -l pl static
+Pakiet ten zawiera statyczn± bibliotekê GD.
 
 %prep
-%setup -q -n %{name}%{version}
-%patch0 -p1
-%patch1 -p1
+%setup -q 
+%patch0 -p1 
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" make
+libtoolize --copy --force
+automake -a -c
+aclocal
+autoconf
+%configure
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/usr/{include,lib}
 
-install {gd,gdfontg,gdfontl,gdfontmb,gdfonts,gdfontt}.h $RPM_BUILD_ROOT/usr/include
-install -s libgd.so* $RPM_BUILD_ROOT/usr/lib
+%{__make} install \
+        DESTDIR=$RPM_BUILD_ROOT
+
+gzip -9nf readme.txt index.html 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -45,26 +98,18 @@ rm -rf $RPM_BUILD_ROOT
 %postun -p /sbin/ldconfig
 
 %files
-%attr(755, root, root) /usr/lib/*.so.*
+%defattr(644,root,root,755)
+%doc readme.txt.gz
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/*.so.*.*
 
 %files devel
-%defattr(644, root, root, 755)
-%doc readme.txt index.html
-%attr(755, root, root) /usr/lib/*.so
-/usr/include/*
-
-%changelog
-* Thu Sep 24  1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [1.3-4]
-- added -q %setup parameter,
-- changed Buildroot to /tmp/%%{name}-%%{version}-root,
-- added using %%{name} and %%{version} in Source and %setup,
-- added %postun,
-- changed dependencies to "Requires: %%{name} = %%{version}" in devel
-  subpackage,
-- added striping shared libraries,
-- added %attr and %defattr macros in %files (allow build package from
-  non-root account).
-
-* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
-- built for 5.2
+%defattr(644,root,root,755)
+%doc index.html.gz 
+%attr(755,root,root) %{_libdir}/*.so
+%attr(755,root,root) %{_libdir}/*.la
+%{_includedir}/*
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
This page took 0.081701 seconds and 4 git commands to generate.