]> git.pld-linux.org Git - packages/gcc4.git/blobdiff - gcc4.spec
- updated to 3.4.3-20041029 (fix for regression in CSE).
[packages/gcc4.git] / gcc4.spec
index ba11a64b829d091ac98addca683c8a87d9c159f9..933eb949e5728fa154579951ae93e4a1bd394c2b 100644 (file)
--- a/gcc4.spec
+++ b/gcc4.spec
@@ -1,16 +1,18 @@
 #
 # TODO:
 #              - http://gcc.gnu.org/PR11203
-#              - http://gcc.gnu.org/PR17384
+#              - http://gcc.gnu.org/PR14776
 #              - http://gcc.gnu.org/PR17567
 #
+# - after 3.4.3 release snaps should go to DEVEL branch
+#
 # Conditional build:
 %bcond_without ada             # build without ADA support
 %bcond_without java            # build without Java support
 %bcond_without objc            # build without objc support
 %bcond_with    ssp             # build with stack-smashing protector support
 #
-%define                _snap           20041008
+%define                _snap           20041029
 #
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es):   Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -26,11 +28,15 @@ Group:              Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
 Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/3.4-%{_snap}/gcc-3.4-%{_snap}.tar.bz2
-# Source0-md5: 9e5a58db111be1b31227b5a1139a740b
+# Source0-md5: f804426952f69c0b27d75d3e7cda03fc
+# Source0-size:        25077382
 Source1:       http://ep09.pld-linux.org/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 4736f3422ddfb808423b745629acc321
+# Source1-size:        63307
 Source2:       http://www.trl.ibm.com/projects/security/ssp/gcc2_95_3/gcc_stack_protect.m4.gz
 # Source2-md5: 07d93ad5fc07ca44cdaba46c658820de
+# Source2-size:        667
+Source3:       gcc_visibility.m4
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
 Patch2:                %{name}-ada-link-new-libgnat.patch
@@ -826,6 +832,7 @@ rm -rf $gccdir/install-tools
 %if %{with ssp}
 zcat %{SOURCE2} > $RPM_BUILD_ROOT%{_aclocaldir}/gcc_stack_protect.m4
 %endif
+install %{SOURCE3} $RPM_BUILD_ROOT%{_aclocaldir}/gcc_visibility.m4
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -872,6 +879,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/gcc/*/*
 %dir %{_libdir}/gcc/*/*/include
 %{?with_ssp:%{_aclocaldir}/gcc_stack_protect.m4}
+%{_aclocaldir}/gcc_visibility.m4
 
 %attr(755,root,root) %{_bindir}/*-gcc*
 %attr(755,root,root) %{_bindir}/gcc
@@ -894,6 +902,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /lib/cpp
 
 %attr(755,root,root) %{_slibdir}*/lib*.so
+%ifarch ia64
+%{_slibdir}*/libunwind.a
+%endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
 %{_libdir}/gcc/*/*/libgcc_eh.a
This page took 0.050515 seconds and 4 git commands to generate.