]> git.pld-linux.org Git - packages/gcc4.git/blobdiff - gcc4.spec
- next PR / zywiec rox ;) /.
[packages/gcc4.git] / gcc4.spec
index 253562166ecc33c9f02a54d81db4e4059e17d010..8ecfc3b982d67daaf9ee893606838930095f470e 100644 (file)
--- a/gcc4.spec
+++ b/gcc4.spec
@@ -1,36 +1,33 @@
 #
 # TODO:
 #              - http://gcc.gnu.org/PR11203
-#              - http://gcc.gnu.org/PR17384
-#              - http://gcc.gnu.org/PR17567
+#              - http://gcc.gnu.org/PR14776
+#              - http://gcc.gnu.org/PR18648
+#              - http://gcc.gnu.org/PR18676
 #
 # Conditional build:
 %bcond_without ada             # build without ADA support
 %bcond_without java            # build without Java support
-%bcond_without objc            # build without objc support
+%bcond_without objc            # build without ObjC support
 %bcond_with    ssp             # build with stack-smashing protector support
 #
-%define                _snap           20041008
-#
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es):   Colección de compiladores GNU: el compilador C y ficheros compartidos
 Summary(pl):   Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       3.4.3
-Release:       0.%{_snap}.1
-#Release:      1
+Release:       2
 Epoch:         5
 License:       GPL
 Group:         Development/Languages
-#Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
-#Source0:      ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
-Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/3.4-%{_snap}/gcc-3.4-%{_snap}.tar.bz2
-# Source0-md5: 9e5a58db111be1b31227b5a1139a740b
+Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: e744b30c834360fccac41eb7269a3011
 Source1:       http://ep09.pld-linux.org/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 4736f3422ddfb808423b745629acc321
 Source2:       http://www.trl.ibm.com/projects/security/ssp/gcc2_95_3/gcc_stack_protect.m4.gz
 # Source2-md5: 07d93ad5fc07ca44cdaba46c658820de
+Source3:       gcc_visibility.m4
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
 Patch2:                %{name}-ada-link-new-libgnat.patch
@@ -69,7 +66,7 @@ Patch9:               %{name}-visibility.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: binutils >= 2.15.91.0.2
+BuildRequires: binutils >= 2:2.15.91.0.2
 BuildRequires: bison
 BuildRequires: fileutils >= 4.0.41
 BuildRequires: flex
@@ -79,11 +76,11 @@ BuildRequires:      gcc-ada
 %endif
 BuildRequires: gettext-devel
 BuildRequires: glibc-devel >= 2.2.5-20
-BuildRequires: gzip
 BuildRequires: perl-devel
 BuildRequires: texinfo >= 4.1
 BuildRequires: zlib-devel
-Requires:      binutils >= 2.15.91.0.2
+Requires:      binutils >= 2:2.15.91.0.2
+Requires:      gcc-dirs >= 1.0-3
 Requires:      libgcc = %{epoch}:%{version}-%{release}
 Provides:      cpp = %{epoch}:%{version}-%{release}
 %{?with_ada:Provides:  gcc(ada)}
@@ -642,12 +639,7 @@ Ten pakiet zawiera biblioteki statyczne dla program
 Adzie.
 
 %prep
-# prerelease
-#setup -q -n %{name}-%{version}-%{_snap} -a1
-# snapshot
-%setup -q -n %{name}-3.4-%{_snap} -a1
-# final
-#setup -q -n %{name}-%{version} -a1
+%setup -q -a1
 
 %patch0 -p1
 %patch1 -p1
@@ -739,11 +731,6 @@ for tgt in gnatlib-shared gnattools gnatlib; do
 done
 %endif
 
-# snapshot doesn't contain these files...
-[ -r "NEWS" ] || touch NEWS
-[ -r "gcc/f/BUGS" ] || touch gcc/f/BUGS
-[ -r "gcc/f/NEWS" ] || touch gcc/f/NEWS
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
@@ -827,6 +814,7 @@ rm -rf $gccdir/install-tools
 %if %{with ssp}
 zcat %{SOURCE2} > $RPM_BUILD_ROOT%{_aclocaldir}/gcc_stack_protect.m4
 %endif
+install %{SOURCE3} $RPM_BUILD_ROOT%{_aclocaldir}/gcc_visibility.m4
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -868,11 +856,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ChangeLog.general MAINTAINERS NEWS bugs.html faq.html
 %doc gcc/{ChangeLog,ONEWS,README.Portability}
-%dir %{_libdir}/gcc
-%dir %{_libdir}/gcc/*
 %dir %{_libdir}/gcc/*/*
 %dir %{_libdir}/gcc/*/*/include
 %{?with_ssp:%{_aclocaldir}/gcc_stack_protect.m4}
+%{_aclocaldir}/gcc_visibility.m4
 
 %attr(755,root,root) %{_bindir}/*-gcc*
 %attr(755,root,root) %{_bindir}/gcc
@@ -895,6 +882,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /lib/cpp
 
 %attr(755,root,root) %{_slibdir}*/lib*.so
+%ifarch ia64
+%{_slibdir}*/libunwind.a
+%endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
 %{_libdir}/gcc/*/*/libgcc_eh.a
This page took 0.107434 seconds and 4 git commands to generate.