]> git.pld-linux.org Git - packages/gcc4.git/blobdiff - gcc4.spec
- proper symlink /lib/cpp (not only for %with_ada)
[packages/gcc4.git] / gcc4.spec
index 97e3d56464df7e6540a667e07bb96a43d5b7e4ea..7e1bf9b6ac67d55240778bef7d5bca437efb29c8 100644 (file)
--- a/gcc4.spec
+++ b/gcc4.spec
@@ -4,6 +4,15 @@
 %bcond_without fortran         # build without Fortran support
 %bcond_without java            # build without Java support
 %bcond_without objc            # build without ObjC support
+
+%bcond_with    bootstrap
+
+%if %{with bootstrap}
+%undefine      with_fortran
+%undefine      with_java
+%undefine      with_objc
+%endif
+
 #
 # TODO:
 #              - http://gcc.gnu.org/PR11203 (inline-asm)
 #              - disable internal zlib usage
 #              - translations from gcc.spec:HEAD
 #
-%define                _snap           20050109
+%define                _snap           20050213
 #
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(pl):   Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
 Name:          gcc
 Epoch:         5
 Version:       4.0.0
-Release:       0.%{_snap}.2
+Release:       0.%{_snap}.1
 License:       GPL
 Group:         Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
 Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
-# Source0-md5: 599c4ea4915c32accbb4dcfda1be4ca9
+# Source0-md5: 56c68edf4047dc42aeda22186cedb40b
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
 Patch2:                %{name}-nodebug.patch
@@ -487,6 +496,7 @@ TEXCONFIG=false \
        --enable-nls \
        --with-gnu-as \
        --with-gnu-ld \
+       --with-demangler-in-ld \
        --with-system-zlib \
        --with-slibdir=%{_slibdir} \
        --without-x \
@@ -496,10 +506,10 @@ TEXCONFIG=false \
 cd ..
 
 %{__make} -C obj-%{_target_platform} \
-       profiledbootstrap \
+       %{!?with_bootstrap:profiledbootstrap} \
        GCJFLAGS="%{rpmcflags}" \
        BOOT_CFLAGS="%{rpmcflags}" \
-       STAGE1_CFLAGS="%{rpmcflags}" \
+       STAGE1_CFLAGS="%{rpmcflags} -O0" \
        LDFLAGS_FOR_TARGET="%{rpmldflags}" \
        mandir=%{_mandir} \
        infodir=%{_infodir}
@@ -522,6 +532,7 @@ ln -sf      $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
        $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
 %endif
 
+ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
 
@@ -540,7 +551,6 @@ ln -sf      libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
 ln -sf libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
 ln -sf libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
 ln -sf libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
-ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 %endif
 
 cd ..
@@ -579,7 +589,7 @@ mkdir       $gccdir/tmp
 %{?with_objc:mv -f $gccdir/include/objc        $gccdir/tmp}
 mv -f  $gccdir/include/syslimits.h $gccdir/tmp
 rm -rf $gccdir/include
- mv -f $gccdir/tmp $gccdir/include
+mv -f  $gccdir/tmp $gccdir/include
 cp -f  $gccdir/install-tools/include/*.h $gccdir/include
 # but we don't want anything more from install-tools
 rm -rf $gccdir/install-tools
@@ -834,8 +844,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc/*/*/include/gcj
 %dir %{_libdir}/security
 %{_libdir}/security/*
-%dir %{_datadir}/java
-%{_datadir}/java/libgcj*.jar
+%{_javadir}/libgcj*.jar
 %{_libdir}/lib*cj.spec
 %{_libdir}/lib*cj*.la
 %attr(755,root,root) %{_libdir}/lib*cj*.so
This page took 0.039918 seconds and 4 git commands to generate.