]> git.pld-linux.org Git - packages/gammu.git/blobdiff - gammu.spec
- tabs in preamble
[packages/gammu.git] / gammu.spec
index 7f469f8d04568116ebd5c6a33c8338575e85b355..a799f01eeded8b03538dc0731cb6dd9331167018 100644 (file)
@@ -1,20 +1,19 @@
-%define         major   0
-%define         minor   85
-
 Summary:       Linux/Unix tool suite for Nokia mobile phones
-Summary(pl):   Linuksowy/Uniksowy zestaw narzêdzi dla telefonów komórkowych Nokia
+Summary(pl.UTF-8):     Linuksowy/uniksowy zestaw narzędzi dla telefonów komórkowych Nokia
 Name:          gammu
-Version:       %{major}.%{minor}
+Version:       1.07.00
 Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Applications/Communications
-Source0:       http://www.mwiacek.com/zips/gsm/%{name}/older/%{name}-%{major}%{minor}.tar.gz
-# Source0-md5: 9e275a3d8f1e691816aa8e8ed695b71f
+Source0:       http://www.mwiacek.com/zips/gsm/gammu/stable/1_0x/%{name}-%{version}.tar.gz
+# Source0-md5: b706e35a6f003acc47f8c2bb71fa8036
 Patch0:                %{name}-etc_dir.patch
-URL:           http://www.mwiacek.com/english/gsm/gammu/gammu.html
+Patch1:                %{name}-no_nss.patch
+URL:           http://www.gammu.org/
 BuildRequires: autoconf
 BuildRequires: bluez-libs-devel
+BuildRequires: mysql-devel
 Provides:      mygnokii2
 Obsoletes:     mygnokii2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -28,44 +27,74 @@ WaveCom, IPAQ, and other). It has a command line version with many
 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
 calls, etc. It can also make full backups and restore them.
 
-%description -l pl
-Gammu (poprzednio znany jako MyGnokii2) jest narzêdziem do zarz±dzania
-ró¿nymi telefonami komórkowymi i modemami. Aktualnie obs³uguje Nokie
+%description -l pl.UTF-8
+Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
+różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
-82xx, 8310, 9110 i 3210 oraz urz±dzenia AT (takie jak Siemens,
-Alcatel, WaveCom, IPAQ i inne). Ma wersjê dzia³aj±c± z linii poleceñ z
-wieloma funkcjami do dzwonków, ksi±¿ki telefonicznej, SMS-ów, logo,
-WAP, daty/czasu, budzika, dzwonienia itp. Mo¿e tak¿e wykonywaæ pe³ne
-kopie zapasowe danych i odtwarzaæ je.
+82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
+Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
+wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
+WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
+kopie zapasowe danych i odtwarzać je.
 
 %prep
-%setup -q -n %{name}-%{major}%{minor}
-%patch0 -p1
+%setup -q
+#%patch0 -p1
+%patch1 -p1
+cp -f version cfg/autoconf/VERSION
+mv docs/docs/english/gammu.1 .
 
 %build
 cd cfg/autoconf
 %{__autoconf}
-%configure
+%configure \
+       --disable-static \
+       --without-rpmdir \
+       --enable-cb \
+       --enable-7110incoming \
+       --enable-6210calendar \
+       --with-localedir=%{_datadir}/%{name}
 cd ../..
-%{__make}
+%{__make} shared
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_examplesdir}/%{name},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version},%{_datadir}/%{name}}
+%{__make} installlocales installlibonly \
+       DESTDIR=$RPM_BUILD_ROOT \
+       prefix=%{_prefix} \
+       INSTALL_LIB_DIR=%{_libdir} \
+       INSTALL_MAN_DIR=%{_mandir}/man1 \
+       FIND=find
 
-install %{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
+install -D gammu.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
-mv -f docs/docs/english/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
-mv -f docs/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}
-mv -f docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}
+cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
+# anybody feels like developing gammu-based apps?
+rm -rf $RPM_BUILD_ROOT{%{_includedir},%{_libdir}/{*.{so,a},pkgconfig}}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc changelog docs/* readme.txt
+%doc changelog docs/docs/english/gammu.htm other/bash readme.txt
+%doc %lang(it) docs/docs/italian
 %attr(755,root,root) %{_bindir}/%{name}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/gammurc
-%{_examplesdir}/%{name}
-%{_mandir}/man1/*.1*
+%attr(755,root,root) %{_libdir}/*.so.*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
+%dir %{_datadir}/%{name}
+%lang(cs) %{_datadir}/gammu/gammu_cs.txt
+%lang(de) %{_datadir}/gammu/gammu_de.txt
+%lang(es) %{_datadir}/gammu/gammu_es.txt
+%lang(it) %{_datadir}/gammu/gammu_it.txt
+%lang(pl) %{_datadir}/gammu/gammu_pl.txt
+%lang(ru) %{_datadir}/gammu/gammu_ru.txt
+%{_datadir}/gammu/gammu_us.txt
+%{_examplesdir}/%{name}-%{version}
+%{_mandir}/man1/*
This page took 0.087764 seconds and 4 git commands to generate.