]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- s/bonobo-activation/libbonobo/ in {,B}R
[packages/galeon.git] / galeon.spec
index 21efe00206e322bb7838f5722225f94ea997c4d7..e76983e2014922125f8f5a07a4d6e1e4adeeb6ab 100644 (file)
@@ -1,46 +1,62 @@
-
-%define                minmozver       0.9.9
+#
+# Conditional build:
+# _with_gcc2           - compile using gcc2 to get working java plugin.
+#                        Flash plugin seems to still doesn't work, use 
+#                        mozilla instead. To compile wit this option, You 
+#                        have to install mozilla compiled with gcc2.
+#
+%define                minmozver       1.4b
+%define                snap            20030518
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
+Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.2.1
-Release:       2
+Version:       1.3.4
+Release:       1.%{snap}.1
+#Release:      1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://prdownloads.sourceforge.net/galeon/%{name}-%{version}.tar.gz
+#Source0:      http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
+Source0:       %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
-Patch0:                %{name}-mozilla_five_home.patch
-Patch1:                %{name}-am_fix.patch
-Patch2:                %{name}-vfs.patch
 URL:           http://galeon.sourceforge.net/
-BuildRequires: GConf-devel >= 1.0.4-1
-BuildRequires: ORBit-devel >= 0.5.0
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: GConf2-devel >= 2.0.0
+BuildRequires: ORBit2-devel >= 2.0.0
 BuildRequires: bison
-BuildRequires: gdk-pixbuf-devel >= 0.10.
 BuildRequires: gettext-devel
-BuildRequires: gnome-core-devel >= 1.2.0
-BuildRequires: gnome-libs-devel >= 1.2.0
-BuildRequires: gnome-vfs-devel >= 0.5
+BuildRequires: gnome-vfs2-devel >= 2.0.0
+BuildRequires: gtk+2-devel >= 2.0.6
 BuildRequires: intltool
-BuildRequires: libglade-devel
+BuildRequires: libbonobo-devel >= 2.3.1-4
+BuildRequires: libbonoboui-devel >= 2.1.1
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: libgnomeui-devel >= 2.0.5
 BuildRequires: libstdc++-devel
-BuildRequires: libxml-devel >= 1.8.7
+BuildRequires: libxml2-devel >= 2.4.0
 BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: oaf-devel >= 0.6.2
-BuildRequires: openssl-devel
-Requires:      GConf >= 1.0.4-1
+BuildRequires: nautilus-devel >= 2.0.0
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: scrollkeeper >= 0.1.4
+BuildRequires: rpm-build >= 4.1-10
+Requires:      libbonobo >= 2.3.1-4
 Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
+Requires(post):        GConf2
+Requires(post):        mozilla
+Requires(post):        scrollkeeper
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
-%define                _noautoreqdep   libgtkembedmoz.so libplds4.so libplc4.so libnspr4.so libgtksuperwin.so libxpcom.so
+%define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME
+%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
+%define         __cc            gcc2
+%define         __cxx           gcc2
+%endif
 
 %description
 Gnome browser based on Gecko (Mozilla rendering engine).
@@ -54,66 +70,64 @@ O galeon 
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 rm -f missing
-xml-i18n-toolize --copy --force
-gettextize --copy --force
-aclocal -I %{_aclocaldir}/gnome
-autoconf
-automake -a -c -f
+glib-gettextize --copy --force
+intltoolize --copy --force
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
 %configure \
        --with-mozilla-libs=%{_libdir} \
        --with-mozilla-includes=%{_includedir}/mozilla \
        --with-mozilla-home=%{_libdir}/mozilla \
        --enable-nls \
        --disable-included-gettext \
-       --disable-install-schemas \
+       --disable-schemas-install \
        --disable-werror \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas
+       --with-mozilla-snapshot=1.4b \
+       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       --enable-nautilus-view=yes
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW
+       DESTDIR=$RPM_BUILD_ROOT 
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
-
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-gzip -9nf AUTHORS ChangeLog NEWS README
+%find_lang galeon-2.0
 
-%find_lang %{name} --with-gnome
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
+/usr/bin/scrollkeeper-update
 umask 022
 rm -f %{_libdir}/mozilla/component.reg
 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-gconftool --shutdown
-GCONF_CONFIG_SOURCE=xml::%{_sysconfdir}/gconf/gconf.xml.defaults gconftool --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas 2>dev/null >/dev/null
+%gconf_schema_install
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%postun -p /usr/bin/scrollkeeper-update
 
-%files -f %{name}.lang
+%files -f galeon-2.0.lang
 %defattr(644,root,root,755)
-%doc *.gz
+%doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_applnkdir}/Network/WWW/*
 %{_libdir}/%{name}
+%{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/gnome/help/galeon-manual
-%{_datadir}/gnome/ui/*.xml
-%{_datadir}/oaf/*
-%{_datadir}/omf/*
+%{_datadir}/applications/*
+%{_datadir}/gnome/help/*
+%{_datadir}/gnome-2.0/ui/*.xml
+%{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
 %{_sysconfdir}/gconf/schemas/*
This page took 0.067979 seconds and 4 git commands to generate.