]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- s/mozilla-embedded/mozilla/
[packages/galeon.git] / galeon.spec
index eef144c67ef80d39e06c56d412b9606d7f8b3dd0..cb307f1e138b0f42ee56ed33b5d2c71101bd1303 100644 (file)
@@ -1,73 +1,84 @@
 #
 # Conditional build:
 # _with_gcc2           - compile using gcc2 to get working java plugin.
-#                        Flash plugin seems to still doesn't work, use 
-#                        mozilla instead. To compile wit this option, You 
+#                        Flash plugin seems to still doesn't work, use
+#                        mozilla instead. To compile wit this option, You
 #                        have to install mozilla compiled with gcc2.
 #
-%define                minmozver       1.3b-0.2
-%define                snap            20030305
+%define                minmozver       1.5b
+%define                snap    20030905
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
+Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.3.3
-Release:       1
+Version:       1.3.9
+Release:       2
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
 #Source0:      %{name}-%{version}-%{snap}.tar.bz2
+Source0:       http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
+# Source0-md5: f948047373884a0dc8d841930d11680c
 Source1:       %{name}-config-tool.1
 URL:           http://galeon.sourceforge.net/
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-history-xml.patch
+BuildRequires: GConf2-devel >= 2.0.0
+BuildRequires: ORBit2-devel >= 2.7.5-1
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: GConf2-devel
-BuildRequires: ORBit2-devel
 BuildRequires: bison
-BuildRequires: bonobo-activation-devel >= 2.2.0
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel
+BuildRequires: gnome-vfs2-devel >= 2.0.0
 BuildRequires: gtk+2-devel >= 2.0.6
 BuildRequires: intltool
-BuildRequires: libglade2-devel
-BuildRequires: libgnomeui-devel
+BuildRequires: libbonobo-devel >= 2.3.1-4
+BuildRequires: libbonoboui-devel >= 2.3.3-2
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: libgnomeui-devel >= 2.3.3.1-2
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.0.0
-BuildRequires: openssl-devel >= 0.9.7
-BuildRequires: scrollkeeper
-BuildRequires: bonobo-activation >= 2.2.0
+BuildRequires: libxml2-devel >= 2.4.0
+BuildRequires: mozilla-devel >= %{minmozver}
+BuildRequires: nautilus-devel >= 2.3.7-3
+BuildRequires: openssl-devel >= 0.9.7c
+BuildRequires: scrollkeeper >= 0.1.4
 BuildRequires: rpm-build >= 4.1-10
-Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
 Requires(post):        GConf2
 Requires(post):        mozilla
 Requires(post):        scrollkeeper
+Requires:      libbonobo >= 2.3.1-4
+Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
+%if %{?_with_gcc2:1}%{!?_with_gcc2:0}
 %define         __cc            gcc2
 %define         __cxx           gcc2
 %endif
 
 %description
-Gnome browser based on Gecko (Mozilla rendering engine).
+GNOME browser based on Gecko (Mozilla rendering engine).
 
 %description -l pl
 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
 %description -l pt_BR
-O galeon é um browser para o gnome baseado no mozilla.
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+
+# regenerate - didn't compile with ORBit2 2.7.2
+cd idl
+orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
+mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
@@ -86,7 +97,6 @@ intltoolize --copy --force
        --disable-included-gettext \
        --disable-schemas-install \
        --disable-werror \
-       --with-mozilla-snapshot=1.3b \
        --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
        --enable-nautilus-view=yes
 
@@ -97,20 +107,20 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT 
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-%find_lang galeon-2.0
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+
+# galeon-2.0.mo, but gnome/help/galeon
+%find_lang galeon-2.0 --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /usr/bin/scrollkeeper-update
-umask 022
-rm -f %{_libdir}/mozilla/component.reg
-MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
 %gconf_schema_install
 
 %postun -p /usr/bin/scrollkeeper-update
@@ -119,11 +129,10 @@ MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/applications/*
-%{_datadir}/gnome/help/*
+%{_desktopdir}/*
 %{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
This page took 0.059558 seconds and 4 git commands to generate.