]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- rel 2
[packages/galeon.git] / galeon.spec
index 555ebfb8a93d26c6339adbad31e24c81d802bbf0..c468b559ce20a67c823a01c1d593eccd8f6f097c 100644 (file)
@@ -1,60 +1,68 @@
 #
 # Conditional build:
-# _with_gcc2           - compile using gcc2 to get working java plugin.
-#                        Flash plugin seems to still doesn't work, use
-#                        mozilla instead. To compile wit this option, You
-#                        have to install mozilla compiled with gcc2.
+%bcond_without nautilus        # disable nautilus view
+%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
+                       # plugin (better get gcc3-compiled one).
+                       # Flash plugin seems to still not work, use
+                       # mozilla instead. To compile wit this option, You
+                       # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       1.5b
-%define                snap    20030905
+%define                minmozver       5:1.7
+%define                snap    20040117
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.3.9
-Release:       1
+Version:       1.3.17
+Release:       2
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
+Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
+# Source0-md5: 781ac1c9e15fa4c2b367b195e78d1ab2
 #Source0:      %{name}-%{version}-%{snap}.tar.bz2
-Source0:       http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: f948047373884a0dc8d841930d11680c
 Source1:       %{name}-config-tool.1
-URL:           http://galeon.sourceforge.net/
 Patch0:                %{name}-desktop.patch
-BuildRequires: GConf2-devel >= 2.0.0
-BuildRequires: ORBit2-devel >= 2.7.5-1
-BuildRequires: autoconf
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-locale-names.patch
+Patch3:                %{name}-po.patch
+Patch4:                %{name}-mozilla.patch
+Patch5:                %{name}-mozilla173.patch
+URL:           http://galeon.sourceforge.net/
+BuildRequires: GConf2-devel >= 2.4.0
+BuildRequires: ORBit2-devel >= 2.8.3
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel >= 2.0.0
-BuildRequires: gtk+2-devel >= 2.0.6
+BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-vfs2-devel >= 2.4.0
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
-BuildRequires: libbonobo-devel >= 2.3.1-4
-BuildRequires: libbonoboui-devel >= 2.3.3-2
-BuildRequires: libglade2-devel >= 2.0.0
-BuildRequires: libgnomeui-devel >= 2.3.3.1-2
+BuildRequires: libbonoboui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel >= 2.4.0
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.3.7-3
-BuildRequires: openssl-devel >= 0.9.7
-BuildRequires: scrollkeeper >= 0.1.4
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 2.6.6
+BuildRequires: mozilla-devel >= %{minmozver}
+%{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
 BuildRequires: rpm-build >= 4.1-10
+BuildRequires: scrollkeeper >= 0.1.4
 Requires(post):        GConf2
-Requires(post):        mozilla
-Requires(post):        scrollkeeper
-Requires:      libbonobo >= 2.3.1-4
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
+Requires(post,postun): scrollkeeper
+Requires:      glib2 >= 1:2.4.4
+Requires:      gtk+2 >= 2:2.4.4
+Requires:      libbonobo >= 2.4.0
+Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%if %{?_with_gcc2:1}%{!?_with_gcc2:0}
+%if %{with gcc2}
 %define         __cc            gcc2
 %define         __cxx           gcc2
 %endif
@@ -72,6 +80,13 @@ O galeon 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+
+mv po/{no,nb}.po
 
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
@@ -80,6 +95,7 @@ mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
+cp /usr/share/automake/mkinstalldirs .
 glib-gettextize --copy --force
 intltoolize --copy --force
 %{__libtoolize}
@@ -88,15 +104,12 @@ intltoolize --copy --force
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
        --disable-schemas-install \
-       --disable-werror \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       %if %{with nautilus}
        --enable-nautilus-view=yes
+       %else
+       --enable-nautilus-view=no
+       %endif
 
 %{__make}
 
@@ -118,10 +131,15 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 rm -rf $RPM_BUILD_ROOT
 
 %post
+umask 022
 /usr/bin/scrollkeeper-update
 %gconf_schema_install
+[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
 
-%postun -p /usr/bin/scrollkeeper-update
+%postun
+umask 022
+/usr/bin/scrollkeeper-update
+[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
This page took 0.033749 seconds and 4 git commands to generate.