]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- rel. 2 to rebuild with mozilla 1.5a
[packages/galeon.git] / galeon.spec
index c393ba7c29be65c754d230cc7da8c42e4d21d7d2..bb809fba1f749532efc50f2982e98d77eaa0e605 100644 (file)
@@ -1,44 +1,49 @@
-
-%define                minmozver       1.2
-%define                snap            20021127
+#
+# Conditional build:
+# _with_gcc2           - compile using gcc2 to get working java plugin.
+#                        Flash plugin seems to still doesn't work, use 
+#                        mozilla instead. To compile wit this option, You 
+#                        have to install mozilla compiled with gcc2.
+#
+%define                minmozver       1.5a
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.3
-Release:       0.%{snap}.0
+Version:       1.3.7
+Release:       2
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-#Source0:      http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}.%{snap}.tar.bz2
+Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 9b89ebfb0a4019f0edd3ef227abc111f
 Source1:       %{name}-config-tool.1
-Patch0:                %{name}-mozilla_five_home.patch
-Patch1:                %{name}-bookmarks_pixmaps_path.patch
 URL:           http://galeon.sourceforge.net/
+Patch0:                %{name}-desktop.patch
+BuildRequires: GConf2-devel >= 2.0.0
+BuildRequires: ORBit2-devel >= 2.0.0
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: GConf2-devel
-BuildRequires: ORBit2-devel
 BuildRequires: bison
-BuildRequires: bonobo-activation-devel >= 2.1.0
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel
+BuildRequires: gnome-vfs2-devel >= 2.0.0
 BuildRequires: gtk+2-devel >= 2.0.6
 BuildRequires: intltool
-BuildRequires: libglade2-devel
-BuildRequires: libgnomeui-devel
+BuildRequires: libbonobo-devel >= 2.3.1-4
+BuildRequires: libbonoboui-devel >= 2.1.1
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: libgnomeui-devel >= 2.0.5
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel
+BuildRequires: libxml2-devel >= 2.4.0
 BuildRequires: mozilla-embedded-devel >= %{minmozver}
 BuildRequires: nautilus-devel >= 2.0.0
-BuildRequires: openssl-devel
-BuildRequires: scrollkeeper
-BuildRequires: bonobo-activation >= 2.1.0-3
-BuildRequires: rpm-build >= 4.1-7
-Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: scrollkeeper >= 0.1.4
+BuildRequires: rpm-build >= 4.1-10
+Requires:      libbonobo >= 2.3.1-4
+Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
 Requires(post):        GConf2
 Requires(post):        mozilla
 Requires(post):        scrollkeeper
@@ -47,10 +52,10 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME2
-%define                _serverdir      /usr/lib/bonobo/servers
+%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
+%define         __cc            gcc2
+%define         __cxx           gcc2
+%endif
 
 %description
 Gnome browser based on Gecko (Mozilla rendering engine).
@@ -65,14 +70,17 @@ O galeon 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+
+# regenerate - didn't compile with ORBit2 2.7.2
+cd idl
+orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
+mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
 glib-gettextize --copy --force
-#xml-i18n-toolize --copy --force
 intltoolize --copy --force
-libtoolize --copy --force
+%{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
@@ -83,9 +91,8 @@ libtoolize --copy --force
        --with-mozilla-home=%{_libdir}/mozilla \
        --enable-nls \
        --disable-included-gettext \
-       --disable-install-schemas \
+       --disable-schemas-install \
        --disable-werror \
-       --with-mozilla-snapshot=1.2 \
        --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
        --enable-nautilus-view=yes
 
@@ -96,23 +103,20 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW \
-       omf_dest_dir=%{_omf_dest_dir}/%{name} \
-       serverdir=%{_serverdir}
+       DESTDIR=$RPM_BUILD_ROOT 
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-%find_lang galeon-2.0
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+
+# galeon-2.0.mo, but gnome/help/galeon
+%find_lang galeon-2.0 --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /usr/bin/scrollkeeper-update
-umask 022
-rm -f %{_libdir}/mozilla/component.reg
-MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
 %gconf_schema_install
 
 %postun -p /usr/bin/scrollkeeper-update
@@ -121,11 +125,10 @@ MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_libdir}/%{name}
-%{_serverdir}/*
+%attr(755,root,root) %{_libdir}/%{name}
+%{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/applications/*
-%{_datadir}/gnome/help/*
+%{_desktopdir}/*
 %{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
This page took 0.068453 seconds and 4 git commands to generate.