]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- added BR and R: glib2 >= 1:2.4.0
[packages/galeon.git] / galeon.spec
index 510c902e51781b79371a0efec1b7304207bcef62..a6b129f09f0c56813f00102a5c3c2859cb00beb9 100644 (file)
@@ -1,59 +1,64 @@
 #
 # Conditional build:
-# _with_gcc2           - compile using gcc2 to get working java plugin.
-#                        Flash plugin seems to still doesn't work, use
-#                        mozilla instead. To compile wit this option, You
-#                        have to install mozilla compiled with gcc2.
+%bcond_without nautilus        # disable nautilus view
+%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
+                       # plugin (better get gcc3-compiled one).
+                       # Flash plugin seems to still not work, use
+                       # mozilla instead. To compile wit this option, You
+                       # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       1.5a
+%define                minmozver       5:1.6
+%define                snap    20040117
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.3.7
-Release:       4
+Version:       1.3.14
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
-# Source0-md5: 9b89ebfb0a4019f0edd3ef227abc111f
+Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
+# Source0-md5: 6621b8b65313d189a139172f0e767899
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
-URL:           http://galeon.sourceforge.net/
 Patch0:                %{name}-desktop.patch
-Patch1:                %{name}-schemas.patch
-BuildRequires: GConf2-devel >= 2.0.0
-BuildRequires: ORBit2-devel >= 2.7.5-1
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-locale-names.patch
+URL:           http://galeon.sourceforge.net/
+BuildRequires: GConf2-devel >= 2.4.0
+BuildRequires: ORBit2-devel >= 2.8.3
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel >= 2.0.0
-BuildRequires: gtk+2-devel >= 2.0.6
+BuildRequires: glib2-devel >= 1:2.4.0
+BuildRequires: gnome-vfs2-devel >= 2.4.0
+BuildRequires: gtk+2-devel >= 2.2.0
 BuildRequires: intltool
-BuildRequires: libbonobo-devel >= 2.3.1-4
-BuildRequires: libbonoboui-devel >= 2.3.3-2
-BuildRequires: libglade2-devel >= 2.0.0
-BuildRequires: libgnomeui-devel >= 2.3.3.1-2
+BuildRequires: libbonoboui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 2.0.1
+BuildRequires: libgnomeui-devel >= 2.4.0
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.4.0
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.3.7-3
-BuildRequires: openssl-devel >= 0.9.7
-BuildRequires: scrollkeeper >= 0.1.4
+BuildRequires: mozilla-devel >= %{minmozver}
+%{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
 BuildRequires: rpm-build >= 4.1-10
+BuildRequires: scrollkeeper >= 0.1.4
 Requires(post):        GConf2
-Requires(post):        mozilla
 Requires(post):        scrollkeeper
-Requires:      libbonobo >= 2.3.1-4
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
+Requires:      glib2 >= 1:2.4.0
+Requires:      libbonobo >= 2.4.0
+Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%if %{?_with_gcc2:1}%{!?_with_gcc2:0}
+%if %{with gcc2}
 %define         __cc            gcc2
 %define         __cxx           gcc2
 %endif
@@ -72,6 +77,9 @@ O galeon 
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+
+mv po/{no,nb}.po
 
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
@@ -80,6 +88,7 @@ mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
+cp /usr/share/automake/mkinstalldirs .
 glib-gettextize --copy --force
 intltoolize --copy --force
 %{__libtoolize}
@@ -88,15 +97,12 @@ intltoolize --copy --force
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
        --disable-schemas-install \
-       --disable-werror \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       %if %{with nautilus}
        --enable-nautilus-view=yes
+       %else
+       --enable-nautilus-view=no
+       %endif
 
 %{__make}
 
This page took 0.040637 seconds and 4 git commands to generate.