]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- updated to version 1.3.3
[packages/galeon.git] / galeon.spec
index 2d5391e2cbbe26cbb6b4894301e552fceed66570..7dbd19263de6cfbab70591699391aec2b17535af 100644 (file)
@@ -1,51 +1,60 @@
-
-%define                minmozver       1.0
+#
+# Conditional build:
+# _with_gcc2           - compile using gcc2 to get working java plugin.
+#                        Flash plugin seems to still doesn't work, use 
+#                        mozilla instead. To compile wit this option, You 
+#                        have to install mozilla compiled with gcc2.
+#
+%define                minmozver       1.3b-0.2
+%define                snap            20030305
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.2.6
-Release:       3
+Version:       1.3.3
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
 Source0:       http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
-Patch0:                %{name}-mozilla_five_home.patch
-Patch1:                %{name}-am_fix.patch
-Patch2:                %{name}-omf.patch
-Patch3:                %{name}-pl.patch
 URL:           http://galeon.sourceforge.net/
-BuildRequires: GConf-devel >= 1.0.9-2
-BuildRequires: ORBit-devel >= 0.5.0
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: GConf2-devel
+BuildRequires: ORBit2-devel
 BuildRequires: bison
-BuildRequires: gdk-pixbuf-devel >= 0.10.
+BuildRequires: bonobo-activation-devel >= 2.2.0
 BuildRequires: gettext-devel
-BuildRequires: gnome-core-devel >= 1.2.0
-BuildRequires: gnome-libs-devel >= 1.2.0
-BuildRequires: gnome-vfs-devel >= 0.5
+BuildRequires: gnome-vfs2-devel
+BuildRequires: gtk+2-devel >= 2.0.6
 BuildRequires: intltool
-BuildRequires: libglade-gnome-devel
+BuildRequires: libglade2-devel
+BuildRequires: libgnomeui-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libxml-devel >= 1.8.7
+BuildRequires: libxml2-devel
 BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: oaf-devel >= 0.6.2
-BuildRequires: openssl-devel
+BuildRequires: nautilus-devel >= 2.0.0
+BuildRequires: openssl-devel >= 0.9.7
 BuildRequires: scrollkeeper
-Requires:      GConf >= 1.0.4-1
+BuildRequires: bonobo-activation >= 2.2.0
+BuildRequires: rpm-build >= 4.1-10
 Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
-Prereq:                scrollkeeper
+Requires(post):        GConf2
+Requires(post):        mozilla
+Requires(post):        scrollkeeper
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME
-%define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
+%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
+%define         __cc            gcc2
+%define         __cxx           gcc2
+%endif
 
 %description
 Gnome browser based on Gecko (Mozilla rendering engine).
@@ -59,16 +68,14 @@ O galeon 
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
 rm -f missing
-xml-i18n-toolize --copy --force
-%{__gettextize}
-aclocal -I %{_aclocaldir}/gnome
+glib-gettextize --copy --force
+intltoolize --copy --force
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
@@ -77,11 +84,11 @@ aclocal -I %{_aclocaldir}/gnome
        --with-mozilla-home=%{_libdir}/mozilla \
        --enable-nls \
        --disable-included-gettext \
-       --disable-install-schemas \
+       --disable-schemas-install \
        --disable-werror \
-       --with-mozilla-snapshot=1.0 \
+       --with-mozilla-snapshot=1.3b \
        --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
-       --enable-nautilus-view=no
+       --enable-nautilus-view=yes
 
 %{__make}
 
@@ -90,15 +97,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW \
-       omf_dest_dir=%{_omf_dest_dir}/%{name}
-
-mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
+       DESTDIR=$RPM_BUILD_ROOT 
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-%find_lang %{name} --with-gnome
+%find_lang galeon-2.0
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -108,21 +111,20 @@ rm -rf $RPM_BUILD_ROOT
 umask 022
 rm -f %{_libdir}/mozilla/component.reg
 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-gconftool --shutdown
-GCONF_CONFIG_SOURCE=xml::%{_sysconfdir}/gconf/gconf.xml.defaults gconftool --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas 2>dev/null >/dev/null
+%gconf_schema_install
 
 %postun -p /usr/bin/scrollkeeper-update
 
-%files -f %{name}.lang
+%files -f galeon-2.0.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_applnkdir}/Network/WWW/*
 %{_libdir}/%{name}
+%{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/gnome/help/galeon-manual
-%{_datadir}/gnome/ui/*.xml
-%{_datadir}/oaf/*
+%{_datadir}/applications/*
+%{_datadir}/gnome/help/*
+%{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
This page took 0.07566 seconds and 4 git commands to generate.