]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- version 1.3.5
[packages/galeon.git] / galeon.spec
index ca7165146a4e400f7698e8435298597b58e0d0ad..67e20a78cd7af8447030b831019fadf6568c340c 100644 (file)
@@ -1,40 +1,50 @@
-
-%define                minmozver       1.1
-%define                snap            20021015
+#
+# Conditional build:
+# _with_gcc2           - compile using gcc2 to get working java plugin.
+#                        Flash plugin seems to still doesn't work, use 
+#                        mozilla instead. To compile wit this option, You 
+#                        have to install mozilla compiled with gcc2.
+#
+%define                minmozver       1.4b
+%define                snap            20030518
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.2.99
-Release:       0.%{snap}.1
+Version:       1.3.5
+#Release:      1.%{snap}.1
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-#Source0:      http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{version}.%{snap}.tar.bz2
+Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 6d0a503e82e0c676712859ee273dcd81
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
-Patch0:                %{name}-mozilla_five_home.patch
 URL:           http://galeon.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: GConf2-devel
-BuildRequires: ORBit2-devel
+BuildRequires: GConf2-devel >= 2.0.0
+BuildRequires: ORBit2-devel >= 2.0.0
 BuildRequires: bison
-BuildRequires: bonobo-activation-devel
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel
+BuildRequires: gnome-vfs2-devel >= 2.0.0
 BuildRequires: gtk+2-devel >= 2.0.6
 BuildRequires: intltool
-BuildRequires: libglade2-devel
-BuildRequires: libgnomeui-devel
+BuildRequires: libbonobo-devel >= 2.3.1-4
+BuildRequires: libbonoboui-devel >= 2.1.1
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: libgnomeui-devel >= 2.0.5
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel
+BuildRequires: libxml2-devel >= 2.4.0
 BuildRequires: mozilla-embedded-devel >= %{minmozver}
 BuildRequires: nautilus-devel >= 2.0.0
-BuildRequires: openssl-devel
-BuildRequires: scrollkeeper
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: scrollkeeper >= 0.1.4
+BuildRequires: rpm-build >= 4.1-10
+Requires:      libbonobo >= 2.3.1-4
 Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
 Requires(post):        GConf2
 Requires(post):        mozilla
@@ -44,9 +54,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME2
+%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
+%define         __cc            gcc2
+%define         __cxx           gcc2
+%endif
 
 %description
 Gnome browser based on Gecko (Mozilla rendering engine).
@@ -60,14 +71,12 @@ O galeon 
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 rm -f missing
 glib-gettextize --copy --force
-#xml-i18n-toolize --copy --force
 intltoolize --copy --force
-libtoolize --copy --force
+%{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
@@ -78,9 +87,9 @@ libtoolize --copy --force
        --with-mozilla-home=%{_libdir}/mozilla \
        --enable-nls \
        --disable-included-gettext \
-       --disable-install-schemas \
+       --disable-schemas-install \
        --disable-werror \
-       --with-mozilla-snapshot=1.0 \
+       --with-mozilla-snapshot=1.4b \
        --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
        --enable-nautilus-view=yes
 
@@ -91,11 +100,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW \
-       omf_dest_dir=%{_omf_dest_dir}/%{name}
-
-#mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
+       DESTDIR=$RPM_BUILD_ROOT 
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
@@ -109,15 +114,14 @@ rm -rf $RPM_BUILD_ROOT
 umask 022
 rm -f %{_libdir}/mozilla/component.reg
 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-GCONF_CONFIG_SOURCE="" gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas >/dev/null
+%gconf_schema_install
 
 %postun -p /usr/bin/scrollkeeper-update
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-#%{_applnkdir}/Network/WWW/*
 %{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
This page took 0.043163 seconds and 4 git commands to generate.