]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- massive attack: do not put bonobo servers into /usr/lib; remove
[packages/galeon.git] / galeon.spec
index e52af494730c973735ebd65a7a1121fc5fd8276e..5a17d016277d31a40e4bb36b4c790dd179afc9d1 100644 (file)
@@ -1,39 +1,55 @@
+
+%define                minmozver       1.2
+%define                snap            20021127
+
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
 Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
+Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.0.1
-Release:       3
-Epoch:         1
+Version:       1.3
+Release:       0.%{snap}.1
+Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Group(de):     X11/Applikationen/Netzwerkwesen
-Group(pl):     X11/Aplikacje/Sieciowe
-Source0:       http://prdownloads.sourceforge.net/galeon/%{name}-%{version}.tar.gz
+#Source0:      http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.%{snap}.tar.bz2
+Source1:       %{name}-config-tool.1
 Patch0:                %{name}-mozilla_five_home.patch
+Patch1:                %{name}-bookmarks_pixmaps_path.patch
 URL:           http://galeon.sourceforge.net/
-BuildRequires: GConf-devel >= 1.0.4-1
-BuildRequires: ORBit-devel >= 0.5.0
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: GConf2-devel
+BuildRequires: ORBit2-devel
+BuildRequires: bison
+BuildRequires: bonobo-activation-devel >= 2.1.0
 BuildRequires: gettext-devel
-BuildRequires: gnome-core-devel >= 1.2.0
-BuildRequires: gnome-libs-devel >= 1.2.0
-BuildRequires: gnome-vfs-devel >= 0.5
-BuildRequires: libxml-devel >= 1.8.7
-BuildRequires: libglade-devel
+BuildRequires: gnome-vfs2-devel
+BuildRequires: gtk+2-devel >= 2.0.6
+BuildRequires: intltool
+BuildRequires: libglade2-devel
+BuildRequires: libgnomeui-devel
 BuildRequires: libstdc++-devel
-BuildRequires: mozilla-devel >= 0.9.6
-BuildRequires: oaf >= 0.6.2
-BuildRequires: oaf-devel >= 0.6.2
-BuildRequires: gdk-pixbuf-devel >= 0.10.
-BuildRequires: bison
-BuildRequires: xml-i18n-tools
-Requires:      GConf >= 1.0.4-1
-%requires_eq   mozilla
+BuildRequires: libxml2-devel
+BuildRequires: mozilla-embedded-devel >= %{minmozver}
+BuildRequires: nautilus-devel >= 2.0.0
+BuildRequires: openssl-devel
+BuildRequires: scrollkeeper
+BuildRequires: bonobo-activation >= 2.1.0-3
+BuildRequires: rpm-build >= 4.1-7
+Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
+Requires(post):        GConf2
+Requires(post):        mozilla
+Requires(post):        scrollkeeper
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# can be provided by mozilla or mozilla-embedded
+%define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
+
 %define                _prefix         /usr/X11R6
 %define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME
+%define                _sysconfdir     /etc/X11/GNOME2
 
 %description
 Gnome browser based on Gecko (Mozilla rendering engine).
@@ -48,55 +64,68 @@ O galeon 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-#sed -e s/AM_GNOME_GETTEXT/AM_GNU_GETTEXT/ configure.in >configure.in.tmp
-#mv -f configure.in.tmp configure.in
-#rm -f missing
-#aclocal -I %{_aclocaldir}/gnome
-#autoconf
-#automake -a -c
-%configure2_13 \
+rm -f missing
+glib-gettextize --copy --force
+#xml-i18n-toolize --copy --force
+intltoolize --copy --force
+libtoolize --copy --force
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
+%configure \
        --with-mozilla-libs=%{_libdir} \
        --with-mozilla-includes=%{_includedir}/mozilla \
        --with-mozilla-home=%{_libdir}/mozilla \
        --enable-nls \
        --disable-included-gettext \
        --disable-install-schemas \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas
+       --disable-werror \
+       --with-mozilla-snapshot=1.2 \
+       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       --enable-nautilus-view=yes
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW
+       Networkdir=%{_applnkdir}/Network/WWW \
+       omf_dest_dir=%{_omf_dest_dir}/%{name}
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
+install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-gzip -9nf AUTHORS ChangeLog NEWS README
+%find_lang galeon-2.0
 
-%find_lang %{name} --with-gnome
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
+/usr/bin/scrollkeeper-update
 umask 022
 rm -f %{_libdir}/mozilla/component.reg
 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-gconftool --shutdown
-GCONF_CONFIG_SOURCE=xml::%{_sysconfdir}/gconf/gconf.xml.defaults gconftool --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas 2>dev/null >/dev/null
+%gconf_schema_install
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%postun -p /usr/bin/scrollkeeper-update
 
-%files -f %{name}.lang
+%files -f galeon-2.0.lang
 %defattr(644,root,root,755)
-%doc *.gz
+%doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_applnkdir}/Network/WWW/*
+%{_libdir}/%{name}
+%{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/oaf/*
+%{_datadir}/applications/*
+%{_datadir}/gnome/help/*
+%{_datadir}/gnome-2.0/ui/*.xml
+%{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
 %{_sysconfdir}/gconf/schemas/*
This page took 0.081678 seconds and 4 git commands to generate.