]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- added mozilla17 patch (compile fix for mozilla-1.7)
[packages/galeon.git] / galeon.spec
index 983a6affed90ff93e243516af527c5ed29786b14..4cbdfdf215bde03929f35674fe98469a6b3f71a5 100644 (file)
-
-%define                minmozver       1.0
+#
+# Conditional build:
+%bcond_without nautilus        # disable nautilus view
+%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
+                       # plugin (better get gcc3-compiled one).
+                       # Flash plugin seems to still not work, use
+                       # mozilla instead. To compile wit this option, You
+                       # have to install mozilla compiled with gcc2.
+#
+%define                minmozver       5:1.7
+%define                snap    20040117
 
 Summary:       Galeon - gecko-based GNOME web browser
 Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
+Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.2.6
+Version:       1.3.15
 Release:       2
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
+Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
+# Source0-md5: 9334cbdf0734f626470e788ce37d21a6
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
-Patch0:                %{name}-mozilla_five_home.patch
-Patch1:                %{name}-am_fix.patch
-Patch2:                %{name}-omf.patch
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-locale-names.patch
+Patch3:                %{name}-mozilla17.patch
+Patch4:                %{name}-gcc34.patch
 URL:           http://galeon.sourceforge.net/
-BuildRequires: GConf-devel >= 1.0.9-2
-BuildRequires: ORBit-devel >= 0.5.0
+BuildRequires: GConf2-devel >= 2.4.0
+BuildRequires: ORBit2-devel >= 2.8.3
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: bison
-BuildRequires: gdk-pixbuf-devel >= 0.10.
 BuildRequires: gettext-devel
-BuildRequires: gnome-core-devel >= 1.2.0
-BuildRequires: gnome-libs-devel >= 1.2.0
-BuildRequires: gnome-vfs-devel >= 0.5
+BuildRequires: glib2-devel >= 1:2.4.0
+BuildRequires: gnome-vfs2-devel >= 2.4.0
+BuildRequires: gtk+2-devel >= 2:2.4.0
 BuildRequires: intltool
-BuildRequires: libglade-gnome-devel
+BuildRequires: libbonoboui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.4.0
 BuildRequires: libstdc++-devel
-BuildRequires: libxml-devel >= 1.8.7
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: oaf-devel >= 0.6.2
-BuildRequires: openssl-devel
-BuildRequires: scrollkeeper
-Requires:      GConf >= 1.0.4-1
-Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
-Prereq:                scrollkeeper
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 2.6.6
+BuildRequires: mozilla-devel >= %{minmozver}
+%{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
+BuildRequires: rpm-build >= 4.1-10
+BuildRequires: scrollkeeper >= 0.1.4
+Requires(post):        GConf2
+Requires(post):        scrollkeeper
+Requires:      glib2 >= 1:2.4.2
+Requires:      gtk+2 >= 2:2.4.3
+Requires:      libbonobo >= 2.4.0
+Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _sysconfdir     /etc/X11/GNOME
-%define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
+%if %{with gcc2}
+%define         __cc            gcc2
+%define         __cxx           gcc2
+%endif
 
 %description
-Gnome browser based on Gecko (Mozilla rendering engine).
+GNOME browser based on Gecko (Mozilla rendering engine).
 
 %description -l pl
 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
 %description -l pt_BR
-O galeon é um browser para o gnome baseado no mozilla.
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+
+mv po/{no,nb}.po
+
+# regenerate - didn't compile with ORBit2 2.7.2
+cd idl
+orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
+mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
-xml-i18n-toolize --copy --force
-%{__gettextize}
-aclocal -I %{_aclocaldir}/gnome
+cp /usr/share/automake/mkinstalldirs .
+glib-gettextize --copy --force
+intltoolize --copy --force
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
-       --disable-install-schemas \
-       --disable-werror \
-       --with-mozilla-snapshot=1.0 \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       --disable-schemas-install \
+       %if %{with nautilus}
+       --enable-nautilus-view=yes
+       %else
        --enable-nautilus-view=no
+       %endif
 
 %{__make}
 
@@ -88,39 +116,33 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       Networkdir=%{_applnkdir}/Network/WWW \
-       omf_dest_dir=%{_omf_dest_dir}/%{name}
-
-mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-%find_lang %{name} --with-gnome
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+
+# galeon-2.0.mo, but gnome/help/galeon
+%find_lang galeon-2.0 --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /usr/bin/scrollkeeper-update
-umask 022
-rm -f %{_libdir}/mozilla/component.reg
-MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-gconftool --shutdown
-GCONF_CONFIG_SOURCE=xml::%{_sysconfdir}/gconf/gconf.xml.defaults gconftool --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas 2>dev/null >/dev/null
+%gconf_schema_install
 
 %postun -p /usr/bin/scrollkeeper-update
 
-%files -f %{name}.lang
+%files -f galeon-2.0.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_applnkdir}/Network/WWW/*
-%{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}
+%{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/gnome/help/galeon-manual
-%{_datadir}/gnome/ui/*.xml
-%{_datadir}/oaf/*
+%{_desktopdir}/*
+%{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
This page took 0.058047 seconds and 4 git commands to generate.