]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- up to 2.7.1
[packages/ffmpeg.git] / ffmpeg.spec
index 2dec301eef5c03fe24bfc303898baf8bf854d048..a5e44af39a0a169de20762e3f2198496fba74067 100644 (file)
@@ -1,16 +1,18 @@
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
-#      1. make-request -r --without opencv ffmpeg.spec
+#      1. make-request -r --with bootstrap ffmpeg.spec
 #      2. make-request -r opencv.spec
 #      3. bump release of ffmpeg.spec
 #      4. make-request -r ffmpeg.spec
 #
 # Conditional build:
+%bcond_with    bootstrap       # disable features to able to build without installed ffmpeg
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_with    fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
 %bcond_without bs2b            # BS2B audio filter support
 %bcond_without caca            # textual display using libcaca
+%bcond_without dcadec          # DCA decoding via libdcadec
 %bcond_without decklink        # Blackmagic DeskLink output support
 %bcond_without flite           # flite voice synthesis support
 %bcond_without frei0r          # frei0r video filtering
 %bcond_without doc             # don't build docs
 %bcond_with    tests           # "make check" (some tests fail as of 2.5)
 
+%if %{with bootstrap}
+%undefine      with_opencv
+%endif
+
 %ifnarch %{ix86} %{x8664} arm
 %undefine      with_x265
 %endif
@@ -53,7 +59,7 @@
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.7
+Version:       2.7.1
 Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, x265, xavs, xvid, x11grab)
@@ -61,7 +67,7 @@ Release:      1
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 5a16425b0bde1b952f58cff71b569a45
+# Source0-md5: f159c6d7eed8546b23e1a17325cbf1f8
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -74,6 +80,7 @@ BuildRequires:        SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
+%{?with_dcadec:BuildRequires:  dcadec-devel}
 %{?with_nonfree:BuildRequires: faac-devel}
 %{?with_fdk_aac:BuildRequires: fdk-aac-devel}
 %{?with_flite:BuildRequires:   flite-devel >= 1.4}
@@ -86,6 +93,7 @@ BuildRequires:        freetype-devel
 # require version with altivec support fixed
 BuildRequires: gcc >= 5:3.3.2-3
 %endif
+BuildRequires: gmp-devel
 BuildRequires: gnutls-devel
 BuildRequires: jack-audio-connection-kit-devel
 %{?with_ladspa:BuildRequires:  ladspa-devel}
@@ -114,10 +122,10 @@ BuildRequires:    libv4l-devel
 BuildRequires: libvdpau-devel >= 0.2
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 1.3.0}
-%{?with_webp:BuildRequires:    libwebp-devel >= 0.2.0}
+%{?with_webp:BuildRequires:    libwebp-devel >= 0.4.0}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
-# X265_BUILD >= 17
+# X265_BUILD >= 57
 %{?with_x265:BuildRequires:    libx265-devel >= 1.3-0.20150610.1}
 # libxcb xcb-shm xcb-xfixes xcb-shape
 BuildRequires: libxcb-devel >= 1.4
@@ -234,6 +242,7 @@ Requires:   SDL-devel >= 1.2.1
 Requires:      alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
+%{?with_dcadec:Requires:       dcadec-devel}
 %{?with_nonfree:Requires:      faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
 %{?with_flite:Requires:        flite-devel >= 1.4}
@@ -263,7 +272,7 @@ Requires:   libtheora-devel >= 1.0-0.beta3
 %{?with_va:Requires:   libva-devel >= 1.0.3}
 Requires:      libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 1.3.0}
-%{?with_webp:Requires: libwebp-devel >= 0.2.0}
+%{?with_webp:Requires: libwebp-devel >= 0.4.0}
 %{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
 %{?with_x265:Requires: libx265-devel >= 1.3-0.20150610.1}
 %{?with_mfx:Requires:  mfx_dispatch-devel}
@@ -458,6 +467,7 @@ EOF
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
+       %{?with_dcadec:--enable-libdcadec} \
        %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
This page took 0.040896 seconds and 4 git commands to generate.