]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
move html docs to -doc subpackage
[packages/ffmpeg.git] / ffmpeg.spec
index 55b389ece87cf4d31fac52b1fe837a7751520f5a..66fe5c846035a2677ba9c93020e9b637e5212b4f 100644 (file)
@@ -1,4 +1,4 @@
-# TODO: libshine, libvidstab, libzmq, opencl ?
+# TODO: libzmq ?
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
 %bcond_without gme             # Game Music Emu support
 %bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
 %bcond_without openal          # OpenAL 1.1 capture support
+%bcond_with    opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
 %bcond_without opencv          # OpenCV video filtering
 %bcond_without pulseaudio      # PulseAudio input support
 %bcond_without quvi            # quvi input support
+%bcond_without shine           # shine fixed-point MP3 encoder
 %bcond_without soxr            # SoX Resampler support
 %bcond_without x264            # x264 encoder
 %bcond_without utvideo         # Ut Video decoder
 %bcond_without va              # VAAPI (Video Acceleration API)
+%bcond_without vidstab         # vid.stab video stabilization support
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without wavpack         # wavpack encoding support
+%bcond_without zmq             # 0MQ message passing
 %bcond_without doc             # don't build docs
 
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       2.0
-Release:       1
+Version:       2.0.1
+Release:       2
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 13a0feb74474f89052f6b8ba1bce46be
+# Source0-md5: dd71a1baedb2daa3e4d21e0651daa918
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
 Patch0:                %{name}-opencv24.patch
 URL:           http://www.ffmpeg.org/
 %{?with_openal:BuildRequires:  OpenAL-devel >= 1.1}
+%{?with_opencl:BuildRequires:  OpenCL-devel >= 1.2}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bzip2-devel
@@ -84,6 +89,7 @@ BuildRequires:        libv4l-devel
 BuildRequires: libvdpau-devel >= 0.2
 BuildRequires: libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.7}
+%{?with_shine:BuildRequires:   shine-devel}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
 %ifarch %{ix86}
@@ -108,6 +114,7 @@ BuildRequires:      speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
 %{?with_utvideo:BuildRequires: utvideo-devel >= 12}
+%{?with_vidstab:BuildRequires: vid.stab-devel}
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
 %{?with_wavpack:BuildRequires: wavpack-devel}
@@ -118,6 +125,7 @@ BuildRequires:      xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xvid-devel >= 1:1.1.0
 BuildRequires: yasm
+%{?with_zmq:BuildRequires:     zeromq-devel}
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
 # overflows maximum hash table size
@@ -180,17 +188,18 @@ Summary(pl.UTF-8):        Pliki nagłówkowe ffmpeg
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 # Libs.private from *.pc (unreasonably they are all the same)
+%{?with_opencl:Requires:       OpenCL-devel >= 1.2}
 Requires:      SDL-devel >= 1.2.1
 Requires:      alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
 %{?with_nonfree:Requires:      faac-devel}
 %{?with_fdk_aac:Requires:      fdk-aac-devel}
+%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 %{?with_gme:Requires:  game-music-emu-devel}
 Requires:      jack-audio-connection-kit-devel
-%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -215,10 +224,12 @@ Requires: opencore-amr-devel
 %{?with_opencv:Requires:       opencv-devel}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
+%{?with_shine:Requires:        shine-devel}
 %{?with_soxr:Requires: soxr-devel}
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
 %{?with_utvideo:Requires:      utvideo-devel >= 12}
+%{?with_vidstab:Requires:      vid.stab-devel}
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
 %{?with_wavpack:Requires:      wavpack-devel}
@@ -227,6 +238,7 @@ Requires:   xavs-devel
 Requires:      xorg-lib-libXext-devel
 Requires:      xorg-lib-libXfixes-devel
 Requires:      xvid-devel >= 1:1.1.0
+%{?with_zmq:Requires:  zeromq-devel}
 Requires:      zlib-devel
 Obsoletes:     libpostproc-devel
 
@@ -285,6 +297,28 @@ czasie dla źródeł na żywo (można przeskakiwać na położenia w
 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
 
+%package doc
+Summary:       Manual for ffmpeg
+Summary(fr.UTF-8):     Documentation pour ffmpeg
+Summary(it.UTF-8):     Documentazione di ffmpeg
+Summary(pl.UTF-8):     Podręcznik dla ffmpeg
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description doc
+Documentation for ffmpeg.
+
+%description doc -l fr.UTF-8
+Documentation pour ffmpeg.
+
+%description doc -l it.UTF-8
+Documentazione di ffmpeg.
+
+%description doc -l pl.UTF-8
+Dokumentacja do ffmpeg.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -401,12 +435,14 @@ EOF
        %{?with_quvi:--enable-libquvi} \
        --enable-librtmp \
        --enable-libschroedinger \
+       %{?with_shine:--enable-libshine} \
        %{?with_soxr:--enable-libsoxr} \
        --enable-libspeex \
        --enable-libtheora \
        --enable-libtwolame \
        %{?with_utvideo:--enable-libutvideo} \
        --enable-libv4l2 \
+       %{?with_vidstab:--enable-libvidstab} \
        --enable-libvo-aacenc \
        --enable-libvo-amrwbenc \
        --enable-libvorbis \
@@ -415,7 +451,9 @@ EOF
        %{?with_x264:--enable-libx264} \
        --enable-libxavs \
        --enable-libxvid \
+       %{?with_zmq:--enable-libzmq} \
        %{?with_openal:--enable-openal} \
+       %{?with_opencl:--enable-opencl} \
        --enable-postproc \
        --enable-pthreads \
        --enable-shared \
@@ -501,7 +539,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
+%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
 %attr(755,root,root) %{_bindir}/ffmpeg
 %attr(755,root,root) %{_bindir}/ffprobe
 %attr(755,root,root) %{_bindir}/qt-faststart
@@ -619,3 +657,9 @@ fi
 %endif
 %dir %attr(770,root,ffserver) /var/cache/ffserver
 %dir %attr(770,root,ffserver) /var/log/ffserver
+
+%if %{with doc}
+%files doc
+%defattr(644,root,root,755)
+%doc doc/*.html
+%endif
This page took 0.307128 seconds and 4 git commands to generate.