]> git.pld-linux.org Git - packages/ffmpeg.git/blobdiff - ffmpeg.spec
- expllicit req for webrtc-libilbc to avoid confusion with libilbc
[packages/ffmpeg.git] / ffmpeg.spec
index aa9a4060339d204f7a833de998493c6c36a08bbf..4ff59dfd2eacfc5b991c02355f905ae4be2a6a90 100644 (file)
@@ -1,4 +1,3 @@
-# TODO: libilbc, libfdk-aac, flite
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
@@ -9,15 +8,16 @@
 # Conditional build:
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
-%bcond_without autoreqdep      # don't care about package name deps generated by rpm
+%bcond_with    fdk_aac         # AAC encoding via libfdk_aac (requires nonfree)
 %bcond_without caca            # textual display using libcaca
-%bcond_with    flite           # flite voice synthesis support [ffmpeg expects more voices]
-%bcond_without frei0r          # build without frei0r video filtering
-%bcond_without openal          # build without OpenAL 1.1 capture support
-%bcond_without opencv          # build without opencv video filtering
-%bcond_without pulseaudio      # build without PulseAudio input support
-%bcond_without x264            # build without x264 encoder
-%bcond_without utvideo         # build without Ut Video decoder
+%bcond_without flite           # flite voice synthesis support
+%bcond_without frei0r          # frei0r video filtering
+%bcond_without ilbc            # iLBC de/encoding via WebRTC libilbc
+%bcond_without openal          # OpenAL 1.1 capture support
+%bcond_without opencv          # OpenCV video filtering
+%bcond_without pulseaudio      # PulseAudio input support
+%bcond_without x264            # x264 encoder
+%bcond_without utvideo         # Ut Video decoder
 %bcond_without va              # VAAPI (Video Acceleration API)
 %bcond_without vpx             # VP8, a high-quality video codec
 %bcond_without doc             # don't build docs
@@ -26,7 +26,7 @@ Summary:      FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
 Version:       1.0
-Release:       1
+Release:       4
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
@@ -47,7 +47,8 @@ BuildRequires:        alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
 %{?with_nonfree:BuildRequires: faac-devel}
-%{?with_flite:BuildRequires:   flite-devel}
+%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
+%{?with_flite:BuildRequires:   flite-devel >= 1.4}
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel
 %{?with_frei0r:BuildRequires:  frei0r-devel}
@@ -101,18 +102,20 @@ BuildRequires:    speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     texinfo}
 BuildRequires: twolame-devel
 %{?with_utvideo:BuildRequires: utvideo-devel}
-BuildRequires: yasm
 BuildRequires: vo-aacenc-devel
 BuildRequires: vo-amrwbenc-devel
+%{?with_ilbc:BuildRequires:    webrtc-libilbc-devel}
 BuildRequires: xavs-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xvid-devel >= 1:1.1.0
+BuildRequires: yasm
 BuildRequires: zlib-devel
 %{?with_autoreqdep:BuildConflicts:     libpostproc}
 # overflows maximum hash table size
 BuildConflicts:        pdksh < 5.2.14-57
 Requires:      %{name}-libs = %{version}-%{release}
+%{?with_ilbc:Requires: webrtc-libilbc}
 Requires:      xvid >= 1:1.1.0
 Obsoletes:     libpostproc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -173,10 +176,11 @@ Requires: alsa-lib-devel
 Requires:      bzip2-devel
 Requires:      celt-devel >= 0.11.0
 %{?with_nonfree:Requires:      faac-devel}
+%{?with_fdk_aac:Requires:      fdk-aac-devel}
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 Requires:      jack-audio-connection-kit-devel
-%{?with_flite:Requires:        flite-devel}
+%{?with_flite:Requires:        flite-devel >= 1.4}
 Requires:      lame-libs-devel >= 3.98.3
 %{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
 Requires:      libass-devel
@@ -196,12 +200,14 @@ Requires: libvorbis-devel
 %{?with_vpx:Requires:  libvpx-devel >= 0.9.6}
 %{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
 Requires:      opencore-amr-devel
+%{?with_opencv:Requires:       opencv-devel}
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 Requires:      speex-devel >= 1:1.2-rc1
 Requires:      twolame-devel
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
+%{?with_ilbc:Requires: webrtc-libilbc-devel}
 Requires:      xavs-devel
 Requires:      xorg-lib-libXext-devel
 Requires:      xorg-lib-libXfixes-devel
@@ -353,10 +359,12 @@ EOF
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
+       %{?with_fdk_aac:--enable-libfdk-aac} \
        %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
        --enable-libgsm \
        --enable-libiec61883 \
+       %{?with_ilbc:--enable-libilbc} \
        --enable-libmodplug \
        --enable-libmp3lame \
        --enable-libnut \
This page took 0.03629 seconds and 4 git commands to generate.