]> git.pld-linux.org Git - packages/esh.git/blobdiff - esh.spec
- invoke fix-info-dir via /sbin/postshell where possible to avoid extra /bin/sh dep
[packages/esh.git] / esh.spec
index fee978cebfed761f3c7dc70b66eae6a4c7b67ae8..814034164a8d4c8ecd7a2d246585b2809013afbc 100644 (file)
--- a/esh.spec
+++ b/esh.spec
@@ -1,69 +1,60 @@
-%define name esh
-%define version 0.7
-%define release 1
-%define serial 1
-
-Summary: esh, the easy shell.
-Name: %{name}
-Version: %{version}
-Release: %{release}
-Serial: %{serial}
-Copyright: GPL
-Group: Shells
-URL: http://esh.netpedia.net
-Vendor: Ivan Tkatchev <ivantk@yahoo.com>
-Source: %{name}-%{version}.tar.gz
-Distribution: Freshmeat RPMs
-Packager: Ryan Weaver <ryanw@infohwy.com>
-BuildRoot: /tmp/%{name}-%{version}
+Summary:       esh, the easy shell
+Summary(pl.UTF-8):     esh - prosta powłoka
+Name:          esh
+Version:       0.8.5
+Release:       1
+License:       GPL
+Group:         Applications/Shells
+Vendor:                Ivan Tkatchev <ivantk@yahoo.com>
+#Source0:      http://esh.netpedia.net/%{name}-%{version}.tar.gz
+Source0:       %{name}-%{version}.tar.gz
+# Source0-md5: ab8dc77db3eb7aa5b1097336a91cdd39
+#URL:          http://esh.netpedia.net/
+BuildRequires: readline-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _bindir         /bin
 
 %description
 esh was primarily written out of a need for a simple and lightweight
-shell for Unix. As such, it deviates completely from all of the traditional
-shells, opting instead for a Lisp-like syntax. This allows exceptionally
-small size, both in terms of lines of code and memory consumption, while
-retaining remarkable flexibility and programmability.
+shell for Unix. As such, it deviates completely from all of the
+traditional shells, opting instead for a Lisp-like syntax. This allows
+exceptionally small size, both in terms of lines of code and memory
+consumption, while retaining remarkable flexibility and
+programmability.
+
+%description -l pl.UTF-8
+esh został napisany w pierwszej kolejności z potrzeby posiadania
+prostej i małej powłoki uniksowej. Jako taki różni się od wszystkich
+innych powłok, przyjmując składnię podobną do Lispa. To pozwala na
+uzyskać wyjątkowo małe rozmiary, w rozmiarach kodu jak i w zużyciu
+pamięci przy zachowaniu dużej elastyczności i programowalności.
 
 %prep
 %setup -q -n esh
 
 %build
-make
-
-cp doc/esh.info .; gzip -9 esh.info
+%{__make}
 
 %install
-if [ -e $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
+rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/bin
-install -d $RPM_BUILD_ROOT/usr/info
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_infodir}}
 
-install -s -m 755 esh $RPM_BUILD_ROOT/bin
-install    -m 644 esh.info.gz  $RPM_BUILD_ROOT/usr/info
+install esh $RPM_BUILD_ROOT%{_bindir}
+install doc/esh.info $RPM_BUILD_ROOT%{_infodir}
 
-%post
-/sbin/install-info /usr/info/esh.info.gz /usr/info/dir --entry="* esh: (esh).                 esh, the easy shell."
+%post  -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%preun
-if [ $1 = 0 ]; then
-       /sbin/install-info --delete /usr/info/esh.info.gz /usr/info/dir --entry="* esh: (esh).                 esh, the easy shell."
-fi
+%postun        -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(-,root,root)
-%doc doc emacs examples CHANGELOG CREDITS GC_README INSTALL LICENSE READLNE-HACKS TODO
-/bin/esh
-/usr/info/esh.info.gz
-
-%changelog
-* Wed Feb 23 1999 Ryan Weaver <ryanw@infohwy.com>
-  [esh-0.7-1]
-- Initial RPM Build
-- "run" and "run-simple" now return the exit status of the 
-  pipeline if the job was launched in the foreground.
-- "chop!" and "chop-nl!" now return their arguments.
-- Added "begin-last", which is like the "begin" in Scheme.
-- Added the "<" and ">" commands.
+%defattr(644,root,root,755)
+%doc CHANGELOG CREDITS GC_README INSTALL READLNE-HACKS TODO doc/*.html emacs examples
+%attr(755,root,root) %{_bindir}/esh
+%{_infodir}/esh.info*
This page took 0.056335 seconds and 4 git commands to generate.