]> git.pld-linux.org Git - packages/entrance.git/blobdiff - entrance.spec
- pl for themes, strict internal deps
[packages/entrance.git] / entrance.spec
index 16169b1244dd5160581d4aba52cd703de07bfd02..909b48c5eb5f7a7c6b7a71e9b8732d4fc57a567c 100644 (file)
@@ -1,14 +1,19 @@
+#
+# TODO:
+#  - when WM finishes to load entrance process fork's (or simply finishes)
+#    so entranced thinks session has finished and restarts login greeter
+#
 Summary:       Enlightened display manager
 Summary(pl):   O¶wiecony zarz±dca ekranu
 Name:          entrance
-Version:       0.9.0.003
-%define _snap  20050707
-Release:       0.%{_snap}.0.2
+Version:       0.9.0.004
+%define        _snap   20051029
+Release:       1.%{_snap}.1
 License:       BSD
 Group:         X11/Applications
-#Source0:      http://dl.sourceforge.net/enlightenment/%{name}-%{version}.tar.gz
-Source0:       ftp://ftp.sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.gz
-# Source0-md5: 4f1747d588dcb4ed1f0f613966519ca4
+#Source0:      http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
+Source0:       http://sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.bz2
+# Source0-md5: 6d98baf539649abbe3124a02574fe87f
 Source1:       %{name}.init
 Source2:       %{name}.Xsession
 Source3:       %{name}.gen-conf
@@ -16,12 +21,15 @@ Patch0:             %{name}-conf.in.patch
 URL:           http://enlightenment.org/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: edje
 BuildRequires: esmart-devel
 BuildRequires: libtool
 BuildRequires: pam-devel
 BuildRequires: sed >= 4.0
 Requires:      /bin/bash
 Requires(post,preun):  /sbin/chkconfig
+Requires:      ecore
+Requires:      %{name}-theme
 Requires:      pam
 Requires:      sessreg
 Requires:      xinitrc-ng
@@ -42,9 +50,64 @@ Entrance to zarz
 Podobnie jak Enlightenment ma piêkno i mo¿liwo¶ci konfiguracji, o
 jakich KDM czy GDM mog± tylko pomarzyæ... i to bez narzutu.
 
+%package theme-default
+Summary:       Default Entrance theme
+Summary(pl):   Domy¶lny motyw Entrance
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-theme
+
+%description theme-default
+Default Entrance theme.
+
+%description theme-default -l pl
+Domy¶lny motyw Entrance.
+
+%package theme-Nebulous
+Summary:       Nebulous Entrance theme
+Summary(pl):   Motyw Entrance Nebulous
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-theme
+
+%description theme-Nebulous
+Nebulous Entrance theme.
+
+%description theme-Nebulous -l pl
+Motyw Entrance Nebulous.
+
+%package theme-darkrock
+Summary:       Darkrock Entrance theme
+Summary(pl):   Motyw Entrance Darkrock
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-theme
+
+%description theme-darkrock
+Darkrock Entrance theme.
+
+%description theme-darkrock -l pl
+Motyw Entrance Darkrock.
+
+%package theme-taillights
+Summary:       Taillights Entrance theme
+Summary(pl):   Motyw Entrance Taillights
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-theme
+
+%description theme-taillights
+Taillights Entrance theme.
+
+%description theme-taillights -l pl
+Motyw Entrance Taillights.
+
 %prep
 %setup -q -n %{name}
 %patch0 -p1
+mv data/images/sessions/enlightenment{,DR17}.png
+sed 's/enlightenment.png/enlightenmentDR17.png/' \
+       -i data/images/sessions/Makefile.am
 
 sed '/PACKAGE_CFG_DIR/s@"${sysconfdir}"@"${localstatedir}/lib/${PACKAGE}"@' \
        -i configure.in
@@ -55,7 +118,7 @@ sed 's|/bin/sh|/bin/bash|g' \
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -76,7 +139,7 @@ install %{SOURCE3} \
        $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/generate-config
 install data/config/build_config.sh.in \
        $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/
-touch $RPM_BUILD_ROOT%{_var}/lib/%{name}/entrance_config.db
+touch $RPM_BUILD_ROOT%{_var}/lib/%{name}/entrance_config.cfg
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -104,10 +167,29 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/entrance
 %attr(755,root,root) %{_bindir}/entrance*
 %attr(755,root,root) %{_sbindir}/entranced
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}/images
+%dir %{_datadir}/%{name}/themes
+%{_datadir}/%{name}/users
 %dir %{_sysconfdir}/X11/%{name}
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/Xsession
 %attr(755,root,root) %{_sysconfdir}/X11/%{name}/generate-config
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/build_config.sh.in
 %dir %{_var}/lib/%{name}
-%ghost %{_var}/lib/%{name}/entrance_config.db
+%ghost %{_var}/lib/%{name}/entrance_config.cfg
+
+%files theme-default
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/themes/default.edj
+
+%files theme-Nebulous
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/themes/Nebulous.edj
+
+%files theme-darkrock
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/themes/darkrock.edj
+
+%files theme-taillights
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/themes/taillights.edj
This page took 0.158166 seconds and 4 git commands to generate.