]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- updated to 0.11.0
[packages/elinks.git] / elinks.spec
index 402b713d5cf537cdf6dc0265e3aceebc6c6ebb33..ea9cb2d08655592114e31b0b775c6443e580bddf 100644 (file)
@@ -1,46 +1,66 @@
+#
 # Conditional build:
 %bcond_with    x       # Use the X Windows System
+%bcond_with    gnutls  # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby    # Enable (experimental) Ruby scripting support
+%bcond_without 256     # Disable 256 colors support
+%bcond_without bittorent # Disable BitTorrent support
 %bcond_without cgi     # Disable Local CGI support
-%bcond_without ipv6    # Disable IPv6 Support
+%bcond_without guile   # Disable Guile scripting
+%bcond_without idn     # Disable Internation Domain Names support
+%bcond_without ipv6    # Disable IPv6 support
+%bcond_without js      # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
 %bcond_without led     # Disable LEDs
-%bcond_without 256     # Disable 256 colors support
-%bcond_without lua # Disable Lua scripting
+%bcond_without lua     # Disable Lua scripting
+%bcond_without openssl # Disable OpenSSL support
+%bcond_without perl    # Disable Perl scripting
+# 
+%if %{with gnutls}
+%undefine      with_openssl
+%endif
 #
 Summary:       Experimantal Links (text WWW browser)
 Summary(es):   El links es un browser para modo texto, similar a lynx
 Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
 Summary(pt_BR):        O links é um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.9.1
-Release:       4
+Version:       0.11.0
+Release:       1
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://elinks.or.cz/download.html
-Source0:       http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 78b536a9e9607ed522229b70172706a8
+#Source0Download:      http://www.elinks.cz/download.html
+Source0:       http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 9154f493f544af31ae31ec1dd203d315
 Source1:       %{name}.desktop
 Source2:       links.png
-Patch0:                %{name}-pl.po.patch
-Patch1:                %{name}-home_etc.patch
-Patch2:                %{name}-lua40.patch
-URL:           http://elinks.or.cz/
+Patch0:                %{name}-home_etc.patch
+Patch1:                %{name}-lua40.patch
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-srcdir.patch
+URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
-BuildRequires: lua40-devel >= 4.0.1-9
-BuildRequires: ncurses-devel => 5.1
-BuildRequires: openssl-devel >= 0.9.7d
+%{?with_guile:BuildRequires: guile-devel}
+%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
+%{?with_js:BuildRequires:      js-devel >= 1.5-0.rc6a.1}
+%{?with_idn:BuildRequires:     libidn-devel}
+%{?with_lua:BuildRequires:     lua50-devel}
+BuildRequires: ncurses-devel >= 5.1
+%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
+%{?with_perl:BuildRequires:    perl-devel}
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
-BuildRequires: /usr/bin/texi2html
+BuildRequires: tetex
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/elinks
-%define                specflags_ia32   -fomit-frame-pointer 
+%define                specflags_ia32  -fomit-frame-pointer 
 
 %description
 This is the elinks tree - intended to provide feature-rich version of
@@ -55,7 +75,7 @@ tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
 keepalive.
 
 %description -l pl
-Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki www - links.
+Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
 elinks jednak jest dedykowana g³ównie do testowania.
 
 %description -l pt_BR
@@ -68,21 +88,41 @@ keepalive.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-%{__automake}
 %configure \
-%{!?debug:     --enable-fastmem} \
-%{?debug:      --enable-debug} \
+       --disable-no-root \
+       HAVE_SMBCLIENT=yes \
+       %{!?debug:--enable-fastmem} \
+       %{?debug:--enable-debug} \
        %{!?with_ipv6:--disable-ipv6} \
+       %{?with_bittorrent:--enable-bittorrent} \
+       %{?with_cgi:--enable-cgi} \
+       --enable-finger \
+       --enable-gopher \
+       --enable-nntp \
+       %{?with_256:--enable-256-colors} \
+       --enable-exmode \
+       %{?with_leds:--enable-leds} \
+       --enable-marks \
+       --enable-html-highlight \
+       %{!?with_idn:--without-idn} \
+       %{?with_guile:--with-guile} \
+       %{?with_perl:--with-perl} \
        %{!?with_lua:--without-lua} \
+       %{?with_ruby:--with-ruby} \
+       %{!?with_js:--without-spidermonkey} \
+       %{?with_gnutls:--with-gnutls} \
+       %{!?with_openssl:--without-openssl} \
        --with%{!?with_x:out}-x
-%{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
-%{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
-%{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
+# xterm -e is default, one might want to change it to
+# something else
+#      --with-xterm="xterm -e"
+
 %{__make}
 
 cd doc
@@ -101,7 +141,7 @@ install -d $RPM_BUILD_ROOT%{_desktopdir} \
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 
-install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}
+%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
 
 %find_lang %{name}
 
@@ -113,9 +153,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,*.html}
+%doc doc/{*.txt,html}
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
 %{_desktopdir}/*
 %{_pixmapsdir}/*
-%{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
+%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.071637 seconds and 4 git commands to generate.