]> git.pld-linux.org Git - packages/elfutils.git/blobdiff - elfutils.spec
up to 0.188
[packages/elfutils.git] / elfutils.spec
index 5821ba9a6ec3bb4e2b34f063115270343eb0b3dd..12bea10e384f5a94419b38986ad7d11fb039642b 100644 (file)
@@ -1,3 +1,5 @@
+# TODO:
+# - package debuginfod.service
 #
 # Conditional build:
 %bcond_without debuginfod      # debuginfod server and client
@@ -6,34 +8,35 @@
 Summary:       A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
-Version:       0.178
+Version:       0.188
 Release:       1
 License:       GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
 Group:         Development/Tools
 Source0:       https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 5480d0b7174446aba13a6adde107287f
+# Source0-md5: efb25a91873b2eec4df9f31e6a4f4e5c
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-debian-manpages.patch
 Patch2:                %{name}-awk.patch
 Patch3:                %{name}-align.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
-Patch6:                %{name}-cxx.patch
-Patch7:                x32.patch
+Patch6:                disable-tests.patch
 URL:           https://sourceware.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
+%{?with_tests:BuildRequires:   bsdtar}
 BuildRequires: bzip2-devel
 BuildRequires: gawk
 BuildRequires: gcc >= 6:4.3
-BuildRequires: gettext-tools
+BuildRequires: gettext-tools >= 0.19.6
 BuildRequires: glibc-devel >= 6:2.7
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.315
+BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: sharutils
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 %if %{with tests} && %(test -d /proc/self ; echo $?)
 # native test needs proc (for libdwfl -p PID to work)
 BuildRequires: MOUNTED_PROC
@@ -82,7 +85,8 @@ Requires:     %{name} = %{version}-%{release}
 Requires:      bzip2-devel
 Requires:      xz-devel
 Requires:      zlib-devel
-Obsoletes:     libelf-devel
+Obsoletes:     libelf-devel < 0.8.14
+Obsoletes:     libelf0-devel < 0.8.14
 
 %description devel
 The elfutils-devel package contains the development part of libraries
@@ -123,7 +127,7 @@ Summary:    Static libraries to handle compiled objects
 Summary(pl.UTF-8):     Statyczne biblioteki do obsługi skompilowanych obiektów
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
-Obsoletes:     libelf-static
+Obsoletes:     libelf-static < 0.8.14
 
 %description static
 The elfutils-static package contains the static libraries to create
@@ -142,30 +146,39 @@ służących do odpluskwiania. libasm udostępnia programowalny interfejs
 asemblera.
 
 %package debuginfod
-Summary:       debuginfod library, server and client
-Summary(pl.UTF-8):     Biblioteka, serwer i klient debuginfod
+Summary:       debuginfod server and client
+Summary(pl.UTF-8):     Serwer i klient debuginfod
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-%if %{with debuginfod}
-# for library
-Requires:      curl-libs >= 7.29.0
-# the rest for server
+Requires:      %{name}-debuginfod-libs = %{version}-%{release}
 Requires:      libarchive >= 3.1.2
 Requires:      libmicrohttpd >= 0.9.33
 Requires:      sqlite3 >= 3.7.17
-%endif
 
 %description debuginfod
-debuginfod library, server and client.
+debuginfod server and client.
 
 %description debuginfod -l pl.UTF-8
-Biblioteka, serwer i klient debuginfod.
+Serwer i klient debuginfod.
+
+%package debuginfod-libs
+Summary:       debuginfod library
+Summary(pl.UTF-8):     Biblioteka debuginfod
+Group:         Libraries
+Requires:      curl-libs >= 7.29.0
+Conflicts:     elfutils-debuginfod < 0.187-3
+
+%description debuginfod-libs
+debuginfod library.
+
+%description debuginfod-libs -l pl.UTF-8
+Biblioteka debuginfod.
 
 %package debuginfod-devel
 Summary:       Header file for debuginfod library
 Summary(pl.UTF-8):     Plik nagłówkowy biblioteki debuginfod
 Group:         Development/Libraries
-Requires:      %{name}-debuginfod = %{version}-%{release}
+Requires:      %{name}-debuginfod-libs = %{version}-%{release}
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description debuginfod-devel
@@ -183,7 +196,6 @@ Plik nagłówkowy biblioteki debuginfod.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
 
 %{__rm} po/stamp-po
 
@@ -200,12 +212,11 @@ Plik nagłówkowy biblioteki debuginfod.
 %build
 #%%{__gettextize}
 %{__aclocal} -I m4
-%{__autoheader}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
        --disable-silent-rules \
-       --disable-werror \
        %{__enable_disable debuginfod} \
        --program-prefix=%{programprefix}
 
@@ -245,8 +256,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  libelf -p /sbin/ldconfig
 %postun        libelf -p /sbin/ldconfig
 
-%post  debuginfod -p /sbin/ldconfig
-%postun        debuginfod -p /sbin/ldconfig
+%post  debuginfod-libs -p /sbin/ldconfig
+%postun        debuginfod-libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
@@ -296,12 +307,18 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with debuginfod}
 %files debuginfod
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libdebuginfod-*.so
-%attr(755,root,root) %ghost %{_libdir}/libdebuginfod.so.1
 %attr(755,root,root) %{_bindir}/debuginfod
 %attr(755,root,root) %{_bindir}/debuginfod-find
 %{_mandir}/man1/debuginfod-find.1*
+%{_mandir}/man7/debuginfod-client-config.7*
 %{_mandir}/man8/debuginfod.8*
+%attr(755,root,root) /etc/profile.d/debuginfod.sh
+%attr(755,root,root) /etc/profile.d/debuginfod.csh
+
+%files debuginfod-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libdebuginfod-*.so
+%attr(755,root,root) %ghost %{_libdir}/libdebuginfod.so.1
 
 %files debuginfod-devel
 %defattr(644,root,root,755)
This page took 0.102104 seconds and 4 git commands to generate.