]> git.pld-linux.org Git - packages/ekg.git/blobdiff - ekg.spec
- up to 2003.05.29 ("... psujacy zabawe blad off-by-one w ioctld.")
[packages/ekg.git] / ekg.spec
index 49f0c8c25363afc9b6a29f2eb4ed894ed0b4d61a..1fd3e4fc3eb848c0465390fff86e5c8a70afca52 100644 (file)
--- a/ekg.spec
+++ b/ekg.spec
@@ -1,22 +1,35 @@
 #
 # Conditional build:
-# _with_ioctl_daemon - with ioctl_daemon (suid-root!)
+# _with_ioctl_daemon    - with ioctl_daemon (suid-root!)
+# _with_python          - with python support
+# _with_voip           - with voip support (libgsm)
 #
+
+%define                snapshot 20030529
+
 Summary:       A client compatible with Gadu-Gadu
 Summary(de):   Einen client kompatibel zu Gadu-Gadu
 Summary(it):   Esperimentale cliente di Gadu-Gadu
 Summary(pl):   Eksperymentalny Klient Gadu-Gadu
 Name:          ekg
-Version:       20020807
-Release:       2
-Epoch:         1
+Version:       1.0
+Release:       3.%{snapshot}.1
+Epoch:         3
 License:       GPL
 Group:         Applications/Communications
-Source0:       http://dev.null.pl/ekg/%{name}-%{version}.tar.gz
+# Source0-md5: 4049340e57d0fc99e23662c6ce87c56f
+Source0:       http://dev.null.pl/ekg/%{name}-%{snapshot}.tar.gz
+Source1:       %{name}.conf
 URL:           http://dev.null.pl/ekg/
-BuildRequires: libgsm-devel
+BuildRequires: autoconf
+BuildRequires: automake
+%{?_with_voip:BuildRequires: libgsm-devel}
 BuildRequires: ncurses-devel
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: %{_bindir}/perl
+%{?_with_python:BuildRequires: python-devel}
 BuildRequires: readline-devel
+BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -54,7 +67,7 @@ bazuj
 Summary:       libgadu library development
 Summary(pl):   Czê¶æ biblioteki libgadu dla programistów
 Group:         Development/Libraries
-Requires:      libgadu
+Requires:      libgadu = %{version}
 Obsoletes:     libgg-devel
 License:       LGPL
 
@@ -75,7 +88,7 @@ potrzebne do kompilowania aplikacji korzystaj
 Summary:       Static libgadu Library
 Summary(pl):   Statyczna biblioteka libgadu
 Group:         Development/Libraries
-Requires:      libgadu-devel
+Requires:      libgadu-devel = %{version}
 Obsoletes:     libgg-static
 License:       LGPL
 
@@ -89,31 +102,43 @@ Statisches libgadu Archiv.
 Statyczna biblioteka libgadu.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{snapshot}
 
 %build
+rm -f missing
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
 %configure \
        --enable-shared \
        --enable-static \
-       %{?!debug:--without-debug} \
+       --with-pthread \
+       %{?_with_python:--with-python} \
+       %{?_with_voip:--with-libgsm} \
        %{?!_with_ioctl_daemon:--disable-ioctld}
-
 %{__make}
 
-( cd docs/api && ./make.pl )
+%if %{?_with_ioctl_daemon:1}0
+cd src 
+%{__make} ioctld
+cd ..
+%endif
+
+cd docs/api
+./make.pl
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+
+%{__make} install install-ekl2 DESTDIR=$RPM_BUILD_ROOT
 
-install contrib/ekl2.pl $RPM_BUILD_ROOT%{_bindir}
-install contrib/ekl2.sh $RPM_BUILD_ROOT%{_bindir}
-install docs/ekl2.man.pl $RPM_BUILD_ROOT%{_mandir}/pl/man1/ekl2.1
-install docs/ekl2.man.en $RPM_BUILD_ROOT%{_mandir}/man1/ekl2.1
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/
 
 # For libgadu-devel
 
-rm examples/Makefile examples/Makefile.in
+rm examples/Makefile examples/Makefile.in examples/.cvsignore
 
 %if %{?_with_ioctl_daemon:1}%{?!_with_ioctl_daemon:0}
 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
@@ -130,10 +155,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/e*
-%doc docs/{7thguard,dcc,emoticons,gdb,on,themes,ui,vars,voip}.txt
+%doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
+%attr(755,root,root) %{_bindir}/e*
 %{?_with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
+%attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
 %{_datadir}/ekg
 %{_mandir}/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
@@ -144,10 +170,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libgadu-devel
 %defattr(644,root,root,755)
-%doc docs/{7thguard,api,dcc-protocol,devel-hints,http,przenosny-kod}.txt docs/protocol.html docs/api/ref.functions.html
+%doc docs/{7thguard,api,ui,devel-hints,przenosny-kod}.txt docs/protocol.html docs/api/{functions,index,types}.html
 %doc ChangeLog docs/{README,TODO} examples
 %{_libdir}/libgadu.so
 %{_includedir}/libgadu.h
+%{_includedir}/libgadu-config.h
+%{_pkgconfigdir}/*
 
 %files -n libgadu-static
 %defattr(644,root,root,755)
This page took 0.063564 seconds and 4 git commands to generate.