]> git.pld-linux.org Git - packages/ecasound.git/blobdiff - ecasound.spec
- adapterized.
[packages/ecasound.git] / ecasound.spec
index e72c4172962c2dbf7ff9bc2630e465cd5c5f535f..1b91e125c0973a1fdb32ef518f1b0481224b581a 100644 (file)
@@ -1,20 +1,26 @@
+
+%define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
+%define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
+%define python_compile python -c "import compileall; compileall.compile_dir('.')"
+
 Summary:       Software package for multitrack audio processing
 Summary(pl):   Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
 Name:          ecasound
-Version:       1.8.3d15
+Version:       1.8.5d15
 Release:       1
 License:       GPL
 Group:         Applications/Sound
 Group(de):     Applikationen/Laut
 Group(pl):     Aplikacje/D¼wiêk
 Source0:       http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
-Patch0:        ecasound-plugin_no_ver.patch
+Patch0:                %{name}-lib.patch
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: ncurses-devel >= 5.0
 BuildRequires: readline-devel
 BuildRequires: alsa-lib-devel
 BuildRequires: audiofile-devel >= 0.1.7
+BuildRequires: python-devel
 Requires:      lame
 Requires:      mpg123
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -113,9 +119,22 @@ Pakiet ten zawiera wtyczki dla programu ecasound, kt
 wspó³pracê z bibliotekami takich projektów jak ALSA, Audio File
 Library oraz aRts.
 
+%package -n python-%{name}
+Summary:       Python module for Ecasound
+Summary(pl):   Modu³ jêzyka Python dla biblioteki programu ecasound
+Group:         Development/Languages/Python
+Group(de):     Entwicklung/Sprachen/Python
+Group(pl):     Programowanie/Jêzyki/Python
+
+%description -n python-%{name}
+Python module for Ecasound library.
+
+%description -l pl -n python-%{name}
+Modu³ jêzyka Python dla biblioteki programu ecasound.
+
 %prep
 %setup -q
-%patch0 -p1
+%patch -p1
 
 %build
 CXXFLAGS="$RPM_OPT_FLAGS -fno-rtti"
@@ -128,9 +147,12 @@ automake
 rm -rf $RPM_BUILD_ROOT
 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
 
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
+( cd pyecasound
+  %python_compile_opt
+  %python_compile
+  install *.pyc *.pyo $RPM_BUILD_ROOT%{python_sitepkgsdir}
+)
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/*/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -144,8 +166,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ecafixdc
 %attr(755,root,root) %{_bindir}/ecanormalize
 %attr(755,root,root) %{_bindir}/ecaplay
+%attr(755,root,root) %{_bindir}/ecasignalview
 %attr(755,root,root) %{_bindir}/ecasound
-%attr(755,root,root) %{_bindir}/ecasound-config
 %{_mandir}/man1/eca*
 %{_mandir}/man5/eca*
 
@@ -158,6 +180,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libecasound-devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ecasound-config
+%attr(755,root,root) %{_bindir}/ecasoundc-config
 %{_includedir}/ecasound/*
 %{_includedir}/kvutils/*
 %attr(755,root,root) %{_libdir}/libkvutils.so
@@ -176,3 +200,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/ecasound-plugins/lib*.so*
 %{_libdir}/ecasound-plugins/lib*.la
 %{_libdir}/ecasound-plugins/lib*.a
+
+%files -n python-%{name}
+%defattr(644,root,root,755)
+%attr(755,root,root) %{python_sitepkgsdir}/*.so
+%{python_sitepkgsdir}/*.pyo
+%{python_sitepkgsdir}/*.pyc
This page took 0.115707 seconds and 4 git commands to generate.