]> git.pld-linux.org Git - packages/dx.git/blobdiff - dx.spec
- do not list %{_desktopdir}/* -- dangerous, could list directories unexpectedly
[packages/dx.git] / dx.spec
diff --git a/dx.spec b/dx.spec
index a95eb686838819acbd0cd31c66379fada61de143..8007add43405634dbe976a6c7bcc4ce445bac5a5 100644 (file)
--- a/dx.spec
+++ b/dx.spec
@@ -1,23 +1,23 @@
-#
-# TODO: - add samples
-#      - add desktop file
-#
 Summary:       Excellent tool for making visualization of data
 Summary(pl):   Doskona³e narzêdzie do wizualizacji danych
 Name:          dx
-Version:       4.3.2
-Release:       2
+Version:       4.4.0
+Release:       1
 License:       IPL
 Group:         Applications
 Source0:       http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
-# Source0-md5: 201afdd86a5ddcfda0dc60fc7b6d3fea
+# Source0-md5: 8fe6a09faea4aa713a1540f51371b719
 Source1:       http://opendx.npaci.edu/source/%{name}samples-%{version}.tar.gz
-# Source1-md5: 940eece74fc2bf001a8017f9df18daac
+# Source1-md5: e8f43722ca0a66282608bded7c0e4f93
+Source2:       %{name}.desktop
 Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-nolibs.patch
+Patch2:                dxsamples-DESTDIR.patch
+Patch3:                dxsamples-unused_bin.patch
 URL:           http://www.opendx.org/
-BuildRequires: ImageMagick-devel
+BuildRequires: ImageMagick-devel >= 1:6.2.4.0
 BuildRequires: OpenGL-devel-base
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
@@ -27,7 +27,7 @@ BuildRequires:        libtool
 BuildRequires: libtiff-devel
 BuildRequires: motif-devel
 BuildRequires: netcdf-devel
-Requires:      %{name}-libs = %{version}
+Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_ia32  -fomit-frame-pointer
@@ -43,7 +43,7 @@ creating visualizations.
 OpenDX jest w pe³ni funkcjonalnym, o unikalnych mo¿liwo¶ciach,
 pakietem do wizualizacji danych naukowych, in¿ynierskich i
 analitycznych. Zosta³ zaprojektowany w sposób otwarty, w oparciu o
-standardowe ¶rodowiska interfejstów. Jego przemy¶lany model danych
+standardowe ¶rodowiska interfejsów. Jego przemy¶lany model danych
 daje u¿ytkownikom du¿± elastyczno¶æ w tworzeniu wizualizacji.
 
 %package libs
@@ -61,7 +61,7 @@ Biblioteki wsp
 Summary:       OpenDX development files
 Summary(pl):   Pliki nag³ówkowe OpenDX
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 OpenDX development files.
@@ -73,7 +73,7 @@ Pliki nag
 Summary:       OpenDX static libraries
 Summary(pl):   Biblioteki statyczne OpenDX
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenDX static libraries.
@@ -92,12 +92,25 @@ Online help and html documentation for OpenDX.
 %description doc -l pl
 Podrêczna pomoc oraz dokumentacja html dla OpenDX.
 
+%package examples
+Summary:       OpenDX Examples
+Summary(pl):   Przyk³ady dla OpenDX
+Group:         Documentation
+
+%description examples
+Examples for OpenDX.
+
+%description examples -l pl
+Przyk³ady dla OpenDX.
+
 %prep
-%setup  -q
+%setup  -q -a 1
 #%patch0 -p1
+%patch1 -p1
+%patch2 -p0
+%patch3 -p1
 
 %build
-rm -f missing aclocal.m4
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
@@ -112,21 +125,40 @@ rm -f missing aclocal.m4
        --enable-new-keylayout \
        --without-javadx
 
+cd %{name}samples-%{version}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
+%configure \
+       --prefix=%{_examplesdir} \
+       --without-javadx
+cd ..
+
 %{__make}
 
+%{__make} -C %{name}samples-%{version}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir}}
+%{__make} -C %{name}samples-%{version} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
+install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+install src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
+mv $RPM_BUILD_ROOT%{_examplesdir}/dx/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
 rm -rf $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
@@ -136,6 +168,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc doc/README*
 %attr(755,root,root) %{_bindir}/*
 %dir %{_datadir}/dx
 %attr(755,root,root) %{_datadir}/dx/bin
@@ -144,16 +177,15 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dx/lib
 %{_datadir}/dx/lib_linux
 %{_datadir}/dx/ui
-%doc doc/README*
 %{_mandir}/manl/*
+%{_desktopdir}/*.desktop
+%{_pixmapsdir}/*
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*
-%exclude %{_libdir}/dx/*.mak
-%exclude %{_libdir}/dx/*.la
-%exclude %{_libdir}/dx/*.so
-%exclude %{_libdir}/dx/*.a
+%dir %{_libdir}/dx
+%attr(755,root,root) %{_libdir}/dx/bin_linux
+%attr(755,root,root) %{_libdir}/dx/lib*.so.*
 
 %files devel
 %defattr(644,root,root,755)
@@ -169,3 +201,7 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %{_datadir}/dx/h*
+
+%files examples
+%defattr(644,root,root,755)
+%{_examplesdir}/%{name}-%{version}
This page took 0.03516 seconds and 4 git commands to generate.