]> git.pld-linux.org Git - packages/dvdrip.git/blobdiff - dvdrip.spec
- cosmetics
[packages/dvdrip.git] / dvdrip.spec
index 41b418ef3d04cda0f5552b3d6a62f9457ade8bc3..93f1234a8207379500eef518365f5135f12f346d 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+# _with_tests - perform "make test" (needs working, not busy /dev/audio!)
+#
 %include        /usr/lib/rpm/macros.perl
 %define                pnam    Video-DVDRip
 Summary:       Video::DVDRip Perl module
@@ -18,22 +22,19 @@ Summary(sv):        Video::DVDRip Perlmodul
 Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Video::DVDRip
 Summary(zh_CN):        Video::DVDRip Perl Ä£¿é
 Name:          perl-Video-DVDRip
-Version:       0.44
-Release:       0.2
-License:       GPL/Artistic
+Version:       0.50.13
+Release:       1
+License:       GPL/Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.exit1.org/dvdrip/dist/%{pnam}-%{version}.tar.gz
+# Source0-md5: 08877521b5ef24044e4ce192d6407e8d
 URL:           http://www.exit1.org/dvdrip/
-BuildRequires: perl >= 5.6
-BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRequires: perl-devel >= 5.6
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: perl-gtk
+BuildRequires: perl-gtk-Gdk-Pixbuf
 BuildRequires: gdk-pixbuf-devel
 Requires:      transcode
-Provides:      perl(Video::DVDRip::GUI::Project::ClipZoomTab)
-Provides:      perl(Video::DVDRip::GUI::Project::LoggingTab)
-Provides:      perl(Video::DVDRip::GUI::Project::StorageTab)
-Provides:      perl(Video::DVDRip::GUI::Project::TitleTab)
-Provides:      perl(Video::DVDRip::GUI::Project::TranscodeTab)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -51,30 +52,17 @@ obrazu, napisanego przez Thomasa 
 %setup -q -n %{pnam}-%{version}
 
 %build
-#CFLAGS="%{rpmcflags}"
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make} OPTIMIZE="%{rpmcflags}"
-%{__make} test
+
+%{?_with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_mandir}/man3
-
-eval `perl '-V:installarchlib'`
-install -d $RPM_BUILD_ROOT/$installarchlib 
-%{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
-
-#find $RPM_BUILD_ROOT%{_prefix} -type f -print |
-#      sed "s@^$RPM_BUILD_ROOT@@g" |
-#      grep -v perllocal.pod |
-#      grep -v "\.packlist" > Video-DVDRip-%{version}-filelist
-#if [ "$(cat Video-DVDRip-%{version}-filelist)X" = "X" ] ; then
-#    echo "ERROR: EMPTY FILE LIST"
-#    exit -1
-#fi
 
-cd $RPM_BUILD_ROOT%{perl_sitelib}/Video
-pod2man --section=3pm DVDRip.pm >$RPM_BUILD_ROOT%{_mandir}/man3/Video::DVDRip.3pm
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -83,5 +71,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc Changes Credits README TODO
 %attr(755,root,root) %{_bindir}/*
-%{perl_sitelib}/Video
+%{perl_vendorlib}/Video
+%{_mandir}/man1/*
 %{_mandir}/man3/*
This page took 0.079731 seconds and 4 git commands to generate.