]> git.pld-linux.org Git - packages/dshowserver.git/blobdiff - dshowserver.spec
- missing dir
[packages/dshowserver.git] / dshowserver.spec
index 71d94c6ae3822cfb1b3472ce781690112c388b81..5d4253a6066286939c4c5e3832188381eae27588 100644 (file)
@@ -1,96 +1,95 @@
-
-# Conditional build:
-%bcond_with    static  # static package for use with x86_64 systems
-
-%define                pname           dshowserver
-%define        _snap           svn
-%define                _rel            73
-
-Summary:       Win32 CoreAVC H.264 codec helper.
+%define                svn                     101
+Summary:       Win32 CoreAVC H.264 codec helper
 Summary(pl.UTF-8):     Serwer windowsowego kodeka CoreAVC H.264.
-Name:          %{pname}%{?with_static:-static}
-Version:       %{_snap}%{_rel}
-Release:       0.1
-License:       GPL
-Group:         X11/Multimedia
-Source0:       %{pname}-%{version}.tar.bz2
-# Source0-md5:
-Patch0:                %{pname}-codecspath.patch
-URL:           http://code.google.com/         
-BuildRequires: glibc-static
+Name:          dshowserver
+Version:       0.%{svn}
+Release:       0.3
+License:       GPL v2
+Group:         X11/Applications/Multimedia
+Source0:       %{name}-0.svn%{svn}.tar.bz2
+# Source0-md5: 9a5fefb6dc8e34114ae9ca99ee799eea
+Patch0:                %{name}-codecspath.patch
+Patch1:                %{name}-make.patch
+URL:           http://code.google.com/p/coreavc-for-linux/
+BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: sed >= 4.0
+BuildRequires: wine-devel
+ExclusiveArch: %{ix86}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                x8664_flags     -m32
+%define                specflags_x86_64 %{x8664_flags}
+%define                specflags_amd64 %{x8664_flags}
+%define                specflags_ia32e %{x8664_flags}
 
 %description
-CoreAVC is a proprietary Windows codec for H.264 video decoding. 
-It is much faster than any currently available open-source codecs. 
-Being multi-threaded, and able to play PAFF streams, 
-it can handle HD H.264/AVC streams that no freely available codecs can. 
-CoreAVC is reasonably priced, but it is Windows only. 
-Dshowserver serves CoreAVC for mythtv, mplayer and xine.
-Dshowserver can work under 32 or 64 bits linux system.
-For 64 bits use static binary compiled in 32 bits environement.
+CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
+much faster than any currently available open-source codecs. Being
+multi-threaded, and able to play PAFF streams, it can handle HD
+H.264/AVC streams that no freely available codecs can. CoreAVC is
+reasonably priced, but it is Windows only. Dshowserver serves CoreAVC
+for mythtv, mplayer and xine. Dshowserver can work under 32 or 64 bits
+linux system. For 64 bits use static binary compiled in 32 bits
+environement.
 
 %description -l pl.UTF-8
-CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie szybszy
-od dowolnego wolnego kodeka. Obsługujac wielowatkowosc moze odtwarzac
-strumienie zakodowane z uzyciem interlacingu PAFF.
-Odtwarza strumienie HD H.264/AVC.
-Kosztuje rozsadnie, ale dostepny jest tylko dla Windows.
-Dhowserevr implementuje obsluge tego kodeka przez mythtv, mplayer i xine.
-Dshowserver moze byc uzyty w architekturach x86 i x86_64.
-Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow 
+CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie
+szybszy od dowolnego wolnego kodeka. Obsługujac wielowatkowosc moze
+odtwarzac strumienie zakodowane z uzyciem interlacingu PAFF. Odtwarza
+strumienie HD H.264/AVC. Kosztuje rozsadnie, ale dostepny jest tylko
+dla Windows. Dhowserevr implementuje obsluge tego kodeka przez mythtv,
+mplayer i xine. Dshowserver moze byc uzyty w architekturach x86 i
+x86_64. Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow
 zbudowanych w 32 bitowym srodowisku.
 
-
 %package -n registercodec
-Summary:        Utility to register win32 CoreAVC H.264 codec.
-Summary(pl.UTF-8):      Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
-Group:          X11/Multimedia
+Summary:       Utility to register win32 CoreAVC H.264 codec
+Summary(pl.UTF-8):     Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
+Group:         X11/Applications/Multimedia
 
 %description -n registercodec
-Utility to register win32 CoreAVC H.264 codec for usage with mythtv/mplayer/xine.
-
-%description -l pl.UTF-8 -n registercodec
-Narzedzie do przeprowadzenia rejestracji komercyjnego  kodeka CoreAVC H.264.
+Utility to register win32 CoreAVC H.264 codec for usage with
+mythtv/mplayer/xine.
 
+%description -n registercodec -l pl.UTF-8
+Narzedzie do przeprowadzenia rejestracji komercyjnego kodeka CoreAVC
+H.264.
 
 %prep
-cd %{_builddir}
-rm -rf %{pname}-%{version}
-tar jxvf %{SOURCE0}
-cd %{pname}-%{version}
-
-
+%setup -q -n %{name}-svn%{svn}
 %patch0 -p1
+%patch1 -p1
+
+%if "%{cc_version}" < "3.4"
+# CC version is arbitary (just to be > 3.3)
+%{__sed} -i -e 's/-Wno-pointer-sign//;s/-Wdeclaration-after-statement//' {loader,dshowserver}/Makefile
+%endif
 
 %build
-cd %{pname}-%{version}
-make -C dshowserver %{?with_static:STATIC=1} && %{!?with_static:cd loader && make && cd ../}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-cd %{pname}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_bindir}
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-
-install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
-%{!?with_static:install loader/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec}
-
-install man/* $RPM_BUILD_ROOT%{_mandir}/man1
+%{__make} install -C dshowserver PREFIX=$RPM_BUILD_ROOT%{_prefix}
+install  -d $RPM_BUILD_ROOT%{_mandir}/man1
+#install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
+#install dshowserver/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec
+cp -a man/ds* $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-
-%postun
-
 %files
+%defattr(644,root,root,755)
+%doc README
 %attr(755,root,video) %{_bindir}/dshowserver
-%attr(644,root,root) %{_mandir}/man1/ds*
+%dir  %{_libdir}/dshowserver
+%attr(755,root,video) %{_libdir}/dshowserver/dshowserver.exe.so
+%{_mandir}/man1/ds*
 
-%if %{without static}
+%if 0
 %files -n registercodec
+%defattr(644,root,root,755)
 %attr(755,root,video) %{_bindir}/registercodec
-%attr(644,root,root) %{_mandir}/man1/re*
+%{_mandir}/man1/re*
 %endif
This page took 0.073614 seconds and 4 git commands to generate.