]> git.pld-linux.org Git - packages/drupal.git/blobdiff - drupal.spec
- 4.6.8; resolves SA-2006-007, SA-2006-008
[packages/drupal.git] / drupal.spec
index 327497d39f577c8199c81e9ae35e79d08bbf180a..d21288d2f063199d94720b73a9003cf35a1737a5 100644 (file)
@@ -1,14 +1,14 @@
 %define                _ver            4.6
-%define                _patchlevel     5
+%define                _patchlevel     8
 Summary:       Open source content management platform
 Summary(pl):   Platforma do zarz±dzania tre¶ci± o otwartych ¼ród³ach
 Name:          drupal
 Version:       %{_ver}.%{_patchlevel}
-Release:       0.21
+Release:       1
 License:       GPL
 Group:         Applications/WWW
 Source0:       http://drupal.org/files/projects/%{name}-%{version}.tar.gz
-# Source0-md5: 21e5e768d92fb6ecf52d56cacd37706e
+# Source0-md5: ffc5bf145f7cb6bb56fb50396cc76dd2
 Source1:       %{name}.conf
 Source2:       %{name}.cron
 Source3:       %{name}.PLD
@@ -258,10 +258,10 @@ fi
 %triggerun -- apache1
 %webapp_unregister apache %{_webapp}
 
-%triggerin -- apache >= 2.0.0
+%triggerin -- apache < 2.2.0, apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache >= 2.0.0
+%triggerun -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerpostun -- %{name} < 4.6.4-0.4
@@ -305,12 +305,41 @@ if [ -L /etc/httpd/httpd.conf/99_%{name}.conf ]; then
 fi
 
 if [ "$httpd_reload" ]; then
-       %service httpd reload
+       %service -q httpd reload
 fi
 if [ "$apache_reload" ]; then
-       %service apache reload
+       %service -q apache reload
 fi
 
+%triggerpostun -- %{name} < 4.6.8-0.5
+grep -l 'This_is_a_Drupal_security_line_do_not_remove' \
+%{_sysconfdir}/apache.conf %{_sysconfdir}/httpd.conf \
+| xargs -r \
+sed -i -e '
+/This_is_a_Drupal_security_line_do_not_remove/{
+       d
+       n
+       a\      SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
+       a\      Options None
+       a\      <IfModule mod_rewrite.c>
+       a\      \       RewriteEngine off
+       a\      </IfModule>
+}'
+egrep -c 'Drupal_Security_Do_Not_Remove_See_SA_2006_006' \
+%{_sysconfdir}/apache.conf %{_sysconfdir}/httpd.conf \
+| awk -F: '/:0/{print $1}' | xargs -r \
+sed -i -e '
+/<Directory \/var\/lib\/drupal>/{
+       n
+       a\      SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
+       a\      Options None
+       a\      <IfModule mod_rewrite.c>
+       a\      \       RewriteEngine off
+       a\      </IfModule>
+}'
+[ ! -L /etc/httpd/webapps.d/drupal.conf ] || %service -q httpd reload
+[ ! -L /etc/apache/webapps.d/drupal.conf ] || %service -q apache reload
+
 %files
 %defattr(644,root,root,755)
 %doc *.txt README.PLD
@@ -331,6 +360,7 @@ fi
 %{_appdir}/modules
 %{_appdir}/scripts
 %dir %{_appdir}/themes
+%dir %{_appdir}/themes/engines
 %{_appdir}/po
 %{_appdir}/update.php
 # symlinks
@@ -365,7 +395,8 @@ fi
 
 %files themes
 %defattr(644,root,root,755)
-%{_appdir}/themes/*
+%{_appdir}/themes/[!e]*
+%{_appdir}/themes/engines/*
 %{_appdir}/htdocs/themes/*
 
 %files xmlrpc
This page took 0.058891 seconds and 4 git commands to generate.