]> git.pld-linux.org Git - packages/drupal-mod-tinymce.git/blobdiff - drupal-mod-tinymce.spec
- update apache2 trigger to match apache-base in case somebody decides not to
[packages/drupal-mod-tinymce.git] / drupal-mod-tinymce.spec
index e700500b1589d4122606b4bd9d7d37ede9eca4be..be3504a272b0462cd6e094bd172b38e52f14337d 100644 (file)
@@ -3,24 +3,28 @@ Summary:      Drupal TinyMCE WYSIWYG Editor Module
 Summary(pl):   Modu³ edytora WYSIWYG TinyMCE dla Drupala
 Name:          drupal-mod-%{modname}
 Version:       4.6.0
-Release:       0.15
-Epoch:         0
+Release:       0.26
 License:       GPL
 Group:         Applications/WWW
 Source0:       http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
-# Source0-md5: dd7630860baf1f7f470d71c272d275eb
+# Source0-md5: 050b885a5437c492f2e9d49181db9326
 Source1:       %{name}.conf
 URL:           http://drupal.org/project/tinymce
-BuildRequires: rpmbuild(macros) >= 1.194
+BuildRequires: rpmbuild(macros) >= 1.264
 BuildRequires: sed >= 4.0
+Requires:      webapps >= 0.2
 Requires:      drupal >= 4.6.0
 Requires:      tinymce >= 1.44
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/drupal
-%define                _moddir         %{_datadir}/drupal/modules
-%define                _htmldir        %{_datadir}/drupal/htdocs/modules
+%define                _webapps        /etc/webapps
+%define                _webapp         drupal/%{modname}
+%define                _sysconfdir     %{_webapps}/%{_webapp}
+%define                _drupaldir      %{_datadir}/drupal
+%define                _moddir         %{_drupaldir}/modules
+%define                _htdocs         %{_drupaldir}/htdocs
+%define                _htmlmoddir     %{_htdocs}/modules/%{modname}
 %define                _tinymceplugindir       %{_datadir}/tinymce/plugins
 
 %description
@@ -47,21 +51,25 @@ Mo
 rm -f LICENSE.txt # pure GPL
 
 # undos the source
-find '(' -name '*.txt' ')' -print0 | xargs -0 sed -i -e 's,
-$,,'
+find '(' -name '*.txt' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_moddir},%{_htmldir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_moddir}}
 install -d $RPM_BUILD_ROOT%{_tinymceplugindir}
 
 install *.module $RPM_BUILD_ROOT%{_moddir}
 cp -a plugins/* $RPM_BUILD_ROOT%{_tinymceplugindir}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache-%{modname}.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
-install -d $RPM_BUILD_ROOT%{_htmldir}/tinymce/jscripts
-ln -s %{_datadir}/tinymce $RPM_BUILD_ROOT%{_htmldir}/tinymce/jscripts/tiny_mce
-ln -s ../htdocs/modules/tinymce $RPM_BUILD_ROOT%{_moddir}/tinymce
+install -d $RPM_BUILD_ROOT%{_moddir}/tinymce/jscripts
+ln -s %{_datadir}/tinymce $RPM_BUILD_ROOT%{_moddir}/tinymce/jscripts/tiny_mce
+
+# need symlink for drupal to think the file is there, we also do
+# apache alias as the symlinks aren't usually allowed in htdocs
+install -d $RPM_BUILD_ROOT%{_htmlmoddir}/jscripts
+ln -s %{_datadir}/tinymce $RPM_BUILD_ROOT%{_htmlmoddir}/jscripts/tiny_mce
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -75,11 +83,65 @@ zcat %{_docdir}/%{name}-%{version}/tinymce.mysql.gz | mysql drupal
 EOF
 fi
 
+%triggerin -- apache1
+# TODO install it only if this apache instance has drupal configured
+%webapp_register apache %{_webapp}
+
+%triggerun -- apache1
+%webapp_unregister apache %{_webapp}
+
+%triggerin -- apache < 2.2.0, apache-base
+# TODO install it only if this apache instance has drupal configured
+%webapp_register httpd %{_webapp}
+
+%triggerun -- apache < 2.2.0, apache-base
+%webapp_unregister httpd %{_webapp}
+
+%triggerpostun -- %{name} < 4.6.0-0.25
+# migrate from apache-config macros
+if [ -f /etc/drupal/apache-tinymce.conf.rpmsave ]; then
+       if [ -d /etc/apache/webapps.d ]; then
+               cp -f %{_sysconfdir}/apache.conf{,.rpmnew}
+               cp -f /etc/drupal/apache-tinymce.conf.rpmsave %{_sysconfdir}/apache.conf
+       fi
+
+       if [ -d /etc/httpd/webapps.d ]; then
+               cp -f %{_sysconfdir}/httpd.conf{,.rpmnew}
+               cp -f /etc/drupal/apache-tinymce.conf.rpmsave %{_sysconfdir}/httpd.conf
+       fi
+       rm -f /etc/drupal/apache-tinymce.conf.rpmsave
+fi
+
+# place new config location, as trigger puts config only on first install, do it here.
+if [ -L /etc/apache/conf.d/99_%{name}.conf ]; then
+       rm -f /etc/apache/conf.d/99_%{name}.conf
+       /usr/sbin/webapp register apache %{_webapp}
+       apache_reload=1
+fi
+if [ -L /etc/httpd/httpd.conf/99_%{name}.conf ]; then
+       rm -f /etc/httpd/httpd.conf/99_%{name}.conf
+       /usr/sbin/webapp register httpd %{_webapp}
+       httpd_reload=1
+fi
+
+if [ "$httpd_reload" ]; then
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd reload 1>&2
+       fi
+fi
+if [ "$apache_reload" ]; then
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache reload 1>&2
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc *.txt tinymce.{mysql,pgsql}
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
+%dir %attr(750,root,http) %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %{_moddir}/*.module
 %{_moddir}/tinymce
-%{_htmldir}/tinymce
 %{_tinymceplugindir}/*
+%{_htmlmoddir}
This page took 0.062938 seconds and 4 git commands to generate.