]> git.pld-linux.org Git - packages/dehydrated.git/blobdiff - dehydrated.spec
add hook-dns-01.sh
[packages/dehydrated.git] / dehydrated.spec
index 56089e5a3dbf0f7048f9cce52272c7ee6e20d338..bdff567ac21a4beb163d1ad9be445aafcadcee01 100644 (file)
@@ -1,21 +1,25 @@
 Summary:       letsencrypt/acme client implemented as a shell-script
 Name:          dehydrated
-Version:       0.3.1
-Release:       0.5
+Version:       0.6.1
+Release:       2
 License:       MIT
 Group:         Applications/Networking
 Source0:       https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 7a3b92b963da6469c4a53f051d6efa24
+# Source0-md5: 97425cf8aaa1a9a1a86036a1b7611a8c
 Source1:       apache.conf
 Source2:       lighttpd.conf
+Source3:       nginx.conf
 Source4:       domains.txt
 Source5:       hook.sh
-Source6:       crontab
+Source6:       hook-dns-01.sh
+Source7:       crontab
 Patch0:                pld.patch
 URL:           https://github.com/lukas2511/dehydrated
 BuildRequires: rpmbuild(macros) >= 1.713
+Requires:      ca-certificates
 Requires:      crondaemon
 Requires:      curl
+Requires:      diffutils
 Requires:      grep
 Requires:      mktemp
 Requires:      openssl-tools
@@ -23,8 +27,6 @@ Requires:     sed
 Requires:      webapps
 Suggests:      webserver(access)
 Suggests:      webserver(alias)
-Provides:      letsencrypt.sh = %{version}
-Obsoletes:     letsencrypt.sh < 0.3
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -57,10 +59,12 @@ install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d} \
 install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
 cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
-cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
+cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/cron.d/%{name}
 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
+install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
 %clean
@@ -84,6 +88,12 @@ rm -rf $RPM_BUILD_ROOT
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
+%triggerin -- nginx
+%webapp_register nginx %{_webapp}
+
+%triggerun -- nginx
+%webapp_unregister nginx %{_webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc README.md CHANGELOG LICENSE
@@ -92,9 +102,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
+%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook-dns-01.sh
 %attr(755,root,root) %{_sbindir}/%{name}
 %dir %attr(751,root,root) /var/lib/%{name}
 %dir %attr(700,root,root) /var/lib/%{name}/accounts
This page took 0.060192 seconds and 4 git commands to generate.