]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blobdiff - crossmingw32-gcc.spec
- updated to 10.5.0
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
index 24c88fd0526a4736bd05c86087862813bbd355cf..172b049ea9e0c634a93476e99ad678bc156a2e8a 100644 (file)
@@ -1,9 +1,13 @@
 #
 # Conditional build:
 %bcond_with    bootstrap       # bootstrap build (using binary w32api/mingwrt, only C/C++, no gomp)
+%bcond_without pthreads        # POSIX threads support (needed for GOMP and C++ 11 thread/mutex support)
 %bcond_without gomp            # OpenMP libraries
 #
 %if %{with bootstrap}
+%undefine      with_pthreads
+%endif
+%if %{without pthreads}
 %undefine      with_gomp
 %endif
 Summary:       Cross MinGW32 GNU binary utility development utilities - gcc
@@ -13,13 +17,13 @@ Summary(pl.UTF-8):  Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
 Summary(pt_BR.UTF-8):  Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
 Summary(tr.UTF-8):     GNU geliştirme araçları - MinGW32 gcc
 Name:          crossmingw32-gcc
-Version:       9.5.0
+Version:       10.5.0
 Release:       1
 Epoch:         1
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.xz
-# Source0-md5: 34cd76facb562835ff5faca81fead17e
+# Source0-md5: c7d1958570fbd1cd859b015774b9987a
 %define                w32api_ver      5.4.2
 #Source1Download: https://osdn.net/projects/mingw/releases/
 Source1:       https://osdn.net/projects/mingw/downloads/74926/w32api-%{w32api_ver}-mingw32-dev.tar.xz
@@ -35,15 +39,16 @@ Patch1:             %{name}-buildsystem2.patch
 Patch2:                %{name}-lfs.patch
 Patch3:                gcc-mingw32.patch
 Patch4:                gcc-build-libvtv.patch
+Patch5:                gcc-pthreads-w32.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11.1
 BuildRequires: bison
-BuildRequires: crossmingw32-binutils >= 2.23
-%{?with_gomp:BuildRequires:    crossmingw32-pthreads-w32}
+BuildRequires: crossmingw32-binutils >= 2.30
+%{?with_pthreads:BuildRequires:        crossmingw32-pthreads-w32}
 %if %{without bootstrap}
 BuildRequires: crossmingw32-runtime >= 3.5
-BuildRequires: crossmingw32-w32api >= 3.1
+BuildRequires: crossmingw32-w32api >= 1:5.4.2-3
 %endif
 BuildRequires: flex >= 2.5.4
 BuildRequires: gettext-tools >= 0.14.5
@@ -51,19 +56,19 @@ BuildRequires:      gmp-devel >= 4.3.2
 BuildRequires: isl-devel >= 0.15
 BuildRequires: libmpc-devel >= 0.8.1
 BuildRequires: libstdc++-devel
-BuildRequires: mpfr-devel >= 2.4.2
+BuildRequires: mpfr-devel >= 3.1.0
 BuildRequires: perl-tools-pod
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.7
 BuildRequires: xz
 BuildRequires: zlib-devel
 BuildConflicts:        pdksh < 5.2.14-50
-Requires:      crossmingw32-binutils >= 2.23
+Requires:      crossmingw32-binutils >= 2.30
 Requires:      gcc-dirs
 Requires:      gmp >= 4.3.2
 Requires:      isl >= 0.15
 Requires:      libmpc >= 0.8.1
-Requires:      mpfr >= 2.4.2
+Requires:      mpfr >= 3.1.0
 # java support dropped from gcc 7+
 Obsoletes:     crossmingw32-java < 1:7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -477,6 +482,7 @@ Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %if %{with bootstrap}
 # note: "winsup" dirs are special, handled by gcc's configure
@@ -550,7 +556,7 @@ CXXFLAGS_FOR_TARGET="-O2 -march=i486" \
        --enable-shared \
        --disable-sjlj-exceptions \
        --disable-symvers \
-       --enable-threads \
+       --enable-threads%{?with_pthreads:=posix} \
        --disable-werror \
        --disable-win32-registry \
        --target=%{target}
@@ -579,6 +585,7 @@ ln -sf %{archbindir}/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
 ln -sf %{archbindir}/%{target}-gcov-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-dump
 ln -sf %{archbindir}/%{target}-gcov-tool $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-tool
 ln -sf %{archbindir}/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
+ln -sf %{archbindir}/%{target}-lto-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-lto-dump
 
 # DLLs
 install -d $RPM_BUILD_ROOT%{_dlldir}
@@ -629,6 +636,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/%{target}-gcov
 %attr(755,root,root) %{_bindir}/%{target}-gcov-dump
 %attr(755,root,root) %{_bindir}/%{target}-gcov-tool
+%attr(755,root,root) %{_bindir}/%{target}-lto-dump
 %attr(755,root,root) %{archbindir}/%{target}-cpp
 %attr(755,root,root) %{archbindir}/%{target}-gcc
 %attr(755,root,root) %{archbindir}/%{target}-gcc-%{version}
@@ -638,6 +646,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{archbindir}/%{target}-gcov
 %attr(755,root,root) %{archbindir}/%{target}-gcov-dump
 %attr(755,root,root) %{archbindir}/%{target}-gcov-tool
+%attr(755,root,root) %{archbindir}/%{target}-lto-dump
 %{archlibdir}/libgcc_s.a
 %dir %{gccarchdir}
 %dir %{gcclibdir}
@@ -659,6 +668,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/%{target}-gcov.1*
 %{_mandir}/man1/%{target}-gcov-dump.1*
 %{_mandir}/man1/%{target}-gcov-tool.1*
+%{_mandir}/man1/%{target}-lto-dump.1*
 
 %files -n crossmingw32-libgcc-dll
 %defattr(644,root,root,755)
@@ -722,6 +732,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{gcclibdir}/cc1plus
 %{archlibdir}/libstdc++.dll.a
 %{archlibdir}/libstdc++.la
+%{archlibdir}/libstdc++fs.a
+%{archlibdir}/libstdc++fs.la
 %{archlibdir}/libsupc++.la
 %{archlibdir}/libsupc++.a
 %{archincludedir}/c++
This page took 0.075284 seconds and 4 git commands to generate.