]> git.pld-linux.org Git - packages/crossmingw32-expat.git/blobdiff - crossmingw32-expat.spec
- updated to 2.4.4 (fixes CVE-2021-45960 CVE-2022-23852 CVE-2022-23990)
[packages/crossmingw32-expat.git] / crossmingw32-expat.spec
index b4435f9a599fd7d73e0ffb8ef0dd946238f3bf5d..49f39bacd132c6b3e9f7c26fedeae609165022ed 100644 (file)
@@ -1,40 +1,47 @@
-%define                realname                expat
 Summary:       XML 1.0 parser - Ming32 cross version
-Summary(pl.UTF-8):   Analizator składni XML-a 1.0 - wersja skrośna dla Ming32
-Summary(pt_BR.UTF-8):   Biblioteca XML expat
-Summary(ru.UTF-8):   Переносимая библиотека разбора XML (expat)
-Summary(uk.UTF-8):   Переносима бібліотека розбору XML (expat)
+Summary(pl.UTF-8):     Analizator składni XML-a 1.0 - wersja skrośna dla Ming32
+%define                realname                expat
 Name:          crossmingw32-%{realname}
-Version:       2.0.0
+Version:       2.4.4
 Release:       1
-License:       Thai Open Source Software Center Ltd (distributable)
-Group:         Applications/Publishing/XML
-Source0:       http://dl.sourceforge.net/expat/%{realname}-%{version}.tar.gz
-# Source0-md5: d945df7f1c0868c5c73cf66ba9596f3f
-Patch0:                %{realname}-ac_fixes.patch
-Patch1:                %{realname}-soname.patch
-URL:           http://expat.sourceforge.net/
-BuildRequires: autoconf
+License:       MIT
+Group:         Development/Libraries
+Source0:       https://downloads.sourceforge.net/expat/%{realname}-%{version}.tar.xz
+# Source0-md5: a712d23b7afb32e7527cf0b3fd8f12ac
+URL:           http://www.libexpat.org/
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
-BuildRequires: crossmingw32-gcc
-BuildRequires: libtool
+BuildRequires: crossmingw32-gcc >= 1:3.2
+BuildRequires: libtool >= 2:2.4
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 Requires:      crossmingw32-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
+%define                _enable_debug_packages  0
 
 %define                target                  i386-mingw32
 %define                target_platform         i386-pc-mingw32
+
 %define                _sysprefix              /usr
 %define                _prefix                 %{_sysprefix}/%{target}
-
+%define                _libdir                 %{_prefix}/lib
+%define                _pkgconfigdir           %{_prefix}/lib/pkgconfig
+%define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
+%define                __pkgconfig_provides    %{nil}
+%define                __pkgconfig_requires    %{nil}
 
-%ifarch alpha sparc sparc64 sparcv9
-# alpha's -mieee and sparc's -mtune=* are not valid for target's gcc
+%ifnarch %{ix86}
+# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
 %define                optflags        -O2
 %endif
+# -z options are invalid for mingw linker
+%define                filterout_ld    -Wl,-z,.*
+%define                filterout_c     -f[-a-z0-9=]*
+%define                filterout_cxx   -f[-a-z0-9=]*
 
 %description
 Expat is an XML parser written in C. It aims to be fully conforming.
@@ -49,34 +56,45 @@ potwiedzał by zgodność ze specyfikacją.
 
 Ten pakiet zawiera wersję skrośną dla Win32.
 
-%description -l pt_BR.UTF-8
-Esta é a biblioteca, em C, XML expat, de James Clark. É um analisador
-orientado a fluxo de informações que pede o uso de handlers para lidar
-com a estrutura que o analisador encontrar no documento.
+%package static
+Summary:       Static expat library (cross mingw32 version)
+Summary(pl.UTF-8):     Statyczna biblioteka expat (wersja skrośna mingw32)
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description static
+Static expat library (cross mingw32 version).
+
+%description static -l pl.UTF-8
+Statyczna biblioteka expat (wersja skrośna mingw32).
+
+%package dll
+Summary:       DLL expat library for Windows
+Summary(pl.UTF-8):     Biblioteka DLL expat dla Windows
+Group:         Applications/Emulators
+Requires:      wine
 
-%description -l ru.UTF-8
-Expat -- парсер XML 1.0, написанный на C. Он предназначен для того,
-чтобы быть полностью совместимым. В настоящее время это не проверяющий
-("not a validating") XML парсер.
+%description dll
+DLL expat library for Windows.
 
-%description -l uk.UTF-8
-Expat -- парсер XML 1.0, написаний на C. Розрахований на те, щоб бути
-повністю сумісним. Наразі це не перевіряючий ("not a validating") XML
-парсер.
+%description dll -l pl.UTF-8
+Biblioteka DLL expat dla Windows.
 
 %prep
 %setup -q -n %{realname}-%{version}
-%patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --target=%{target} \
-       --host=%{target_platform} \
-       --disable-static
+       --host=%{target} \
+       --without-docbook \
+       --without-xmlwf
+
 %{__make}
 
 %install
@@ -85,8 +103,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install -d $RPM_BUILD_ROOT%{_dlldir}
+%{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
+
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/cmake
+
 %if 0%{!?debug:1}
-%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_bindir}/*.dll
+%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
 %endif
 
@@ -95,7 +118,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{_bindir}/libexpat-0.dll
+%doc AUTHORS COPYING Changes README.md
 %{_libdir}/libexpat.dll.a
 %{_libdir}/libexpat.la
 %{_includedir}/expat*.h
+%{_pkgconfigdir}/expat.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libexpat.a
+
+%files dll
+%defattr(644,root,root,755)
+%{_dlldir}/libexpat-1.dll
This page took 0.051961 seconds and 4 git commands to generate.