]> git.pld-linux.org Git - packages/courier.git/blobdiff - courier.spec
- update post,preun; fix certsdir perm; rel.1
[packages/courier.git] / courier.spec
index d8277039fce676665c3124976ba86a0d7cbfbd7b..3b0d1f2017e08f39a0c33161d11d77a4b636b2cc 100644 (file)
@@ -6,7 +6,7 @@ Summary:        Courier mail server
 Summary(pl):   Serwer poczty Courier
 Name:          courier
 Version:       0.45.5
-Release:       0.1
+Release:       1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
@@ -17,6 +17,7 @@ Patch2:               %{name}-maildir.patch
 Patch3:                %{name}-sendmail_dir.patch
 Patch4:                %{name}-start_scripts.patch
 Patch5:                %{name}-fix_build.patch
+Patch6:                %{name}-certs.patch
 URL:           http://www.courier-mta.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -62,6 +63,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libexecdir     %{_libdir}
 %define                _localstatedir  /var/spool/courier
 %define                _sysconfdir     /etc/courier
+%define                _certsdir       %{_sysconfdir}/certs
 %define                initdir         /etc/rc.d/init.d
 
 # Change the following if your DocumentRoot and cgibindir differ.  This is
@@ -305,6 +307,7 @@ Ten pakiet pozwala na korzystanie z autentykacji PostgreSQL w Courierze.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %build
 # we don't want fax module
@@ -334,6 +337,18 @@ cd courier
 %{__autoconf}
 ln -s ../ltmain.sh .
 %{__automake}
+
+cd module.esmtp
+%{__aclocal}
+%{__autoconf}
+ln -s ../ltmain.sh .
+%{__automake}
+cd ../..
+
+cd imap
+%{__aclocal}
+%{__autoconf}
+%{__automake}
 cd ..
 
 %configure \
@@ -341,6 +356,7 @@ cd ..
        --sysconfdir=%{_sysconfdir} \
        --mandir=%{_mandir} \
        --enable-imageurl=%{_imageurl} \
+       --with-certsdir=%{_certsdir} \
        --with-db=db \
        --with-mailer=%{_sbindir}/sendmail
 
@@ -354,7 +370,7 @@ install -d -p $RPM_BUILD_ROOT{/etc/{cron.hourly,pam.d},%{initdir}} \
        $RPM_BUILD_ROOT{%{_cgibindir},%{_documentrootdir},%{_prefix}/lib} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{userdb,hosteddomains,shared} \
        $RPM_BUILD_ROOT%{_localstatedir}{/calendar/{private,public},/tmp/broken} \
-       $RPM_BUILD_ROOT/etc/cron.hourly
+       $RPM_BUILD_ROOT{/etc/cron.hourly,%{_certsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -529,9 +545,15 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/courierwebadmin/*fax*
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%triggerin -- courier < 0.45.5
+echo
+echo Directory with certificates has changed to %{_certsdir}
+echo
+
 %post
-if [ "$1" = "1" ]; then
 /sbin/chkconfig --add courier
+
+if [ "$1" = "1" ]; then
 /bin/hostname -f >/etc/courier/me
 cat <<EOF
 
@@ -569,10 +591,20 @@ if [ -e %{_localstatedir}/tmp/imapd.pid ]; then
     %{_sbindir}/imapd stop
     %{_sbindir}/imapd start
 fi
+else
+echo
+echo Type "%{_sbindir}/imapd start" to start imapd server
+echo
+fi
 if [ -e %{_localstatedir}/tmp/imapd-ssl.pid ]; then
     %{_sbindir}/imapd-ssl stop
     %{_sbindir}/imapd-ssl start
 fi
+else
+echo
+echo Type "%{_sbindir}/imapd-ssl start" to start imapd-ssl server
+echo
+fi
 
 %preun imapd
 if [ "$1" = "0" ]; then
@@ -589,10 +621,20 @@ if [ -e %{_localstatedir}/tmp/pop3d.pid ]; then
     %{_sbindir}/pop3d stop
     %{_sbindir}/pop3d start
 fi
+else
+echo
+echo Type "%{_sbindir}/pop3d start" to start pop3d server
+echo
+fi
 if [ -e %{_localstatedir}/tmp/pop3d-ssl.pid ]; then
     %{_sbindir}/pop3d-ssl stop
     %{_sbindir}/pop3d-ssl start
 fi
+else
+echo
+echo Type "%{_sbindir}/pop3d-ssl start" to start pop3d-ssl server
+echo
+fi
 
 %preun pop3d
 if [ "$1" = "0" ]; then
@@ -618,19 +660,19 @@ echo If you want to have calendar starting by default then
 echo put word net to %{_sysconfdir}/calendarmode
 echo
 fi
-if ps -A |grep -q sqwebmaild; then
-    %{_libdir}/courier/sqwebmaild stop
-    %{_libdir}/courier/sqwebmaild start
+if [ -e %{_localstatedir}/tmp/sqwebmaild.pid ]; then
+    %{_sbindir}/webmaild stop
+    %{_sbindir}/webmaild start
 else
 echo
-echo Type "%{_libdir}/courier/sqwebmaild start" to start webmail server
+echo Type "%{_sbindir}/webmaild start" to start webmail server
 echo
 fi
 
 %preun webmail
 if [ "$1" = "0" ]; then
-    if ps -A |grep -q sqwebmaild; then
-       %{_libdir}/courier/sqwebmaild stop
+    if [ -e %{_localstatedir}/tmp/sqwebmaild.pid ]; then
+       %{_sbindir}/webmaild stop
     fi
 fi
 
@@ -721,6 +763,7 @@ fi
 %{_mandir}/man1/testmxlookup.1*
 %{_mandir}/man1/dot-forward.1*
 %{_mandir}/man1/couriertls.1*
+%{_mandir}/man1/courierlogger.1*
 %{_mandir}/man1/mailq*
 %{_mandir}/man1/couriertcpd*
 %{_mandir}/man1/dotforward.1*
@@ -761,6 +804,7 @@ fi
 %{_mandir}/man8/pw2userdb.8*
 %{_mandir}/man8/vchkpw2userdb.8*
 %dir %{_sysconfdir}
+%attr(750,daemon,root) %dir %{_certsdir}
 %attr(755,daemon,daemon) %dir %{_sysconfdir}/hosteddomains
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/me
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ldapaddressbook
@@ -801,7 +845,6 @@ fi
 %attr(755,root,root) %{_datadir}/makeuucpneighbors
 %dir %{_libdir}/courier/modules/local
 %attr(644,daemon,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/module.local
-%attr(644,daemon,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authmodulelist
 %attr(755,root,root) %{_libdir}/courier/modules/local/courierlocal
 %attr(755,root,root) %{_libdir}/courier/modules/local/courierdeliver
 %attr(755,root,root) %{_bindir}/preline
@@ -983,6 +1026,8 @@ fi
 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/webmail
 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/calendar
 %{_documentrootdir}/webmail
+%attr(644,daemon,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sqwebmaild
+%attr(755,root,root) %{_sbindir}/webmaild
 %dir %{_datadir}/sqwebmail
 %dir %{_datadir}/sqwebmail/html
 %dir %{_datadir}/sqwebmail/html/en-us
This page took 0.073224 seconds and 4 git commands to generate.