]> git.pld-linux.org Git - packages/courier-imap.git/blobdiff - courier-imap.spec
- fixed shell syntax
[packages/courier-imap.git] / courier-imap.spec
index 5828e9ce82003cd002560f8a8fcc9f9abc30ea56..f4782196fced17b08b43dd5a149814a57eff6908 100644 (file)
@@ -1,16 +1,17 @@
 #
 # Conditional build:
-# _without_ldap - without LDAP support
-# _without_mysql - without MySQL support
-# _without_postgresql - without PostgreSQL support
+%bcond_without ldap    # without LDAP support
+%bcond_without mysql   # without MySQL support
+%bcond_without pgsql   # without PostgreSQL support
 Summary:       Courier-IMAP server
 Summary(pl):   Serwer Courier-IMAP
 Name:          courier-imap
-Version:       1.4.2
-Release:       4
+Version:       2.2.1
+Release:       1
 License:       GPL
 Group:         Networking/Daemons
-Source0:       http://download.sourceforge.net/courier/%{name}-%{version}.tar.gz
+Source0:       http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
+# Source0-md5: 27c90ce2ac2412bc90994cacbd75616b
 Source1:       %{name}.init
 Source2:       %{name}-pop3.init
 Source3:       %{name}-authdaemon.init
@@ -19,20 +20,23 @@ Source5:    %{name}-pop3.pamd
 Source6:       %{name}.sysconfig
 Source7:       %{name}-pop3.sysconfig
 Source8:       %{name}-authdaemon.sysconfig
-Patch0:                ftp://ftp.pld.org.pl/people/siefca/patches/courier/%{name}-myownquery-fix.patch
 URL:           http://www.inter7.com/courierimap/
-%{!?_without_postgresql:BuildRequires: postgresql-devel}
-%{!?_without_mysql:BuildRequires:      mysql-devel}
-%{!?_without_mysql:BuildRequires:      zlib-devel}
-%{!?_without_ldap:BuildRequires:       openldap-devel}
 BuildRequires: gdbm-devel
 BuildRequires: libstdc++-devel
-BuildRequires: openssl-devel
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: openssl-devel >= 0.9.7c
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+%{?with_mysql:BuildRequires:   zlib-devel}
 PreReq:                %{name}-common = %{version}
+PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
+Requires:      pam >= 0.77.3
 Provides:      imapdaemon
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     imapdaemon
+Conflicts:     cyrus-imapd
 Conflicts:     imap
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libexecdir     /usr/lib/courier-imap
 %define                _sysconfdir     /etc/courier-imap
@@ -48,9 +52,9 @@ Summary:      Common files for imap and pop daemons
 Summary(pl):   Pliki wspólne dla serwerów imap i pop
 Group:         Networking/Daemons
 PreReq:                rc-scripts
-PreReq:                /sbin/chkconfig
-Requires:      %{name}-maildirmake
+Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-deliverquota
+Requires:      %{name}-maildirmake
 Requires:      %{name}-userdb
 
 %description common
@@ -101,9 +105,12 @@ Summary:   Courier-IMAP POP3 Server
 Summary(pl):   Serwer Courier-IMAP POP3
 Group:         Networking/Daemons
 PreReq:                %{name}-common = %{version}
+Requires:      pam >= 0.77.3
 Provides:      pop3daemon
 Obsoletes:     pop3daemon
+Conflicts:     cyrus-imapd
 Conflicts:     imap-pop3
+Conflicts:     solid-pop3d
 Conflicts:     tpop3d
 
 %description pop3
@@ -152,18 +159,17 @@ IMAP.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
-%configure2_13 \
+%configure \
        --enable-unicode \
        --with-authchangepwdir=/var/tmp \
        --with-authdaemonvar=/var/lib/authdaemon \
-       %{!?_without_mysql:--with-mysql-libs=%{_libdir} --with-mysql-includes=%{_includedir}/mysql} \
-       %{?_without_mysql:--without-authmysql} \
-       %{!?_without_postgresql:--with-pgsql-libs=%{_libdir} --with-pgsql-includes=%{_includedir}/postgresql} \
-       %{?_without_postgresql:--without-authpgsql} \
-       %{?_without_ldap:--without-authldap}
+       %{?with_mysql:--with-mysql-libs=%{_libdir} --with-mysql-includes=%{_includedir}/mysql} \
+       %{!?with_mysql:--without-authmysql} \
+       %{?with_pgsql:--with-pgsql-libs=%{_libdir} --with-pgsql-includes=%{_includedir}/postgresql} \
+       %{!?with_pgsql:--without-authpgsql} \
+       %{!?with_ldap:--without-authldap}
 
 %{__make}
 
@@ -172,17 +178,18 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,security,sysconfig} \
        $RPM_BUILD_ROOT{%{_sysconfdir},/var/lib/authdaemon}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-imap
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-imap-pop3
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-pop3
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/authdaemon
 
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/imap
 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/pop3
 
 install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/courier-imap
-install %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/courier-imap-pop3
+install %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/courier-pop3
 install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/authdaemon
 
 rm -rf $RPM_BUILD_ROOT%{_mandir}/man8/{authcram,authpam,authpwd,authshadow,authuserdb,authvchkpw,pw2userdb,vchkpw2userdb,authdaemon,authdaemond,authldap,authmysql}.8 \
@@ -192,6 +199,7 @@ mv -f authlib/README.authmysql.html README.authmysql.html
 mv -f authlib/README.ldap README.ldap
 mv -f authlib/README.authmysql.myownquery README.authmysql.myownquery
 mv -f imap/README README.imap
+mv -f imap/ChangeLog ChangeLog
 mv -f maildir/README.maildirquota.txt README.maildirquota
 
 install authlib/authdaemonrc           $RPM_BUILD_ROOT%{_sysconfdir}
@@ -204,20 +212,20 @@ mv -f $RPM_BUILD_ROOT%{_datadir}/*db \
 mv -f $RPM_BUILD_ROOT%{_datadir}/mk*cert \
        $RPM_BUILD_ROOT%{_sbindir}
 
-mv -f tcpd/couriertls.1 $RPM_BUILD_ROOT%{_mandir}/man8/couriertls.1
+mv -f tcpd/couriertls.1 $RPM_BUILD_ROOT%{_mandir}/man8/couriertls.8
 mv -f imap/courierpop3d.8 $RPM_BUILD_ROOT%{_mandir}/man8/courierpop3d.8
 
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authcram.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authpam.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authpwd.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authshadow.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authuserdb.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authvchkpw.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemon.8
-echo ".so authlib.8"   >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemond.8
-%{!?_without_pgsql:echo ".so authlib.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/authpgsql.8}
-%{!?_without_mysql:echo ".so authlib.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/authmysql.8}
-%{!?_without_ldap:echo ".so authlib.8" >$RPM_BUILD_ROOT%{_mandir}/man8/authldap.8}
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authcram.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authpam.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authpwd.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authshadow.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authuserdb.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authvchkpw.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemon.8
+echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemond.8
+%{?with_pgsql:echo ".so man7/authlib.7"        >$RPM_BUILD_ROOT%{_mandir}/man8/authpgsql.8}
+%{?with_mysql:echo ".so man7/authlib.7"        >$RPM_BUILD_ROOT%{_mandir}/man8/authmysql.8}
+%{?with_ldap:echo ".so man7/authlib.7" >$RPM_BUILD_ROOT%{_mandir}/man8/authldap.8}
 echo ".so makeuserdb.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/pw2userdb.8
 echo ".so makeuserdb.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/vchkpw2userdb.8
 
@@ -262,20 +270,29 @@ if [ "$1" = "0" ]; then
 fi
 
 %post pop3
-/sbin/chkconfig --add courier-imap-pop3
-
+/sbin/chkconfig --add courier-pop3
+/sbin/chkconfig --del courier-imap-pop3 >/dev/null 2>&1 || :
 if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
-       /etc/rc.d/init.d/courier-imap-pop3 restart >&2
+       /etc/rc.d/init.d/courier-imap-pop3 stop >&2
+       /etc/rc.d/init.d/courier-pop3 start >&2
+elif [ -f /var/lock/subsys/courier-pop3 ]; then
+       /etc/rc.d/init.d/courier-pop3 restart >&2
 else
-       echo "Run \"/etc/rc.d/init.d/courier-imap-pop3 start\" to start courier-imap pop3 daemon."
+       echo "Run \"/etc/rc.d/init.d/courier-pop3 start\" to start courier-pop3 daemon."
 fi
+rm -f /etc/rc.d/init.d/courier-imap-pop3
 
 %preun pop3
 if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/courier-pop3 ]; then
+               /etc/rc.d/init.d/courier-pop3 stop >&2
+       fi
+       /sbin/chkconfig --del courier-pop3
        if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
                /etc/rc.d/init.d/courier-imap-pop3 stop >&2
        fi
-       /sbin/chkconfig --del courier-imap-pop3
+       /sbin/chkconfig --del courier-imap-pop3 >/dev/null 2>&1 || :
+       rm -f /etc/rc.d/init.d/courier-imap-pop3
 fi
 
 %post authldap
@@ -326,13 +343,15 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/courier-imap
 %{_sysconfdir}/imapd.cnf
 %attr(755,root,root) %{_bindir}/imapd
+%attr(755,root,root) %{_bindir}/maildirkw
 %attr(755,root,root) %{_sbindir}/imaplogin
 %attr(755,root,root) %{_sbindir}/mkimapdcert
 %{_mandir}/man8/imapd*
+%{_mandir}/man1/maildirkw.1*
 
 %files common
 %defattr(644,root,root,755)
-%doc README* imap/BUGS AUTHORS COPYING
+%doc README* imap/BUGS ChangeLog AUTHORS
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/authdaemon
 %attr(754,root,root) /etc/rc.d/init.d/authdaemon
 %attr(700,root,root) /var/lib/authdaemon
@@ -345,12 +364,13 @@ fi
 %attr(755,root,root) %{_libexecdir}/authlib/authdaemon
 %attr(755,root,root) %{_libexecdir}/authlib/authdaemond.plain
 %attr(755,root,root) %{_libexecdir}/couriertcpd
-%attr(755,root,root) %{_libexecdir}/logger
+%attr(755,root,root) %{_libexecdir}/courierlogger
 %attr(755,root,root) %{_libexecdir}/makedatprog
 %{_mandir}/man8/auth[cdsuv]*
 %{_mandir}/man8/authp[aw]*
 %{_mandir}/man7/authlib*
 %{_mandir}/man1/couriert*
+%{_mandir}/man8/couriert*
 %{_mandir}/man8/mk*
 
 %files userdb
@@ -366,7 +386,7 @@ fi
 
 %files deliverquota
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libexecdir}/deliverquota
+%attr(755,root,root) %{_bindir}/deliverquota
 %{_mandir}/man8/deliverquota*
 
 %files maildirmake
@@ -378,15 +398,15 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/pop3
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.pop3
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/courier-imap-pop3
-%attr(754,root,root) /etc/rc.d/init.d/courier-imap-pop3
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/courier-pop3
+%attr(754,root,root) /etc/rc.d/init.d/courier-pop3
 %attr(755,root,root) %{_bindir}/pop3d
 %attr(755,root,root) %{_sbindir}/mkpop3dcert
 %attr(755,root,root) %{_sbindir}/pop3login
 %{_sysconfdir}/pop3d.cnf
 %{_mandir}/man8/courierpop*
 
-%if %{?_without_ldap:0}%{!?_without_ldap:1}
+%if %{with ldap}
 %files authldap
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authldaprc
@@ -394,7 +414,7 @@ fi
 %{_mandir}/man8/authldap*
 %endif
 
-%if %{?_without_mysql:0}%{!?_without_mysql:1}
+%if %{with mysql}
 %files authmysql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authmysqlrc
@@ -402,7 +422,7 @@ fi
 %{_mandir}/man8/authmysql*
 %endif
 
-%if %{?_without_pgsql:0}%{!?_without_pgsql:1}
+%if %{with pgsql}
 %files authpgsql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authpgsqlrc
This page took 0.157607 seconds and 4 git commands to generate.