]> git.pld-linux.org Git - packages/courier-imap.git/blobdiff - courier-imap.spec
- fixed shell syntax
[packages/courier-imap.git] / courier-imap.spec
index 19735b4005a335160243d171f8c943c563634df1..f4782196fced17b08b43dd5a149814a57eff6908 100644 (file)
@@ -1,18 +1,17 @@
 #
 # Conditional build:
-# _without_ldap                - without LDAP support
-# _without_mysql       - without MySQL support
-# _without_pgsql       - without PostgreSQL support
-#
+%bcond_without ldap    # without LDAP support
+%bcond_without mysql   # without MySQL support
+%bcond_without pgsql   # without PostgreSQL support
 Summary:       Courier-IMAP server
 Summary(pl):   Serwer Courier-IMAP
 Name:          courier-imap
-Version:       2.1.1
+Version:       2.2.1
 Release:       1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/courier/%{name}-%{version}.tar.bz2
-# Source0-md5: 71d9e88053351dbf7df04943189ec1cd
+# Source0-md5: 27c90ce2ac2412bc90994cacbd75616b
 Source1:       %{name}.init
 Source2:       %{name}-pop3.init
 Source3:       %{name}-authdaemon.init
@@ -21,18 +20,18 @@ Source5:    %{name}-pop3.pamd
 Source6:       %{name}.sysconfig
 Source7:       %{name}-pop3.sysconfig
 Source8:       %{name}-authdaemon.sysconfig
-# Patch0:              ftp://ftp.pld.org.pl/people/siefca/patches/courier/%{name}-myownquery.patch
 URL:           http://www.inter7.com/courierimap/
 BuildRequires: gdbm-devel
 BuildRequires: libstdc++-devel
-%{!?_without_mysql:BuildRequires:      mysql-devel}
-%{!?_without_ldap:BuildRequires:       openldap-devel}
-BuildRequires: openssl-devel >= 0.9.7
-%{!?_without_pgsql:BuildRequires:      postgresql-devel}
-%{!?_without_mysql:BuildRequires:      zlib-devel}
+%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: openssl-devel >= 0.9.7c
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+%{?with_mysql:BuildRequires:   zlib-devel}
 PreReq:                %{name}-common = %{version}
 PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
+Requires:      pam >= 0.77.3
 Provides:      imapdaemon
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     imapdaemon
@@ -106,6 +105,7 @@ Summary:    Courier-IMAP POP3 Server
 Summary(pl):   Serwer Courier-IMAP POP3
 Group:         Networking/Daemons
 PreReq:                %{name}-common = %{version}
+Requires:      pam >= 0.77.3
 Provides:      pop3daemon
 Obsoletes:     pop3daemon
 Conflicts:     cyrus-imapd
@@ -159,18 +159,17 @@ IMAP.
 
 %prep
 %setup -q
-#%patch0 -p1
 
 %build
 %configure \
        --enable-unicode \
        --with-authchangepwdir=/var/tmp \
        --with-authdaemonvar=/var/lib/authdaemon \
-       %{!?_without_mysql:--with-mysql-libs=%{_libdir} --with-mysql-includes=%{_includedir}/mysql} \
-       %{?_without_mysql:--without-authmysql} \
-       %{!?_without_pgsql:--with-pgsql-libs=%{_libdir} --with-pgsql-includes=%{_includedir}/postgresql} \
-       %{?_without_pgsql:--without-authpgsql} \
-       %{?_without_ldap:--without-authldap}
+       %{?with_mysql:--with-mysql-libs=%{_libdir} --with-mysql-includes=%{_includedir}/mysql} \
+       %{!?with_mysql:--without-authmysql} \
+       %{?with_pgsql:--with-pgsql-libs=%{_libdir} --with-pgsql-includes=%{_includedir}/postgresql} \
+       %{!?with_pgsql:--without-authpgsql} \
+       %{!?with_ldap:--without-authldap}
 
 %{__make}
 
@@ -224,9 +223,9 @@ echo ".so man7/authlib.7"   >$RPM_BUILD_ROOT%{_mandir}/man8/authuserdb.8
 echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authvchkpw.8
 echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemon.8
 echo ".so man7/authlib.7"      >$RPM_BUILD_ROOT%{_mandir}/man8/authdaemond.8
-%{!?_without_pgsql:echo ".so man7/authlib.7"   >$RPM_BUILD_ROOT%{_mandir}/man8/authpgsql.8}
-%{!?_without_mysql:echo ".so man7/authlib.7"   >$RPM_BUILD_ROOT%{_mandir}/man8/authmysql.8}
-%{!?_without_ldap:echo ".so man7/authlib.7"    >$RPM_BUILD_ROOT%{_mandir}/man8/authldap.8}
+%{?with_pgsql:echo ".so man7/authlib.7"        >$RPM_BUILD_ROOT%{_mandir}/man8/authpgsql.8}
+%{?with_mysql:echo ".so man7/authlib.7"        >$RPM_BUILD_ROOT%{_mandir}/man8/authmysql.8}
+%{?with_ldap:echo ".so man7/authlib.7" >$RPM_BUILD_ROOT%{_mandir}/man8/authldap.8}
 echo ".so makeuserdb.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/pw2userdb.8
 echo ".so makeuserdb.8"        >$RPM_BUILD_ROOT%{_mandir}/man8/vchkpw2userdb.8
 
@@ -272,7 +271,7 @@ fi
 
 %post pop3
 /sbin/chkconfig --add courier-pop3
-/sbin/chkconfig --del courier-imap-pop3 2>&1 >/dev/null
+/sbin/chkconfig --del courier-imap-pop3 >/dev/null 2>&1 || :
 if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
        /etc/rc.d/init.d/courier-imap-pop3 stop >&2
        /etc/rc.d/init.d/courier-pop3 start >&2
@@ -292,7 +291,7 @@ if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/courier-imap-pop3 ]; then
                /etc/rc.d/init.d/courier-imap-pop3 stop >&2
        fi
-       /sbin/chkconfig --del courier-imap-pop3 2>&1 >/dev/null
+       /sbin/chkconfig --del courier-imap-pop3 >/dev/null 2>&1 || :
        rm -f /etc/rc.d/init.d/courier-imap-pop3
 fi
 
@@ -371,6 +370,7 @@ fi
 %{_mandir}/man8/authp[aw]*
 %{_mandir}/man7/authlib*
 %{_mandir}/man1/couriert*
+%{_mandir}/man8/couriert*
 %{_mandir}/man8/mk*
 
 %files userdb
@@ -406,7 +406,7 @@ fi
 %{_sysconfdir}/pop3d.cnf
 %{_mandir}/man8/courierpop*
 
-%if %{?_without_ldap:0}%{!?_without_ldap:1}
+%if %{with ldap}
 %files authldap
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authldaprc
@@ -414,7 +414,7 @@ fi
 %{_mandir}/man8/authldap*
 %endif
 
-%if %{?_without_mysql:0}%{!?_without_mysql:1}
+%if %{with mysql}
 %files authmysql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authmysqlrc
@@ -422,7 +422,7 @@ fi
 %{_mandir}/man8/authmysql*
 %endif
 
-%if %{?_without_pgsql:0}%{!?_without_pgsql:1}
+%if %{with pgsql}
 %files authpgsql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/authpgsqlrc
This page took 0.063682 seconds and 4 git commands to generate.