]> git.pld-linux.org Git - packages/conserver.git/blobdiff - conserver.spec
- up to 8.1.16 by zagrodzki
[packages/conserver.git] / conserver.spec
index e202484f791333006085ba6c64cefdca9bcf8f1c..231e1c323f67661d9ca4ace37c39c860c1283fa1 100644 (file)
@@ -1,78 +1,95 @@
 # TODO: smart .init/.sysconfig, maybe a default configuration
 #
 Summary:       Console server
-Summary(pl):   Serwer konsoli
+Summary(pl.UTF-8):     Serwer konsoli
 Name:          conserver
-Version:       8.1.1
+Version:       8.1.16
 Release:       1
 License:       BSD-like
 Group:         Daemons
 Source0:       http://www.conserver.com/%{name}-%{version}.tar.gz
-# Source0-md5: d2641597713768cb62f09f1d94f95ef1
+# Source0-md5: 2364ba56f5201b07646bdfaefedd330b
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
+Source4:       %{name}.pam
+Patch0:                %{name}-locks.patch
 URL:           http://www.conserver.com/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: libwrap-devel
+BuildRequires: openssl-devel
+BuildRequires: pam-devel
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _sysconfdir     /etc/conserver
+
 %description
 Conserver is an application that allows multiple users to watch a
-serial console at the same time.  It can log the data, allows users
-to take write-access of a console (one at a time), and has a
-variety of bells and whistles to accentuate that basic
-functionality.
+serial console at the same time. It can log the data, allows users to
+take write-access of a console (one at a time), and has a variety of
+bells and whistles to accentuate that basic functionality.
 
-%description -l pl
-Conserver jest aplikacj±, która umo¿liwia kilku u¿ytkownikom naraz
-ogl±daæ logi na konsoli szeregowej. Mo¿e zapisywaæ zebrane dane,
-pozwalaæ u¿ytkownikom na pe³ne korzystanie z konsoli (ale tylko
-jednemu naraz), oraz posiada mnóstwo dodatków rozszerzaj±cych tê
-podstawow± funkcjonalno¶æ.
+%description -l pl.UTF-8
+Conserver jest aplikacją, która umożliwia kilku użytkownikom naraz
+oglądać logi na konsoli szeregowej. Może zapisywać zebrane dane,
+pozwalać użytkownikom na pełne korzystanie z konsoli (ale tylko
+jednemu naraz), oraz posiada mnóstwo dodatków rozszerzających tę
+podstawową funkcjonalność.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %configure \
-       --with-master=localhost
+       --with-master=localhost \
+       --with-port=782 \
+       --with-extmsgs \
+       --with-libwrap \
+       --with-openssl \
+       --with-pam
+#      --with-uds
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d} \
-       $RPM_BUILD_ROOT/var/log/{conserver.d,archiv/conserver.d}
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,conserver,pam.d} \
+       $RPM_BUILD_ROOT/var/log/{conserver.d,archive/conserver.d}
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 mv $RPM_BUILD_ROOT%{_datadir}/examples/conserver examples
+
+install examples/conserver.cf $RPM_BUILD_ROOT%{_sysconfdir}
+touch $RPM_BUILD_ROOT%{_sysconfdir}/conserver.passwd
+touch $RPM_BUILD_ROOT%{_sysconfdir}/console.cf
+
 rm -f examples/conserver.rc
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/conserver
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/conserver
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/conserver
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/conserver
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/chkconfig --add conserver
-if [ -f /var/lock/subsys/conserver ]; then
-        /etc/rc.d/init.d/conserver restart 1>&2
-else
-        echo "Run \"/etc/rc.d/init.d/conserver start\" to start conserver daemon."
-fi
+%service conserver restart "conserver daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/conserver ]; then
-                /etc/rc.d/init.d/conserver stop 1>&2
-        fi
-        /sbin/chkconfig --del conserver
+       %service conserver stop
+       /sbin/chkconfig --del conserver
 fi
 
 %files
@@ -81,8 +98,11 @@ fi
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
 %attr(754,root,root) /etc/rc.d/init.d/conserver
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/conserver
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
 %attr(750,root,root) %dir /var/log/conserver.d
-%attr(750,root,root) %dir /var/log/archiv/conserver.d
+%attr(750,root,root) %dir /var/log/archive/conserver.d
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
 %{_mandir}/man*/*
This page took 0.364652 seconds and 4 git commands to generate.