]> git.pld-linux.org Git - packages/composer.git/blobdiff - composer.spec
disable tests that require newer phpunit
[packages/composer.git] / composer.spec
index b78e22901f9d5afee2cf6b4e3e27f875762f9b35..c1fc1c72e502e6c6e7d6da761633283020caea5a 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_with    tests           # build with tests
+%bcond_without tests           # build with tests
 
 # NOTE
 # - release tarballs: http://getcomposer.org/download/
@@ -105,6 +105,15 @@ ln -s src/Composer/res
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
+# needs newer phpunit:
+# missing method PHPUnit_Framework_MockObject_Builder_InvocationMocker::willReturn()
+rm tests/Composer/Test/EventDispatcher/EventDispatcherTest.php
+rm tests/Composer/Test/IO/ConsoleIOTest.php
+rm tests/Composer/Test/Package/Loader/RootPackageLoaderTest.php
+rm tests/Composer/Test/Package/RootAliasPackageTest.php
+rm tests/Composer/Test/Package/Version/VersionGuesserTest.php
+rm tests/Composer/Test/Util/GitHubTest.php
+
 %build
 %if %{with tests}
 phpab -n -o src/bootstrap.php -e '*/Fixtures/*' src/ tests/
This page took 0.077173 seconds and 4 git commands to generate.