]> git.pld-linux.org Git - packages/coffee-script.git/blobdiff - coffee-script.spec
- up to 1.6.3
[packages/coffee-script.git] / coffee-script.spec
index dacb9171893bc83207463b8144512ebe106f62f9..d1963dd70653179a0ad1a51aae5c952f3cb6cc5f 100644 (file)
@@ -1,13 +1,15 @@
 %define                pkg     coffee-script
 Summary:       The CoffeeScript Compiler
 Name:          coffee-script
-Version:       1.6.2
+Version:       1.6.3
 Release:       1
 License:       MIT
 Group:         Development/Libraries
-URL:           http://jashkenas.github.com/coffee-script/
-Source0:       http://registry.npmjs.org/coffee-script/-/%{pkg}-%{version}.tgz
-# Source0-md5: 3fd785ef72ecb6b69cfa425a2d13e4fd
+URL:           http://coffeescript.org/
+Source0:       https://github.com/jashkenas/coffee-script/archive/%{version}.tar.gz
+# Source0-md5: 837fb08b97deb00c471101b9c3a5a107
+Patch0:                coffee-script-Cakefile.patch
+Patch1:                coffee-script-fix-importing-test.patch
 BuildRequires: rpmbuild(macros) >= 1.634
 BuildRequires: sed >= 4.0
 Requires:      nodejs >= 0.6
@@ -21,16 +23,23 @@ has always had a gorgeous object model at its heart. CoffeeScript is
 an attempt to expose the good parts of JavaScript in a simple way.
 
 %prep
-%setup -qc
-mv package/* .
+%setup -q
+%patch0 -p0
+%patch1 -p1
 
+%build
 %{__sed} -i -e '1s,^#!.*node,#!/usr/bin/node,' bin/*
 chmod a+rx bin/*
 
+./bin/cake build
+
+#also build the unminifed version
+MINIFY=false ./bin/cake build:browser
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
-cp -a bin lib $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
+cp -a bin lib package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
 
 install -d $RPM_BUILD_ROOT%{_bindir}
 ln -s %{nodejs_libdir}/%{pkg}/bin/cake $RPM_BUILD_ROOT%{_bindir}/cake.coffeescript
@@ -46,5 +55,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/coffee
 %dir %{nodejs_libdir}/%{pkg}
 %{nodejs_libdir}/%{pkg}/lib
+%{nodejs_libdir}/%{pkg}/package.json
 %dir %{nodejs_libdir}/%{pkg}/bin
 %attr(755,root,root) %{nodejs_libdir}/%{pkg}/bin/*
This page took 0.125524 seconds and 4 git commands to generate.